LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-21-2009, 04:15 AM   #1
Zeniff
LQ Newbie
 
Registered: Dec 2009
Posts: 10

Rep: Reputation: 0
Question Strange! Why can't acces fedoraproject.org and other problems? LiveCDs work fine~


Hi~ I've been having very strange problems on Firefox in Ubuntu 9.10 for a few weeks now.

I'll start with the strangest problem: I cannot access anything from http://fedoraproject.org/ and haven't been able to, except for a few minutes....once..... and it never came back. This was when these problems had already been happening and after several tries to reach Fedora's site.

Other problems are just as strange but not so bad or consistent: Pages sometimes seem to randomly not be found or they are found on the wrong server or something. After several minutes, though, they usually go away after refreshing the page.

One of the strange examples from the "not found" or error pages I got was when I tried reading Wikipedia.org and it told me it "could not be found on this server," but....the server and URL it listed were from Google.com! The address bar showed that it was trying to find the page on Google! No, I didn't copy and paste or type the address, I was in an already-working Wikipedia page that stopped working and thought it was on Google's servers! Isn't that weird? (I might have screenshots somewhere...)

Anyway, any ideas? I have tried creating new, empty profiles on Firefox, but they still cannot access Fedora's sites. LiveCDs work fine, though. Also, I copied and used a profile from my Laptop to here and it also cannot access it.

I even tried System > Administration > Network tools and tried Fedora's site in the Ping tab and it usually works just fine (sometimes it gets nothing, though).

Also, I'm not using wireless or dial-up.

By the way, I've only been using Linux a couple of months now, so sorry if I don't know stuff...

Thank you very much~!!! ^_^
 
Old 12-21-2009, 04:20 AM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,511

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
Which dns servers are you using ?
post the output from
Code:
cat /etc/resolv.conf
 
1 members found this post helpful.
Old 12-21-2009, 04:31 AM   #3
Zeniff
LQ Newbie
 
Registered: Dec 2009
Posts: 10

Original Poster
Rep: Reputation: 0
O_O Wow! That was quick! Until now, the fastest reply I ever got for my posts was about half a week...Thanks!

Here's what your command showed me:
Code:
cat /etc/resolv.conf
# Generated by NetworkManager
domain domain.actdsltmp
search domain.actdsltmp
nameserver 192.168.0.1
nameserver 205.171.3.25
 
Old 12-21-2009, 04:34 AM   #4
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,511

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
try to remove
Quote:
domain domain.actdsltmp
search domain.actdsltmp
and comment out
Quote:
nameserver 192.168.0.1
 
Old 12-21-2009, 05:15 AM   #5
Zeniff
LQ Newbie
 
Registered: Dec 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Wow~ I'm surprised and confused...

I did like you said and removed and commented out those lines.

I opened a new tab and fedoraproject.org loaded right away! O_O

But...then I tried to see if it was really that, or just similar to the one other time it worked for me, so I closed Firefox and made Network Manager turn off my Internet... Firefox didn't close right or something, so I forced it. I opened again in a different Firefox profile and it worked (maybe I did that before turning off Internet..)

I tried the original profile and it didn't work anymore...

I found out that it puts back the stuff in the resolv.conf file everytime I connect.

But, now that I know that... it doesn't seem to ever get fedoraproject.org back like the first time I tried it... I've tried several times now, and even while those lines are gone and commented out, it's not working... However, it seems to work in the other profile...confusing...

Any ideas why it worked the first time but not again in one profile, but everytime in another? And, would I have to redo this every time I connect online?

Thanks so much so far! ^^

Last edited by Zeniff; 12-21-2009 at 05:17 AM. Reason: forgot something
 
Old 12-21-2009, 05:20 AM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,511

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
Quote:
Any ideas why it worked the first time but not again in one profile, but everytime in another? And, would I have to redo this every time I connect online?
You need to make the changes in the configuration from networkmanager.
then restart the connection in networkmanager
 
Old 12-21-2009, 05:26 AM   #7
Zeniff
LQ Newbie
 
Registered: Dec 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Okay, I'll try that.

Also, before your reply just now, I got more confused because:

Now fedoraproject.org works again (at least since I last posted) since I refreshed it after it timed out a few minutes ago.

I'm confused why it works now but not before.... does it need some time to work? Or random? The first time I changed resolv.conf and went to the site right away and it worked...hmmm...

I guess I'm fine if it just needs some time for the change to work, but why are those lines in my resolv.conf in the first place? I've never changed Firefox and only installed Ubuntu here last month... Could it be that something happened when Ubuntu let me choose to migrate my Windows XP and browser settings when it installed?

Last edited by Zeniff; 12-21-2009 at 05:31 AM. Reason: Accidentally posted while other user repo was, so I fixed mine.
 
Old 12-21-2009, 05:30 AM   #8
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,511

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
resolv.conf is needed to do the DNS lookup (name to IP)
You probably have set a domainname when you installed ubuntu ( domain.actdsltmp )
Did you made the changes in networkmanager?
 
Old 12-21-2009, 05:52 AM   #9
Zeniff
LQ Newbie
 
Registered: Dec 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Sorry, I can't seem to find any settings that show any domains or those IP addresses I tried to find them in nm-connection-editor (which I also got to from nm-applet) and in gconf-editor. I know I must be looking in the wrong place, but can't find anything else that seems related to Network Manager.

Hmm...I never knowingly chose a domain name. As far as I know, it only gave me the option of a machine name when I installed, which I gave a different name. I feel pretty sure about it, since I installed Fedora in multi-boot with it and it asked for both a domain name and machine name which confused me at the time (so I left it at default localdomain I think). Oh, I had the problem before installing Fedora, though, and Fedora seems fine. Should I try changing Ubuntu's domain name too?

Oh, I just remembered, I saw the hostname and dnsdomainname commands once, so I just now tried
Code:
dnsdomainname -d
But, it returns nothing.

Last edited by Zeniff; 12-21-2009 at 05:54 AM. Reason: Added end stuff.
 
Old 12-21-2009, 05:58 AM   #10
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,511

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
try

edit /etc/dhcp3/dhclient.conf
put a # before the line containing
Code:
supersede domain-name
remove the # before the line
Code:
#prepend domain-name-servers
make it look like
Code:
prepend domain-name-servers 205.171.3.25

If you use dhcp, it is possible the info is provided by the router

Last edited by repo; 12-21-2009 at 06:00 AM.
 
Old 12-21-2009, 07:47 AM   #11
Zeniff
LQ Newbie
 
Registered: Dec 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Okay, I installed Opera browser and checked cat /etc/resolv.conf to make sure it said what it originally did when things weren't working... but it seemed to get to fedoraproject.org just fine...I then rebooted and they are both having trouble. Good, that's what I was hoping for, right? :P But, after posting this reply several minutes after they both had been trying to reach the site, I expected Opera to have given up like Firefox, but instead it seems to have actually got part of the site and is still slowly trying for the rest...O_O Is that something that is useful info to figure out this problem?

Also, what you just said about DHCP, I saw that mentioned in Network Manager's nm-connection-editor, I think... I guess that's what it was? Sorry I was confused before. I guess I didn't see the resolv.conf stuff there because it says mine is set to Automatic DHCP in the Method for the IPv4 Settings tab. I also see empty, disabled "DNS servers" and "Search domains" which I guess are filled in automatically and put into resolv.conf?

Anyway, I guess that means that's where I should do your original suggestion of changes, but since it's automatic, I don't really know what I should change to what? O-O?? Or should just go ahead and do your last suggestion and try editing /etc/dhcp3/dhclient.conf ?

Last edited by Zeniff; 12-21-2009 at 08:37 AM. Reason: Rebooted and found out I was wrong about something. And also found Opera can kind of finally find Fedora.
 
Old 12-21-2009, 08:55 AM   #12
Zeniff
LQ Newbie
 
Registered: Dec 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Gee, this is weird... after my last reply just now, I had left Opera on after it finally got to Fedora. Now, both Opera and Firefox seem to be able to load any fedoraproject.org page like normal! Did Opera's eventual success kickstart both of them to start working?? O_o I guess I should really learn networking stuff, because that's strange to me.

(It's working even though resolv.conf currently contains the lines originally suggested to take out, since I left them in to try Opera.)

...after several minutes of not loading any fedoraproject.org pages, though, it stops being able to again...

Last edited by Zeniff; 12-21-2009 at 09:13 AM. Reason: ...Opera's kickstarting dies after a while.
 
Old 12-21-2009, 10:52 AM   #13
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,511

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
Did you made the changes in
/etc/dhcp3/dhclient.conf ?

Also look in the preferences from the browser, and see if you use any proxy.
Set it to
Quote:
no proxy
 
Old 12-28-2009, 09:00 AM   #14
Zeniff
LQ Newbie
 
Registered: Dec 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Okay, I have just now edited /etc/dhcp3/dhclient.conf

There was already a # before supersede domain-name, so I left it as it was.

I removed the # and changed the number at the end to make
Code:
prepend domain-name-servers 205.171.3.25;
I assume I should leave the semi-colon there too?

Also, my Firefox was set to "Use system proxy settings," so I now changed it to "no proxy" like you said.
I wondered what my system proxy settings were, so I went to System > Preferences > Network Proxy (gnome-network-properties) and its Proxy Configuration tab has the "Direct internet connection" radio option selected.

Okay, now I'll save the changes and hope that it will all work. I'll have to test later when I come back home, though, but I'll post back here when I do.

Thanks again!
(Also, sorry about the delay in replying. I often don't have useful access to my PC for days at a time.)
 
  


Reply

Tags
firefox, internet, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum Prob: Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mirrorlist?r vikram_cvk Linux - Server 4 10-05-2010 01:25 PM
i want to download fedora 10 but in fedoraproject.org is not working properly ravitejatr Linux - Newbie 4 12-21-2009 04:35 AM
quota works fine with a strange message... jeanpba Linux - Distributions 1 05-02-2006 03:14 PM
unable to free acces lib.homelinux.org schrodinger_katze LinuxQuestions.org Member Intro 1 01-17-2006 05:04 PM
Connection setup problems (need refresh for each new domain name, used to work fine) lanthern Linux - Networking 5 06-21-2004 10:35 PM


All times are GMT -5. The time now is 08:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration