LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Strange Delay when Accessing Internet Resources (http://www.linuxquestions.org/questions/linux-networking-3/strange-delay-when-accessing-internet-resources-468267/)

RAdams 07-27-2006 11:29 AM

Strange Delay when Resolving Domain Names ALMOST FIXED!
 
My work computer is connected via LAN cable directly to a router --> bridge --> cable modem setup on our small network. When I boot from Winblows, everything works as expected. However, on this Ubuntu installation, I'm getting a strange 3-10 second delay whenever I access an Internet resource, such as linuxquestions.org in my browser, or searching a repository, or pinging an external address. Now here's three weird points:
  1. I don't see this delay in Winblows on the same machine.
  2. Pinging google.com returns normal times for this connection (~30ms), but theres a longer than normal delay to begin pinging and return the results of each ping.
  3. Intranet resources work as fast as I expect them to.

What am I missing?

EDIT:
I discovered the root of the problem. It isn't in the accessing of the resources, but rather the resolution of the domain names. If I use my browser and go to google.com, there's about a 10 second delay. If I type in one of their IPs directly, it resolves instantly. So the problem is that Ubuntu is having trouble resolving domain names to IP addresses in a timely manner. I know how to fix this problem in Windows, but not Linux. How is this done?

peter_robb 07-30-2006 03:50 PM

I have seen some systems send ident probes out on tcp port 135 before connecting to services.. Coz they're never answered, it creates a 3-5 sec delay..

Make an iptables LOG rule to check,eg
iptables -t nat -I POSTROUTING -o eth0 -p tcp --dport 135 -j LOG --log-prefix "ident "

If there are, make a rule to reject them, eg
iptables -I OUTPUT -p tcp --dport 135 -j REJECT --reject-with tcp-reset

RAdams 08-14-2006 02:22 PM

Quote:

Originally Posted by peter_robb
I have seen some systems send ident probes out on tcp port 135 before connecting to services.. Coz they're never answered, it creates a 3-5 sec delay..

Make an iptables LOG rule to check,eg
iptables -t nat -I POSTROUTING -o eth0 -p tcp --dport 135 -j LOG --log-prefix "ident "

If there are, make a rule to reject them, eg
iptables -I OUTPUT -p tcp --dport 135 -j REJECT --reject-with tcp-reset

I wasn't sure how to check the log I created with your first command, so I just tried making the rule. Unfortunatlely, I'm still experiencing a delay... If anything, it's slightly longer.

RAdams 08-17-2006 12:32 AM

Not to be a thread-bumper, but does anyone have any ideas as to what to try next?

RAdams 08-28-2006 09:38 AM

Only because this thread has been placed rather high on google when using the terms ubuntu domain names delay, I thought I'd take the time to link to the solution to this problem, in case someone else faces this issue in the future:

Code:

sudo gedit /etc/modprobe.d/bad_list
Add the following to the document that opens (it will likely be empty):
Code:

# Added to disable IPV6
alias net-pf-10 off

Then go to http://ubuntu.wordpress.com/2006/08/...ster-browsing/ and follow the instructions there. I recommend that step even if you ARE using ipv6 protocols on your network.


All times are GMT -5. The time now is 10:01 AM.