LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 09-07-2005, 03:26 PM   #1
4mix
LQ Newbie
 
Registered: Jul 2004
Distribution: Debian 2.4.18
Posts: 19

Rep: Reputation: 0
Strange client IP change on a VPN connection(pptp - poptop).txt


I installed a pptpd (poptop) server on a Debian system only for authenticating the users from my network to the server, to provide internet access to them.

At first the VPN connections seems to work fine, also the Internet access through it.

I tested the VPN on a Windows XP client, and from time to time I see that the Internet connections stops. When I look at the connection status I observe that the IP of the client had changed in the IP of the server. If I close the connection and then connect again to the VPN, everything goes back to normal.

The second problem is that I can enter into the VPN with any user and any password, although in chap-secrets file there are passwords set for the users.

A suggestion to help me out in this situation would be wellcome

Thank you in advance!

My settings are:

# cat pptpd.conf

#ppp /usr/sbin/pppd
option /etc/ppp/pptpd-options
debug
# stimeout 10
#noipparam
logwtmp
#bcrelay eth1
localip 10.168.109.1
remoteip 10.168.109.1-255
----------------------------
#cat pptpd-options

name pptpd
# domain mydomain.net
#chapms-strip-domain
refuse-pap
#refuse-chap
refuse-mschap
#require-mschap-v2
#require-mppe-128
ms-dns 125.125.125.125
proxyarp
nodefaultroute
debug
dump
lock
nobsdcomp
--------------------------
On the Windows client in the Security tab of the connection settings I dissabled the "required data encription"checkbox.
--------------------------
#cat chap-secrets

lalala pptpd kuf4!Ryc *
lalalalala pptpd dafdanfr1fsfPfadel *
lalalalalaal pptpd Kefsfsdhrda9fss,Lsdfaz *

Debian Sarge - stable, kernel 2.6.10, Poptop v1.2.1
 
Old 09-16-2005, 11:45 AM   #2
4mix
LQ Newbie
 
Registered: Jul 2004
Distribution: Debian 2.4.18
Posts: 19

Original Poster
Rep: Reputation: 0
With help from a good soul I found where I was wrong:


To force auhtentication it should be enabled require-mschap-v2 in /etc/ppp/pptp-options file

For the problems with the IP the remoteip line should be erased(disabled) in /etc/ppp/pptp-options file, and activated noipparam in /etc/pptpd.conf file

To force the users to have specified IPs in the VPN, those IPs should be set in the /etc/ppp/chap-secrets file:
nick pptpd password 10.168.109.220

Kind regards !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pptp poptop VPN +port omid1979 Linux - Networking 0 06-11-2005 09:29 AM
Problem with installation of a VPN - PPTP client l2g Linux - Networking 1 12-24-2004 02:37 AM
Routing issue with VPN Client into PPP/Poptop loopy69 Linux - Networking 1 10-07-2004 09:48 AM
Winxp Client Connet To Vpn (poptop) Not Working Probably ronaldlee Linux - Networking 13 08-31-2004 04:11 AM
use of pptp client to access vpn krish87 Linux - Networking 0 08-20-2004 02:32 PM


All times are GMT -5. The time now is 03:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration