LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Strange client IP change on a VPN connection(pptp - poptop).txt (http://www.linuxquestions.org/questions/linux-networking-3/strange-client-ip-change-on-a-vpn-connection-pptp-poptop-txt-361158/)

4mix 09-07-2005 02:26 PM

Strange client IP change on a VPN connection(pptp - poptop).txt
 
I installed a pptpd (poptop) server on a Debian system only for authenticating the users from my network to the server, to provide internet access to them.

At first the VPN connections seems to work fine, also the Internet access through it.

I tested the VPN on a Windows XP client, and from time to time I see that the Internet connections stops. When I look at the connection status I observe that the IP of the client had changed in the IP of the server. If I close the connection and then connect again to the VPN, everything goes back to normal.

The second problem is that I can enter into the VPN with any user and any password, although in chap-secrets file there are passwords set for the users.

A suggestion to help me out in this situation would be wellcome

Thank you in advance!

My settings are:

# cat pptpd.conf

#ppp /usr/sbin/pppd
option /etc/ppp/pptpd-options
debug
# stimeout 10
#noipparam
logwtmp
#bcrelay eth1
localip 10.168.109.1
remoteip 10.168.109.1-255
----------------------------
#cat pptpd-options

name pptpd
# domain mydomain.net
#chapms-strip-domain
refuse-pap
#refuse-chap
refuse-mschap
#require-mschap-v2
#require-mppe-128
ms-dns 125.125.125.125
proxyarp
nodefaultroute
debug
dump
lock
nobsdcomp
--------------------------
On the Windows client in the Security tab of the connection settings I dissabled the "required data encription"checkbox.
--------------------------
#cat chap-secrets

lalala pptpd kuf4!Ryc *
lalalalala pptpd dafdanfr1fsfPfadel *
lalalalalaal pptpd Kefsfsdhrda9fss,Lsdfaz *

Debian Sarge - stable, kernel 2.6.10, Poptop v1.2.1

4mix 09-16-2005 10:45 AM

With help from a good soul I found where I was wrong:


To force auhtentication it should be enabled require-mschap-v2 in /etc/ppp/pptp-options file

For the problems with the IP the remoteip line should be erased(disabled) in /etc/ppp/pptp-options file, and activated noipparam in /etc/pptpd.conf file

To force the users to have specified IPs in the VPN, those IPs should be set in the /etc/ppp/chap-secrets file:
nick pptpd password 10.168.109.220

Kind regards !


All times are GMT -5. The time now is 06:20 AM.