LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-18-2008, 04:33 PM   #16
figure002
Member
 
Registered: Nov 2008
Distribution: Ubuntu Maverick
Posts: 31

Original Poster
Rep: Reputation: 16

Quote:
Originally Posted by billymayday View Post
When you open up Network Settings from yast, there's a routing tab on the RHS.

You need to add 192.161.1.1 as the default gateway.
Everything under the routing tab is disabled. The button for Add is disabled too. And the dropdown menu for Standard Gateway is empty. So I can't change anything there..

EDIT: Turns out I could just enter the gateway IP (192.168.1.1) in the empty list, but internet still didn't work after that.

Last edited by figure002; 11-18-2008 at 04:40 PM.
 
Old 11-18-2008, 04:37 PM   #17
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Are you running yast as root?

Try firing it up from a root terminal session (just type yast2 at the command line)

Last edited by billymayday; 11-18-2008 at 04:51 PM.
 
Old 11-18-2008, 04:44 PM   #18
figure002
Member
 
Registered: Nov 2008
Distribution: Ubuntu Maverick
Posts: 31

Original Poster
Rep: Reputation: 16
Yes, I'm running Yast as root, because I have to enter my root password everytime I run Yast. I also fired up Yast from a root terminal session, but there was no difference.
 
Old 11-18-2008, 04:53 PM   #19
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Something is awry then.

Either you have entered something wrong that is causing this or yast is on strike. I can change it here OK.

You are using "Network Settings" from the "Network Devices" tab?
 
Old 11-18-2008, 05:00 PM   #20
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You can always add the route manually. Not sure if it will persist in SuSe

Quote:
route add default gw 192.168.1.1
 
Old 11-18-2008, 06:29 PM   #21
The_Nerd
Member
 
Registered: Aug 2002
Distribution: Debian
Posts: 540

Rep: Reputation: 32
I had a similar problem to what you are experiencing just today. It turned out to be a IP conflict between the two devices in my computer. For some reason, when I changed one devices IP address (eth0) it would change the other one's as well to the same thing. Even though the second network device (eth1) was disabled, this caused a conflict. Maybe try removing your wireless completely? Disable it in the bios?
 
Old 11-18-2008, 06:32 PM   #22
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Except it seems pretty clear it's a routing problem since there is no default gateway.

Were you experiencing a routing issue or just IP conflict?
 
Old 11-18-2008, 10:20 PM   #23
The_Nerd
Member
 
Registered: Aug 2002
Distribution: Debian
Posts: 540

Rep: Reputation: 32
Quote:
Originally Posted by billymayday View Post
Except it seems pretty clear it's a routing problem since there is no default gateway.

Were you experiencing a routing issue or just IP conflict?
Yes, however it was the same for me today. It seamed like a routing problem at first, because sometimes I could ping the router/the 'net (google), and suddenly it would stop. I am just saying it might be possible...
 
Old 11-19-2008, 08:03 AM   #24
figure002
Member
 
Registered: Nov 2008
Distribution: Ubuntu Maverick
Posts: 31

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by billymayday View Post
You are using "Network Settings" from the "Network Devices" tab?
I use the Network Settings in Yast, and then use the second tab to change the eth0 device to static IP. I used the third tab to set 'Nameserver 1' to 192.168.1.1 and Domainname to 'site'. And most options in the fourth tab (Routing) are disabled, except for the Default Gateway menu, which is an empty menu.

Quote:
Originally Posted by billymayday View Post
You can always add the route manually. Not sure if it will persist in SuSe
route add default gw 192.168.1.1
I tried that before, but it didn't work. After that command I still couldn't load any webpages.


Quote:
Originally Posted by The_Nerd View Post
I had a similar problem to what you are experiencing just today. It turned out to be a IP conflict between the two devices in my computer. For some reason, when I changed one devices IP address (eth0) it would change the other one's as well to the same thing. Even though the second network device (eth1) was disabled, this caused a conflict. Maybe try removing your wireless completely? Disable it in the bios?
So when you would do ifconfig, both eth0 and wlan would have the same IP? That isn't the case with me, as you can see from my previous posts. My wlan has a different IP than eth0. Also I didn't get an IP conflict.
 
Old 11-19-2008, 08:20 AM   #25
heloma
LQ Newbie
 
Registered: Jun 2006
Posts: 4

Rep: Reputation: 0
This is definitly a routing issue, you need to add a static route (default gateway):
as root #route add default gw 192.168.1.1

If you are using Linksys, you will need also to clear your routing table.

good luck.


heloma
 
Old 11-19-2008, 08:21 AM   #26
DotHQ
Member
 
Registered: Mar 2006
Location: Ohio, USA
Distribution: Red Hat, Fedora, Knoppix,
Posts: 542

Rep: Reputation: 33
Reading through this one thing does not make sense to me. In post 11 you posted the stats with dhcp off. In the ifconfig I see:
Quote:
RX packets:6486 errors:0 dropped:0 overruns:0 frame:0
TX packets:6335 errors:0 dropped:0 overruns:0 carrier:0
Whenever I've seen my ifconfig show that I'm transmitting and receiving packets, that's a good thing. But here you are indeed transmitting and receiving but have no connetion.

Are you restarting networking after you make these changes?

service network restart works on my distros ...

Last edited by DotHQ; 11-19-2008 at 08:24 AM.
 
Old 11-19-2008, 09:41 AM   #27
figure002
Member
 
Registered: Nov 2008
Distribution: Ubuntu Maverick
Posts: 31

Original Poster
Rep: Reputation: 16
I finally got it to work.

First I tried the following commands as root:
# route add default gw 192.168.1.1
followed by
# service network restart

But this only worked half. Skype would then work, but i could not ping to google.com or visit websites.

So I took another look at billymayday's advice. He told me to set the Default Gateway to '192.168.1.1' in the Routing tab in the Network Settings. When I tried this earlier, another option (Actualize DNS-data through DHCP) under the DNS tab was enabled. This time I disabled it and manually entered '192.168.1.1' for 'Namespace 1'. This in combination with the Default Gateway set to 192.168.1.1, does work I hope this works for other people also.

Thanks a lot for your help guys!
 
Old 11-19-2008, 02:45 PM   #28
heloma
LQ Newbie
 
Registered: Jun 2006
Posts: 4

Rep: Reputation: 0
You need to add external dns servers to your hostfile,

add the following lines to /etc/resolv.conf
nameserver 4.2.2.2
nameserver 142.77.1.1



that's it !
 
  


Reply

Tags
dhcp, ip, private, static


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH with passwordless public/private key not working on another account on server infocom Linux - Server 14 12-27-2010 05:09 AM
Samba not working as intended. Private / Public share's ILikeVoltron Linux - Networking 3 03-14-2006 04:22 PM
static ip in a private lan master Linux - Networking 12 02-19-2006 10:39 PM
Making static symbols private/local in shared libraries skoona Programming 1 02-18-2005 03:14 PM
Working with SSH and multiple private keys IgD Linux - Security 2 09-08-2003 10:07 PM


All times are GMT -5. The time now is 10:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration