LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-13-2004, 01:33 PM   #1
baunemann
LQ Newbie
 
Registered: Mar 2004
Posts: 2

Rep: Reputation: 0
Starting FTP Daemon


I havejsut installed Red Hat Linux Advanced Server. I am currently trying to get an FTP session between Linux and a Windows XP machine.
Currently this is not possible, and a grep of a ps -aux does not indicate
the presence of a FTP daemon. Additionally, netstat shows that the system is not listening on port 21 which I believe is reserved for FTP.
I can get the FTP prompt on the Linux box and Telnet is working ok between the two machines. In the directory /etc/inet.d, the file vsftpd has
the following settings:

disable = no
socket_type = stream
wait = no
user = root
server = /usr/bin/vsftpd
nice = 10

Could anyone suggest how to start off the FTP service ?

Many Thanks
Bau.
 
Old 03-13-2004, 02:07 PM   #2
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
run the binary from where ever you put it, e.g.,

# /usr/local/sbin/vsftpd &

more info:
ftp://vsftpd.beasts.org/users/cevans...-1.2.1/INSTALL
 
Old 03-13-2004, 03:32 PM   #3
tuxguy
Member
 
Registered: Mar 2004
Location: North Bay, Ontario - CANADA
Distribution: Debian
Posts: 77

Rep: Reputation: 15
a good way to test if your linux box is runing a service on a port is to from the command line....

telnet localhost 21 <---port number that the daemon is listening on.
 
Old 03-13-2004, 06:20 PM   #4
baunemann
LQ Newbie
 
Registered: Mar 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks for the suggestions -

I tried the command /usr/local/sbin/vsftpd &
it fails - seems that /usr/local/sbin is empty.. ? any ideas guys..

regards

Bau
 
Old 03-14-2004, 10:07 AM   #5
hob
Senior Member
 
Registered: Mar 2004
Location: Wales, UK
Distribution: Debian, Ubuntu
Posts: 1,075

Rep: Reputation: 45
Not at a Red Hat box ATM, but:

/usr/local is for manually compiled software, and you're probably using the supplied package. The config. snippet you've posted suggests that xinetd is looking for /usr/bin/vsftpd.

From memory, because vsftpd is managed by xinetd, the TCP port is controlled by xinetd, which only loads the vsftpd program when needed - so the vsftpd process isn't often running. If netstat says nothing is listening on the port you need to look at xinetd. I think that you also need to restart xinetd after changing settings in the files in xinetd.d for the changes to take effect.

Last edited by hob; 03-14-2004 at 10:09 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
still cant get nmb daemon starting eroica Linux - Networking 1 12-02-2004 08:42 PM
Starting daemon at boot up Buto Slackware 2 09-07-2004 08:44 PM
Howto stop daemon from starting Lawful Linux - General 3 04-30-2004 04:06 PM
Starting Up MySQL daemon tuka Linux - Software 2 08-06-2003 11:45 AM
Starting daemon during boot up chuck77 Linux - General 3 03-27-2002 06:47 AM


All times are GMT -5. The time now is 04:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration