LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-16-2006, 03:33 PM   #1
trashbird1240
Member
 
Registered: Sep 2006
Location: Durham, NC
Distribution: Slackware, Ubuntu (yes, both)
Posts: 463

Rep: Reputation: 31
sshd: connections times out with putty


Howdy there,

I have set up sshd (OpenSSH) in both PCLinuxOS using the PCLInuxOS Control Center and in Slackware 11.0. I have a domain name from Dynamic DNS (www.dyndns.com) and computer names set up on both installations.

I can log in to each from the machine itself, for example:

ssh joel@xxx.xxx.com

and I connect successfully. Of course, I check /var/log/messages and it says the connection is coming from 127.0.0.1 (because it is).

Now, I have not set up any RSA keys or anything like that -- all the tutorials I've found sound rather contradictory -- it seems like I'd have to connect in order to set up the keys, but I can't connect without setting up public/private keys. Please tell me I'm wrong about this.

Also, I have not added "AllowUsers" or "AllowGroups" or any other camel-cased options in the configuration file: I have not edited the configuration files at all.

The problem is that when I've tried to ssh in using PuTTY on two separate Win$uck machines and ssh from the command line in OS X, I get time-outs.

Is anyone aware of tutorial for a server-newbie?

Thanks,
Joel
 
Old 12-16-2006, 03:34 PM   #2
trashbird1240
Member
 
Registered: Sep 2006
Location: Durham, NC
Distribution: Slackware, Ubuntu (yes, both)
Posts: 463

Original Poster
Rep: Reputation: 31
Oh, one more critical piece of information: I'm behind a router -- sharing a connection with the landlord upstairs (with his permission, of course).

Thanks,
Joel
 
Old 12-16-2006, 04:26 PM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,386

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
well you don't say where you're sshing in from, but i'd assume you mean elsewhere on the internet? you need to use portforwarding on the router you are getting your connectivity through, as the ip address being pointed at is the router, not your actual PC, so the router needs to know where to redirect the connection attempts to when it recieves them. http://www.portforward.com is a great site for that sort of configuration info.
 
Old 12-16-2006, 08:18 PM   #4
trashbird1240
Member
 
Registered: Sep 2006
Location: Durham, NC
Distribution: Slackware, Ubuntu (yes, both)
Posts: 463

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by acid_kewpie
well you don't say where you're sshing in from, but i'd assume you mean elsewhere on the internet? you need to use portforwarding on the router you are getting your connectivity through, as the ip address being pointed at is the router, not your actual PC, so the router needs to know where to redirect the connection attempts to when it recieves them. http://www.portforward.com is a great site for that sort of configuration info.
Mr. Kewpie,

Yes, by saying "two other...machines and the command line in OS X" I mean from elsewhere on the internet (my office, to be specific).

The router is out of my jurisdiction -- it belongs to my landlord. Am I screwed for ssh from home?

Thanks,
Joel
 
Old 12-16-2006, 09:59 PM   #5
xjlittle
Member
 
Registered: Aug 2003
Location: Indiana
Distribution: fc6 sles9 & 10 kubuntu ubuntu-server
Posts: 240
Blog Entries: 2

Rep: Reputation: 30
Quite possibly you are if the landlord won't forward the port for you. Occassionally routers are not set to block unprivileged ports. Try setting the ssh server to port 23000 or something equally high and ssh'ing using that port number.
 
Old 12-17-2006, 03:10 AM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,386

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
that isn't going to help i'm afraid, you still need to port forward from the router to the machine, no where near caring about port numbers yet...

so no, unless you can get the router configured, you can not reach your machine from the internet. there is the possibility of a reverse ssh tunnel, where you connect out from your machine to an external endpoint and then connect to that machine, but that's much mor difficult and restrictive.
 
  


Reply

Tags
openssh, putty, sshd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Putty timout - restart sshd zdenisl Linux - Software 2 10-22-2006 10:43 PM
System hangs; Atheros Madwifi-ping times out every 15/16 times james 456 Linux - Networking 0 01-12-2006 06:55 PM
FC4-Starting sshd: Privilege separation user sshd does not exist FAILED kiranherekar Fedora 5 12-29-2005 02:22 PM
sshd restrict connections introuble Linux - Security 1 07-01-2005 07:57 AM
sshd + putty .. pausing on logon dunkyb Linux - General 4 12-31-2002 04:12 AM


All times are GMT -5. The time now is 07:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration