LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   ssh - How to enable this in suse linux 10 (http://www.linuxquestions.org/questions/linux-networking-3/ssh-how-to-enable-this-in-suse-linux-10-a-474737/)

rust8y 08-17-2006 08:14 AM

ssh - How to enable this in suse linux 10
 
I'm running suse linux 10. ssh was not enabled in the installation. How can I enable ssh?

fatra2 08-17-2006 08:30 AM

Hi there,

Of course need to have ssh install on you system!!!

You can turn on the service "sshd" in the "system-config-services". You should have access to all the service running on your system. You need to enable the sshd service.

Cheers

kstan 08-17-2006 09:14 AM

yast->system -> system services-->sshd--> enable

xtremeclones 08-17-2006 03:03 PM

the way i do it if its already installed on the system

service sshd start

that does it for me

rust8y 08-17-2006 06:37 PM

yast->system -> system services-->sshd--> enable

Done, thanks.

But when I use putty to ssh, I'm getting Access Denied.

KenJackson 08-17-2006 09:37 PM

Do you have a directory named ".ssh" in each home directory with some files in it? If not, run this as a regular user:

ssh-keygen

You should copy the ~/.ssh/*.pub files on each PC to the other PC into file ~/.ssh/authorized_keys. The .pub files are not secret, so you can copy them by ftp or a public directory or whatever. Each .pub file is one very long line, and the authorized_keys file has nothing else but these very long lines.

If you change something after you've logged in once, the entry in ~/.ssh/known_hosts on the othe PC may prevent you from logging again. So if in doubt, delete the known_hosts files and allow them to be regenerated.

To login by password, you must not have "PasswordAuthentication no" in either /etc/ssh/sshd_config or /etc/ssh/ssh_config.

kstan 08-18-2006 07:40 AM

by default i think won't be so much job to do, can you tell us how you login?


All times are GMT -5. The time now is 05:49 AM.