LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 05-24-2009, 03:38 PM   #1
1veedo
Member
 
Registered: Dec 2004
Location: WV, USA
Distribution: Gentoo, Debian
Posts: 186

Rep: Reputation: 34
ssh -D "channel 6: open failed: administratively prohibited: open failed"


I'm getting these messages Over SSH with the -D switch
Code:
channel 6: open failed: administratively prohibited: open failed
channel 43: open failed: connect failed: Connection timed out
At uni I did this for a couple of reasons, primarily to connect to trackers for bittorrent. I would get these messages fairly often but I never thought much of it because I figured I was just loosing packets over the network or something (understandable in my situation). At home I decided to continue to use this method because that computer is set up in DMZ and is very useful. I havn't received many of these messages but recently all my torrents stalled and I had a whole bunch of these messages. Is it possible my computer just cant handle all the network connections (it's a 2ghz AMD running debian)?

What exactly do these messages mean? Is there any way to optimize my connection in any way?
 
Old 06-24-2009, 10:23 PM   #2
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 609

Rep: Reputation: 218Reputation: 218Reputation: 218
You need to set 'GatewayPorts' to 'yes' in your 'sshd_config' file.

Otherwise, you'll see lot of errors like the ones you are talking about.

Just make sure that these lines are in your sshd_config file:
Code:
AllowTcpForwarding yes
GatewayPorts       yes
If most of your traffic is working you most likely either already have the 'AllowTcpForwarding' option set properly, or it is unset. Yes is the default. 'GatewayPorts,' however, defaults to no.

Last edited by foodown; 06-24-2009 at 10:25 PM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh -L '>channel 3: open failed: connect failed:' Luke771 Linux - Networking 14 01-24-2012 04:14 AM
SSH Tunnelling problem. Channel 3: open failed: Administratively prohibited: icedewd Linux - Newbie 4 05-10-2009 12:15 AM
Help meee!!!...."FAILED TO OPEN SOUND DEVICE. bisanshah Linux - Laptop and Netbook 2 01-09-2007 10:27 PM
kismet "channel get ioctl failed...no such device" fatblueduck Linux - Software 0 01-03-2006 02:51 AM
SSH Tunnel not working... "Administratively Probihited..." nsanity Linux - Networking 3 01-03-2004 02:25 PM


All times are GMT -5. The time now is 04:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration