LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   squid not allowing streaming radio (http://www.linuxquestions.org/questions/linux-networking-3/squid-not-allowing-streaming-radio-853379/)

fukawi2 12-31-2010 12:45 AM

squid not allowing streaming radio
 
I have squid running on my home gateway, but when I try to listen to streaming radio, it doesn't work.

Using mplayer with a proxy shows this:
Code:

/home/fukawi2 $ mplayer http://media.on.net/radio/143.m3u
MPlayer SVN-r32492-4.5.1 (C) 2000-2010 MPlayer Team
159 audio & 349 video codecs
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing http://media.on.net/radio/143.m3u.
Resolving proxy.fukawi2.pvt for AF_INET...
Connecting to server proxy.fukawi2.pvt[192.168.31.1]: 3128...

Cache size set to 320 KBytes


Playing http://radio1.internode.on.net:8000/143.
Resolving proxy.fukawi2.pvt for AF_INET...
Connecting to server proxy.fukawi2.pvt[192.168.31.1]: 3128...

Cache size set to 320 KBytes
Cache fill:  0.00% (0 bytes) 

Cache not filling!
Cache not filling!
Cache not filling!
Cache not filling!
Cache not filling!

Cache not filling keeps repeating until ^C

squid logs the access as being allowed:
Quote:

1293774289.002 13826 192.168.31.20 TCP_MISS/200 198228 GET http://radio1.internode.on.net:8000/143 - DIRECT/192.231.203.146 -
If I unset the proxy and open a firewall hole, it works fine:
Code:

/home/fukawi2 $ http_proxy='' mplayer http://media.on.net/radio/143.m3u
MPlayer SVN-r32492-4.5.1 (C) 2000-2010 MPlayer Team
159 audio & 349 video codecs
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing http://media.on.net/radio/143.m3u.
Invalid proxy setting... Trying without proxy.
Resolving media.on.net for AF_INET...
Connecting to server media.on.net[203.26.94.250]: 80...

Cache size set to 320 KBytes


Playing http://radio1.internode.on.net:8000/143.
Invalid proxy setting... Trying without proxy.
Resolving radio1.internode.on.net for AF_INET...
Connecting to server radio1.internode.on.net[192.231.203.146]: 8000...

Name  : You are listening to NovaNation
Genre  : connect . discover . explore . dance
Website: http://www.novanation.com.au
Public : yes
Bitrate: 48kbit/s
Cache size set to 320 KBytes
Cache fill:  0.00% (0 bytes) 
ICY Info: StreamTitle='Duck Sauce - Anyway';StreamUrl='SongID=3826|SongTitle=Anyway|SongArtist=Duck Sauce|CartComplete=False|AlbumArt=407.jpg|SongHook=3826.mp3|Version=|MixedBy=|AdvertiserName=|AdComplete=';


AAC file format detected.
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
versionA not supported
versionA not supported
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:  6.3 (06.2) of 0.0 (unknown)  0.7% 56%


grzesiek 01-02-2011 12:23 PM

The Squid log not contain DENIED. Maybe firewall block its?

fukawi2 01-02-2011 05:25 PM

My firewall and proxy are on the same machine, so only OUTPUT could be blocking it. I tried setting the OUTPUT Policy to ACCEPT and flushing all rules but same result.
Quote:

tank ~ # iptables -P OUTPUT ACCEPT
tank ~ # iptables -F OUTPUT

markotitel 01-04-2011 03:56 AM

Squid config? post it

fukawi2 01-04-2011 04:51 AM

Whoops, of course....
Code:

tank ~ # uncomment /etc/squid/squid.conf
http_port 3128
cache_mem 20 MB
cache_dir ufs /srv/squid 16000 40 256
cache_swap_low 90
cache_swap_high 100
cache_replacement_policy heap LFUDA
memory_replacement_policy heap GDSF
maximum_object_size 60 MB
maximum_object_size_in_memory 20 KB
cache_store_log        none
access_log /var/log/squid/access.log squid
hierarchy_stoplist cgi-bin ?
acl QUERY urlpath_regex cgi-bin \?
no_cache deny QUERY
refresh_pattern ^ftp:          1440    20%    10080
refresh_pattern ^gopher:        1440    0%      1440
refresh_pattern .              0      20%    4320
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl Connect_ports port 443 563 4243 8887 10443 5557
acl Safe_ports port 80          # http
acl Safe_ports port 21          # ftp
acl Safe_ports port 443 563    # https, snews
acl Safe_ports port 70          # gopher
acl Safe_ports port 210        # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280        # http-mgmt
acl Safe_ports port 488        # gss-http
acl Safe_ports port 591        # filemaker
acl Safe_ports port 777        # multiling http
acl CONNECT method CONNECT
acl POST method POST
acl PURGE method PURGE
acl FTP proto ftp
forwarded_for off
header_access X-Forwarded-For deny all
acl ierestrict browser MSIE
acl ieoksites dstdomain .firefox.com
acl ieoksites dstdomain .mozilla.com
acl ieoksites dstdomain .mozilla.org
acl ieoksites dstdomain psi.secunia.com
acl ieokdsts dst 85.17.154.24
acl safe_source src 192.168.0.0/16
acl safe_source src 172.16.0.0/12
acl safe_source src 10.0.0.0/8
http_access allow manager localhost
http_access deny manager
http_access allow PURGE localhost
http_access deny PURGE
http_access deny CONNECT !Connect_ports
http_access allow localhost
http_access deny !safe_source
http_access allow ierestrict ieoksites
http_access allow ierestrict ieokdsts
http_access deny ierestrict
http_access allow all
http_access deny all
http_reply_access allow all
icp_access allow all
visible_hostname tank.fukawi2.pvt


fukawi2 01-27-2011 05:45 PM

Bump? Anyone...?


All times are GMT -5. The time now is 01:49 PM.