LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 01-19-2005, 03:49 PM   #1
jgnasser
Member
 
Registered: Feb 2004
Location: Kenya
Distribution: Red Hat
Posts: 57

Rep: Reputation: 15
squid ncsa authentication


I'm trying out squid authentication using NCSA and soesnt seem to be working. I thought its straight forward. This is what I've done;

created a password file using htpasswd and added a user

added these lines to squid.conf:


auth_param basic program /usr/lib/squid/ncsa_auth /etc/squid/squid_passwd
acl ncsa_users proxy_auth REQUIRED
http_access allow ncsa_users

then I did service squid restart

Web access is as usual, not asking for password.

What have I missed out?
 
Old 01-19-2005, 05:02 PM   #2
kashani
LQ Newbie
 
Registered: May 2004
Location: last train to Satansville
Distribution: gentoo
Posts: 5

Rep: Reputation: 0
I'd guess that you have been using Squid in the past and put an allow in for your IP space. I do it that way so the office users always work, but if you want to use the proxy from home, we use it for web server testing with the dev sites, then you have to enter a password. Easier than trying to keep up with everyone's dynamic IP's.

auth_param basic program /usr/lib/squid/ncsa_auth /etc/squid/squid.pass
acl our_networks src 10.0.0.0/8
acl ncsa_users proxy_auth REQUIRED
http_access allow our_networks
http_access allow ncsa_users
no_cache deny all

kashani
 
Old 01-20-2005, 06:28 AM   #3
jgnasser
Member
 
Registered: Feb 2004
Location: Kenya
Distribution: Red Hat
Posts: 57

Original Poster
Rep: Reputation: 15
Yes I already have

acl mrc src 192.168.0.0/24
http_access allow mrc
http_access deny all

which allows my LAN to connect. I notice that when I put the settings on the browser to use proxy server then squid now requests for passwd. My transparent proxy settings are on because clients can browse without entering proxy details.
 
Old 01-20-2005, 10:40 AM   #4
jgnasser
Member
 
Registered: Feb 2004
Location: Kenya
Distribution: Red Hat
Posts: 57

Original Poster
Rep: Reputation: 15
I think I now have a hint, the authentication wont work when the proxy is transparent. Is that correct?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NCSA authentication goes off Sleen Linux - General 0 10-06-2005 05:41 AM
squid ncsa authentication thillaii Linux - Networking 0 05-06-2005 04:04 AM
squid without authentication paul_mat Linux - Networking 2 03-21-2005 12:02 AM
squid authentication agent bigote Linux - Newbie 0 09-23-2004 03:33 AM
Squid Authentication Modules NCSA ahmerali Linux - Software 0 10-28-2003 04:57 AM


All times are GMT -5. The time now is 10:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration