LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-13-2004, 04:24 AM   #1
tarakthakor
LQ Newbie
 
Registered: Nov 2004
Location: India
Distribution: Redhat Suse
Posts: 1

Rep: Reputation: 0
squid FATAL: Could not determine fully qualified hostname. Please set 'visible_hostn


Pls Refer wheren i am stating squid i am getting below erorr


root@Orion etc]# service squid status
squid is stopped
FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

Squid Cache (Version 2.5.STABLE5): Terminated abnormally.
CPU Usage: 0.021 seconds = 0.010 user + 0.011 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 12
/etc/init.d/squid: line 162: 28166 Aborted $SQUID -k check
[root@Orion etc]# servic squid start
-bash: servic: command not found
[root@Orion etc]# service squid start
Starting squid: /etc/init.d/squid: line 162: 28178 Aborted $SQUID $SQUID_OPTS >>/var/log/squid/squid.out 2>&1



FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

pls let me know what should i do .....

Thanks
 
Old 11-18-2004, 09:31 AM   #2
bdogg
Member
 
Registered: Sep 2004
Location: Salt Lake City, UT
Distribution: Debian Sarge
Posts: 93

Rep: Reputation: 15
Do just what it says.

In your squid.conf there is an option to set a visible_hostname tag. Just open it up, and search for it in that huge file. You will notice that it's default is "none".

Squid is actually doing this because it cannot determine your current hostname. Either you have a problem with the hostname of your box "Orion" which I don't think is the case or your DNS servers that squid is trying to use do not recognize what your hostname should be.

You could set the visible_hostname tag, but that might not solve your problem as it's a little deeper than just having a name to display.

Which IP address are you binding squid to? and internal one or an external? Is there an entry in your /etc/hosts for that ip address?
 
Old 11-18-2004, 11:14 AM   #3
mini_mike
LQ Newbie
 
Registered: Aug 2004
Location: Manila, Philippines
Distribution: Red Hat 9
Posts: 11

Rep: Reputation: 0
Newbie here w/ the same problem

How do u set "TAG: visible_hostname"? by uncommenting the line and setting the Default to my current HOSTNAME instead of none?
 
Old 11-18-2004, 11:19 AM   #4
mini_mike
LQ Newbie
 
Registered: Aug 2004
Location: Manila, Philippines
Distribution: Red Hat 9
Posts: 11

Rep: Reputation: 0
Oh! I finally got it! I just added the line:

visible_hostname [My HOSTNAME]

without the comment character.
 
Old 03-25-2010, 01:42 AM   #5
manoj.patil1727
LQ Newbie
 
Registered: Mar 2010
Posts: 1

Rep: Reputation: 0
erorr in squid

[QUOTE=tarakthakor;1290435]Pls Refer wheren i am stating squid i am getting below erorr


root@Orion etc]# service squid status
squid is stopped
FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

Squid Cache (Version 2.6.STABLE5): Terminated abnormally.
CPU Usage: 0.020 seconds = 0.000 user + 0.020 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 0
/etc/init.d/squid: line 53: 2716 Aborted $SQUID -k check
[root@Orion etc]# servic squid start
-bash: servic: command not found
[root@Orion etc]# service squid start
Starting squid: /etc/init.d/squid: line 53:2716 Aborted $SQUID $SQUID_OPTS >>/var/log/squid/squid.out 2>&1



FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

pls let me know what should i do .....

Thanks
 
Old 12-04-2010, 05:29 AM   #6
indian_munnda
LQ Newbie
 
Registered: Jul 2010
Posts: 8

Rep: Reputation: 0
one of my friend was facing this problem......Check the /etc/hosts file if you have made correct entries or not for the corresponding IPs.....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache giving the error :Could not determine the server's fully qualified domain name bcf2 Linux - Server 46 10-15-2013 03:45 AM
squid fully qualified hostname DutchBoy Linux - Software 2 09-08-2004 10:17 PM
Fully qualified hostname gubak Linux - Newbie 8 07-23-2004 11:56 PM
Apache: httpd: Could not determine the server's fully qualified domain name.. shirtboy Linux - Software 1 11-20-2003 03:47 AM
http: can't could not determine the servers fully qualified domain name, using 127xyz s7nner Linux - Newbie 4 05-05-2003 06:18 PM


All times are GMT -5. The time now is 04:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration