LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 11-19-2003, 05:11 AM   #1
Crasherz
Member
 
Registered: Sep 2003
Location: Australia_Warm & Sunny
Distribution: Fedora & Doze XP Pro
Posts: 68

Rep: Reputation: 15
Squid error even before starting


Squid is being started by the initialisation files but has this error. The host is redhat4 on the fbn network. Does it require a network name like fbn.com?? All other networking runs fine, the host that I want to run squid on has modem access to the Internet which it happily shares with several other computers, no problems. I just wanted to run squid to speed access to commonly accessed sites. As yet I have done no configuration of squid, it has default settings as per redhat v9.

FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'
 
Old 11-19-2003, 08:04 AM   #2
RajaRC
Member
 
Registered: Feb 2003
Distribution: Redhat
Posts: 58

Rep: Reputation: 15
I have faced a similar problem like this. This problem is related to RedHat v9 only.

If you upgrade from Redhat v7.3 to Redhat v9 then it works fine.

If your upgarde from Redhat v8 to Redhat v9 then the same error occurs, even I have tried doing a fresh installation still the problem persists.

What i have done is Re-Install Redhat v7.3 and then upgarded it to v9.

Hope this helps..
 
Old 11-19-2003, 04:42 PM   #3
Crasherz
Member
 
Registered: Sep 2003
Location: Australia_Warm & Sunny
Distribution: Fedora & Doze XP Pro
Posts: 68

Original Poster
Rep: Reputation: 15
No really...I don't want to have to take such a dramatic step. There must be someting in the configuration or other files to fix this silly issue. Does anyone else run squid on redhat 9 from a fresh install?
 
Old 11-20-2003, 12:25 AM   #4
RajaRC
Member
 
Registered: Feb 2003
Distribution: Redhat
Posts: 58

Rep: Reputation: 15
yes i think so but even after doing a fresh installation and upgrading squid to - squid-2.5.STABLE4 it didn't solved.

I hope there is some way out. Since i had to downgrade my live server and then upgrade.
 
Old 11-20-2003, 10:31 AM   #5
nowonmai
Member
 
Registered: Jun 2003
Posts: 481

Rep: Reputation: 48
edit /etc/squid/squid.conf and look for the visible_hostname setting. Uncomment it and put a fully qualified hostname in it and away you go.
 
Old 11-20-2003, 04:52 PM   #6
Crasherz
Member
 
Registered: Sep 2003
Location: Australia_Warm & Sunny
Distribution: Fedora & Doze XP Pro
Posts: 68

Original Poster
Rep: Reputation: 15
Big Thankyou

Done and running.....Doesn't need a FQDN just the name of the host (I don't run a FQDN) I thought there had to be an easier way than playing a round robin install game.
 
Old 11-21-2003, 01:05 AM   #7
RajaRC
Member
 
Registered: Feb 2003
Distribution: Redhat
Posts: 58

Rep: Reputation: 15
my /etc/hosts file reflects -

ip-address test

note: test is the hostname of my system.

so in my case i have uncommented it and put the test in the squid.conf file, but it didn't worked.

is my configuration wrong?
 
Old 11-21-2003, 01:14 AM   #8
Crasherz
Member
 
Registered: Sep 2003
Location: Australia_Warm & Sunny
Distribution: Fedora & Doze XP Pro
Posts: 68

Original Poster
Rep: Reputation: 15
Where the line (1958th line in the squid.conf file in mine) started TAG: xxxxxx
I removed the TAG : so now the 1958 line looks like

visible_hostname redhat4

MY host name is redhat4
It worked fine....
 
Old 11-21-2003, 04:56 AM   #9
nowonmai
Member
 
Registered: Jun 2003
Posts: 481

Rep: Reputation: 48
Quote:
Originally posted by RajaRC
my /etc/hosts file reflects -

ip-address test

note: test is the hostname of my system.

so in my case i have uncommented it and put the test in the squid.conf file, but it didn't worked.

is my configuration wrong?
try setting visible_hostname to test.local
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid not starting..... Ricky Linux - Networking 5 05-31-2006 07:54 AM
Error starting Squid mrpc_cambodia Red Hat 2 07-20-2004 04:45 AM
Squid starting error abhram Linux - Networking 1 10-12-2003 08:17 AM
Squid starting problem?? deepika Linux - Networking 4 10-10-2003 12:13 PM
Starting squid from boot? kabads Linux - Software 3 02-14-2003 07:23 AM


All times are GMT -5. The time now is 12:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration