LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-11-2003, 04:21 PM   #1
TechnoBod
LQ Newbie
 
Registered: Jan 2003
Distribution: Fedora 14, Centos 6
Posts: 26

Rep: Reputation: 15
Squid - Authentication


Hello all,

I have had a redaht 8 box running squid 2.4 stable 7, SMB_AUTH, and sarg running for the last year.

Unfortunately, earlier today it suffered a serious crash and I had to re-install it with Redhat 9. This comes with a newer version of squid, 2.5 stable-X.

I could not use my old squid.conf since the new version of squid has added options and some options have been discontinued. After a while I now have squid running again.

I have tried to make it work with smb_auth, but it doesn't seem to work on this new setup.....

Can any one help by offering advice.

I need to have all users authenticated against my Windows NT 4 PDC.

Can anyone recomend a solution that will validate the user against the PDC and log their username to access.log ????
 
Old 06-13-2003, 05:03 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,953
Blog Entries: 54

Rep: Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733
squid-cache.org/Doc/FAQ/FAQ-23.html ?
 
Old 06-22-2003, 07:22 PM   #3
dulantha
LQ Newbie
 
Registered: Jun 2003
Location: Auckland, New Zealand.
Distribution: Custom on 2.0.36 kernel, RH6, RH7, RH7.1, RH8, RH9
Posts: 3

Rep: Reputation: 0
Post your conf.. I have RH9 and smb_auth working..

If you haven't solved it by now..
Post your auth section and acl section I will take a look see.
I have this working OK..

Also what samba version are you running?

:-)
 
Old 06-23-2003, 07:19 AM   #4
TechnoBod
LQ Newbie
 
Registered: Jan 2003
Distribution: Fedora 14, Centos 6
Posts: 26

Original Poster
Rep: Reputation: 15
thanks for the offer of help but I've cracked it.

The problem was that smb_auth was looking in the wrong location for the nmblookup programme. after a little play around i managed to track down the problem..

after editing the SAMBAPREFIX option to look to the right directory, it all started working again...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SQUID authentication jhp Linux - Software 2 06-14-2005 10:39 AM
squid without authentication paul_mat Linux - Networking 2 03-20-2005 11:02 PM
squid authentication agent bigote Linux - Newbie 0 09-23-2004 02:33 AM
Squid authentication! yenonn Linux - Networking 1 03-21-2003 07:58 AM
squid authentication mayankjohri Linux - General 2 03-13-2003 11:33 PM


All times are GMT -5. The time now is 03:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration