LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-25-2013, 05:23 PM   #1
SBS1
LQ Newbie
 
Registered: Apr 2012
Posts: 16

Rep: Reputation: Disabled
Question Squid Accessing Itself


Hi there,

At our workplace, we've recently installed a Squid proxy & firewall using iptables. It's running Debian stable. It has Apache running on itself for an HTTP interface.

When we access the web interface via the proxy, we receive;
Code:
The following error was encountered while trying to retrieve the URL: http://proxy/

    Unable to determine IP address from host name "proxy"

The DNS server returned:

    Server Failure: The name server was unable to process this query.
This makes sense as in the machine's host file, proxy points to 127.0.1.1. It's would be easy enough to get around by simply changing proxy to point its internal address instead of the loopback.

However, this seems to be breaking a standard and may introduce issues. Would anyone know of a correct to get around this issue?

Thanks to any replies.
 
Old 02-25-2013, 05:30 PM   #2
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,566

Rep: Reputation: 411Reputation: 411Reputation: 411Reputation: 411Reputation: 411
Do you have the hostname "proxy" mapped to that loopback address in your hosts file? You didnt specify that there.
 
Old 02-25-2013, 05:37 PM   #3
SBS1
LQ Newbie
 
Registered: Apr 2012
Posts: 16

Original Poster
Rep: Reputation: Disabled
Hi Kustom42,

Yes, that's right. It's pointing to a loopback address of 127.0.1.1, Debian's standard loopback address.
 
Old 02-25-2013, 05:41 PM   #4
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,566

Rep: Reputation: 411Reputation: 411Reputation: 411Reputation: 411Reputation: 411
What is your /etc/nsswitch.conf set to for hosts? Do you have files listed before dns?
 
Old 02-25-2013, 06:14 PM   #5
SBS1
LQ Newbie
 
Registered: Apr 2012
Posts: 16

Original Poster
Rep: Reputation: Disabled
I wasn't aware of that file, but I've made that adjustment. It's now obtaining a valid IP for the machine.

However, I'm getting the same message, even after restarting Squid, so it wasn't exactly as I had thought. Oddly, using the FQDN 'proxy.worknetwork.local' works fine.
 
  


Reply

Tags
squid


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to bypass squid for accessing website. gardenair Linux - Networking 19 05-11-2011 01:07 PM
squid - limited time slot for accessing the internet via squid. shahg_shahg Linux - Server 1 09-20-2008 06:41 AM
Squid 2.6 not accessing https sites unixashoke Linux - Newbie 2 04-04-2008 07:52 AM
Accessing Squid logs jonnoc Linux - General 2 01-16-2008 08:33 AM
accessing ftp server via squid zamri Linux - Networking 2 11-01-2006 08:15 PM


All times are GMT -5. The time now is 05:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration