LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-24-2005, 08:38 AM   #1
eurekaguy4u
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Rep: Reputation: 0
Squid Access Denied Help


hi friends,

i newly installed squid 2.4 on Red Hat Linux Enterprise server. It is working fine for all my web site, till i tried to access a website which is on port no. 712 like "hxxp://websitename:712/" , while doing this , got following error message : -

The following error was encountered:

* Access Denied.

Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect.

Please help me how to resolve it.

euro guy
 
Old 09-24-2005, 08:40 AM   #2
eurekaguy4u
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Original Poster
Rep: Reputation: 0
hi

i tried one config file from one of my friend, which i earlier tested too on my other server with some changes. but after using that too i am getting the same "Access Denied" message.

i m sure there is some problem with the current installation but not getting out what is that, somebody help plz

Euroguy
 
Old 09-25-2005, 05:26 PM   #3
poochdog
Member
 
Registered: Jul 2004
Location: United Kingdom
Distribution: Fedora Core 9
Posts: 141

Rep: Reputation: 15
I beleive you need to edit your squid.conf file to allow access to that port....
 
Old 09-26-2005, 12:46 AM   #4
usmanmehmood
LQ Newbie
 
Registered: Sep 2005
Posts: 15

Rep: Reputation: 0
port 712 is in safe ports by default.i don't think u need to change it.
is ur proxy running transparently. if not try to use transparent proxy.
or sned ur squid.conf. may be we can suggest something.
 
Old 09-26-2005, 01:40 AM   #5
eurekaguy4u
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Original Poster
Rep: Reputation: 0
i m pasting the acl part of my squid conf.

acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # https, snews
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http


when i tried to download a file from bittorrent site , it is giving me the 403 forbidden error in the bit torrent client

hope this will help you more.

Euro GY
 
Old 09-26-2005, 05:18 AM   #6
usmanmehmood
LQ Newbie
 
Registered: Sep 2005
Posts: 15

Rep: Reputation: 0
dear if u don't mind
plz send me ur squid.conf in my email usman1_ak@yahoo.com
and plz tell me have u configured iptables or ipchains
 
Old 09-26-2005, 05:48 AM   #7
deoren
Member
 
Registered: Oct 2003
Location: USA
Distribution: Ubuntu
Posts: 214

Rep: Reputation: 30
Quote:
Originally posted by eurekaguy4u
i m pasting the acl part of my squid conf.

acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # https, snews
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http


when i tried to download a file from bittorrent site , it is giving me the 403 forbidden error in the bit torrent client

hope this will help you more.

Euro GY
From what I can tell you do not have 712 in your Safe_ports list. Add another line:

Code:
acl Safe_ports port 712 # Add description here
Which should now give you:
Code:
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # https, snews
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl Safe_ports port 712 # Add description here
As root use
Code:
/etc/init.d/squid reload
. It may be reconfigure instead of reload; I don't have a squid box in front of me at the moment.

Now whether bittorrent will work through squid is a different story; that I don't know.
 
Old 09-28-2005, 08:03 AM   #8
eurekaguy4u
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Original Poster
Rep: Reputation: 0
hi ,

nothing solved my problem yet,

i checked the access.log of squid it is giving me following error message :-

1127719673.640 1 191.254.13.59 TCP_DENIED/403 1033 GET http://freeeforums.blogdns.com:712/favicon.ico - NONE/- -

Why this is coming , plz help me

EuroGUY
 
Old 09-28-2005, 08:07 AM   #9
deoren
Member
 
Registered: Oct 2003
Location: USA
Distribution: Ubuntu
Posts: 214

Rep: Reputation: 30
I would have to see your squid.conf file to help you further. usmanmehmood has also requested a copy of squid.conf to provide help.

It's not providing a username so it would appear that your auth_param config section is invalid. By looking at your squid.conf I could possibly spot the issue.
 
Old 09-28-2005, 08:24 AM   #10
usmanmehmood
LQ Newbie
 
Registered: Sep 2005
Posts: 15

Rep: Reputation: 0
i again suggest u that u should send ur squid.conf and tell us that have u configured transparent proxy or not.
i tested that on my network , when i use transparent proxy that problem is solved but when i explicitly give proxy to internet explorer it gives the same error that u told us. so provide us all that information.
 
Old 09-28-2005, 08:26 AM   #11
eurekaguy4u
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Original Poster
Rep: Reputation: 0
which part of squid.conf should i give you ,
 
Old 09-28-2005, 08:29 AM   #12
usmanmehmood
LQ Newbie
 
Registered: Sep 2005
Posts: 15

Rep: Reputation: 0
i suggest u should mail me ur whole squid.conf. i told u my email address in a previous post.
 
Old 09-28-2005, 08:38 AM   #13
eurekaguy4u
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Original Poster
Rep: Reputation: 0
i m mailing you the squid.conf , plz check and give feedback.
 
Old 09-28-2005, 09:12 AM   #14
usmanmehmood
LQ Newbie
 
Registered: Sep 2005
Posts: 15

Rep: Reputation: 0
i got ur squid.conf
im ashtonied how ur squid is running without specifying visible_hostname.
anyways can u tell me ur configuration about transparent proxy i hope it will solve that problem as i told u in previous meesage.
 
Old 09-28-2005, 10:45 PM   #15
eurekaguy4u
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Original Poster
Rep: Reputation: 0
What do you mean by transparent proxy here,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid url port 81 access-denied error steve@korehicom.com Linux - Networking 0 10-13-2005 09:55 AM
squid access denied hariiyer Linux - Networking 2 10-30-2004 09:55 AM
Access Denied Using Squid Lucinda Linux - Software 8 06-10-2004 06:30 AM
squid comes back with message 'access denied' mhs1973 Linux - Networking 4 02-08-2002 11:17 PM
Denied access by squid hagenuk Linux - General 1 10-07-2001 10:45 AM


All times are GMT -5. The time now is 08:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration