LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Some Pc's Getting Out Of Range Ip In Dhcp (http://www.linuxquestions.org/questions/linux-networking-3/some-pcs-getting-out-of-range-ip-in-dhcp-590759/)

reachjohney 10-10-2007 06:33 AM

Some Pc's Getting Out Of Range Ip In Dhcp
 
I have got server configured with dhcp, dns, squid proxy, nat ideally used as the internet server for our 62 pc computer lab. I have recently upgraded to a 1 GB machine with fedora core 6 and configured it fresh. However in the new scenerio my dhcp windows clients, not all but some, are getting ip that's not defined with in the dhcp range assigned with in dhcp.conf [range 172.16.2.0 172.16.2.255; entry]. And these pc's not in the range of ip's are not getting internet access .Wireless clients are also allowed access to the network. can any one find out whether the problems is with dns, or any other setting in dhcp or due to wireless lan configuration problems. These clients are not getting access to internet, but on giving fixed ip , they can get full access to internet.

sir-lancealot 10-11-2007 02:32 PM

My 1st .02 is that you need to provide a bit more info. You said they are windows clients, so what IP's are they getting as you are setup to use the entire 172.16.2 subnet. Are these machines getting that old 169.254.x.x address?

Not sure what wireless has to do with anything above, but can some/any of the wireless clients get internet access?

As for DNS, well if you think that it "may" be a factor, simply ping some outside address such as google (72.14.207.99) and see if you get a reply. But again, if these machines are getting an IP outside the subnet, they won't be able to reach the gateway and get out.

I would say start simple, you only have 65 machines, so allocate 100-200 as the subnet. On the windows machine, restart, do an ipconfig /all and check the IP as well as the DHCP server. It's quite possible there is another box out there giving IP's, but start there and report back with some more info to help.

-lr

farslayer 10-11-2007 03:50 PM

Your range statement looks incorrect to me..

range 172.16.2.0 172.16.2.255

You have included the Network Address 172.16.2.0
You have included the Broadcast Address 172.16.2.255

What is the Subnet mask you are handing out, 255.255.255.0 ?
Do your servers and network gateway addresses fit in that range as well ? If so you should not be handing out addresses that are already statically assigned.. the range should be more along the lines of:

range 172.16.2.50 172.16.2.254


I would post your dhcp conf file, and a bit more information about your network..

reachjohney 10-15-2007 05:16 AM

My dhcpd .conf
 
this is my dhcpd.conf file ...


default-lease-time 86400;
max-lease-time 86400;

option subnet-mask 255.255.0.0; option broadcast-address 172.16.255.255;
option routers 172.16.1.1; option domain-name-servers 172.16.1.1;
option domain-name"ls.edu.in" ;
ddns-update-style interim; subnet 172.16.0.0 netmask 255.255.0.0
{
range 172.16.2.10 172.16.2.200;

}

farslayer 10-15-2007 11:44 AM

Personally I would change it to this...



default-lease-time 86400;
max-lease-time 86400;

option subnet-mask 255.255.255.0; option broadcast-address 172.16.1.255;
option routers 172.16.1.1; option domain-name-servers 172.16.1.1;
option domain-name"ls.edu.in" ;
ddns-update-style interim; subnet 172.16.1.0 netmask 255.255.255.0
{
range 172.16.1.50 172.16.2.254;

}


then put all servers, routers, switches, and other devices in the 1-49 address range.

a 16 bit subnet mask as you have defined (255.255.0.0) is HUGE.. that allows for 65,535 Hosts for that network, if you try and put that many hosts on a network it just simply wont work. It's a bad habit to get into to configure a subnet that large imho.

The largest subnet I would consider using would be a /22 (255.255.252.0) which would allow for 1022 hosts per subnet, but is still rather large and would probably come to a screaching halt if you tried to put tha tmany devices on it.


All times are GMT -5. The time now is 10:50 PM.