LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-31-2007, 02:27 PM   #1
pipesbi
LQ Newbie
 
Registered: Feb 2006
Posts: 1

Rep: Reputation: 0
smtp from netstat command


Hello all!
I"m not a Linux/Network expert obviously, that's why I'm asking this question.

I'm trying to shutdown port 25 (smtp) on my Suse 10 system. I'm okay with it listening locally, but, don't want smtp listening for external requests. When running netstat I get *:* after smtp is this listening for requests locally only?

What I get;
tcp 0 *:smtp *:* listen


Thanks,
 
Old 07-31-2007, 03:54 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
this isn't anything to do with networking per se.. just stop the smtp server opening that port in the first place... you've not said a single thing about what service you're running so we can't really comment any further.
 
Old 07-31-2007, 05:14 PM   #3
The_Dude
LQ Newbie
 
Registered: Jul 2007
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by pipesbi
Hello all!
I"m not a Linux/Network expert obviously, that's why I'm asking this question.

I'm trying to shutdown port 25 (smtp) on my Suse 10 system. I'm okay with it listening locally, but, don't want smtp listening for external requests. When running netstat I get *:* after smtp is this listening for requests locally only?

What I get;
tcp 0 *:smtp *:* listen


Thanks,
It is a good thing what your are trying to do. You don't mention what smtp software you are running. Most SysVR4 wannabe's usually have sendmail, so, in your sendmail.mc file find the line that says:

DAEMON_OPTIONS(`Port=smtp,Name=MTA')dnl

and change it to,

DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl

and save sendmail.mc

If you have all the utilities that came with sendmail installed, then you can do the following, in the directory that you have the sendmail.mc file, type:

#./Build sendmail.cf

This creates a new sendmail.cf file. Copy the file to /etc/mail/ and restart sendmail. When you do a

netstat -al

you should see

tcp 0 localhost:smtp *:* listen

If you don't want it running at all then:

chkconfig --levels 2345 sendmail off

and then

service sendmail stop

This way, if you reboot, the sendmail daemon will be turned off.

much love,

The Dude

Last edited by The_Dude; 07-31-2007 at 05:20 PM.
 
  


Reply

Tags
netstat


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pid in netstat command on solaris girish_hilage Linux - Networking 1 03-10-2007 01:52 AM
Netstat command Panagiotis_IOA Linux - Networking 2 03-13-2006 12:56 PM
question netstat command nick623 Linux - Newbie 2 01-31-2005 07:53 PM
netstat -r command output juanb Linux - Networking 1 10-28-2004 02:30 PM
Netstat command scottpioso Linux - Networking 14 09-06-2003 10:06 AM


All times are GMT -5. The time now is 02:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration