LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-09-2005, 12:07 PM   #1
zzyzx
LQ Newbie
 
Registered: Feb 2005
Distribution: Slackware 10.1
Posts: 20

Rep: Reputation: 0
smbmount write permissions - root


Slackware and WinXP Home share

I've been banging my head against the wall for while about this one and can't track down a solution. I need some expertise.

I've got a shared folder "Joe" on my WinXP Home machine that I mount with fstab:
//newguy/Joe /mnt/Joe smbfs credentials=/etc/samba/private/.smbpw,defaults,rw 0 0

It mounts fine, any user can read from the share, but I cannot write, even as root. My messages log has this after an attempt:
Feb 9 09:47:41 yeOldZX kernel: smb_create: //test failed, error=-13

And my amateur combing of my samba log finds these entries that have something to do with authorization, what I don't know:

[2005/02/09 08:19:08, 5] auth/auth_util.c:debug_nt_user_token(486)
NT user token: (NULL)
[2005/02/09 08:19:08, 5] auth/auth_util.c:debug_unix_user_token(505)
UNIX token of user 0
Primary group is 0 and contains 0 supplementary groups
[2005/02/09 08:19:08, 5] smbd/uid.c:change_to_root_user(296)
change_to_root_user: now uid=(0,0) gid=(0,0)


My credentials file is Ok, I assume, since it mounts fine. What am I missing for write permissions? Might be something on the windows side, but I can write to the share from windows as any user Ok. Any ideas where I should look for the problem?

Thanks for any help.
 
Old 02-09-2005, 12:11 PM   #2
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
i'd assume that'd be your samba server config -- did you enable write access server-side?

Quote:
read only = No
 
Old 02-09-2005, 12:13 PM   #3
cowanrl
Member
 
Registered: Dec 2004
Location: Western Pennsylvania, USA
Distribution: Red Hat
Posts: 150

Rep: Reputation: 15
This link will provide you with the info you need to make the mounted shares writeable by non-root users:

http://www.justlinux.com/nhf/Filesys...rmanently.html
 
Old 02-09-2005, 12:30 PM   #4
zzyzx
LQ Newbie
 
Registered: Feb 2005
Distribution: Slackware 10.1
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks for the link cowanrl. I've actually read through that one already. The problem is that even root cannot write to the share.

secesh, I'm not sure I understand. It's a windows share, does my smb.conf file affect it? I inserted that into my config file and got the same result. Also, if I mount with smbclient I get the following error trying to write (put):
NT_STATUS_ACCESS_DENIED
 
Old 02-09-2005, 12:53 PM   #5
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
sorry... yes -- that changes the game... did you correctly modify the permissions within windows? -- the security tab in the properties window of a shared folder...
 
Old 02-09-2005, 12:56 PM   #6
cowanrl
Member
 
Registered: Dec 2004
Location: Western Pennsylvania, USA
Distribution: Red Hat
Posts: 150

Rep: Reputation: 15
Sorry, I missed that even root couldn't write to the share.

You may need to trun off Simple File Sharing on XP Home. Here's an excerpt from MS Technet on how to do that:

Turning on and turning off Simple File Sharing
Simple File Sharing is always turned on in Windows XP Home Edition-based computers. By default, the Simple File Sharing UI is turned on in Windows XP Professional-based computers that are joined to a workgroup. Windows XP Professional-based computers that are joined to a domain use only the classic file sharing and security interface. When you use the Simple File Sharing UI (that is located in the folder's properties), both share and file permissions are configured.

If you turn off Simple File Sharing, you have more control over the permissions to individual users. However, you must have advanced knowledge of NTFS and share permissions to help keep your folders and files more secure. If you turn off Simple File Sharing, the Shared Documents feature is not turned off.

To turn Simple File Sharing on or off in Windows XP Professional, follow these steps:
Double-click My Computer on the desktop.
On the Tools menu, click Folder Options.
Click the View tab, and then select the Use Simple File Sharing (Recommended) check box to turn on Simple File Sharing. (Clear this check box to turn off this feature.)
 
Old 02-09-2005, 02:16 PM   #7
zzyzx
LQ Newbie
 
Registered: Feb 2005
Distribution: Slackware 10.1
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks for the input. I checked into Simple File Sharing and according to another KB article from MS:
Quote:
Note You cannot turn off simple file sharing in Microsoft Windows XP Home Edition.
Not worth upgrading to professional for at this point. Stupid windows.

With simple file sharing all access is as Guest. I've "Allowed network users to change my files" on the share, but no love. It does sound like it's a problem with windows permissions and probably not something I can fix on my linux box. I'll continue my search though and post back if anything works. Thanks again for your help.
 
Old 02-09-2005, 04:13 PM   #8
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
i ran into similar issue trying to lock-down a version of XP home so some kids couldn't muck it up as much...

here's the idea: XP home still has many of the features of pro -- it's just that they're buried pretty deep.

try this:
boot to safe mode. This gives you expanded administrative capabilities (like logging on as "Administrator" and editing file/folder permissions)
once up, find the shared folder, right-click and select 'properties' -- you should now have a security tab in which you can edit access permissions.

hope that helps, let me know...
 
Old 02-09-2005, 10:07 PM   #9
zzyzx
LQ Newbie
 
Registered: Feb 2005
Distribution: Slackware 10.1
Posts: 20

Original Poster
Rep: Reputation: 0
Brilliant! secesh, that was just what I needed. I had no idea that was available in xp home. Thanks both of you for your input. Writing to my share is working great, and can quit banging my head. I think I need to harden that wide open Guest account though. Sheesh.
 
Old 02-09-2005, 10:25 PM   #10
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
yay!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
it's safe 2 write to nfs disk from smbmount? Gkarfield Linux - Networking 1 09-13-2004 08:53 AM
SMBMount, okay to write to it? GT_Onizuka Linux - Networking 2 08-18-2004 10:56 AM
cannot edit file as root with write permissions set? Mishley Red Hat 4 08-05-2004 12:23 PM
smbmount is messing with mount point permissions Sohni Linux - Networking 1 04-06-2004 10:37 AM
smbmount file permissions Cosmo92 Linux - Newbie 1 07-08-2003 10:21 PM


All times are GMT -5. The time now is 07:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration