LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Slow internet only on Fedora (http://www.linuxquestions.org/questions/linux-networking-3/slow-internet-only-on-fedora-718514/)

Cassanova 04-11-2009 07:56 PM

Slow internet only on Fedora
 
Hi! I just got high speed (10 Megabit) Cable internet in my apartment; and at first all was quite well, and the internet was Coming into my home nice and fast; loading LQ and FedoraForum VERY quickly. But now, my Two Fedora computers (one desktop wired, and one laptop wireless) load pages VERY slowly; sometimes even slower than the DSL (1.5 Megabit) I'm coming off of... The odd thing is, that my Fiancée's Vista Desktop is loading pages just fine... and super fast. I HAVE made a few minor changes, since they set me up, but I don't know why they would only be affecting my Fedora computers. any ideas as to why this may be happening?

amani 04-11-2009 08:37 PM

Post output of
lspci

ifconfig -a

check
#netstat

#man netstat


check firewall settings

configure services... disable useless ones

Cassanova 04-13-2009 03:38 PM

I use the outputs from my Desktop, as it is the system I use the most:

the Output of lspci (I have Bolded the Ethernet hardware):
Code:

[Hermes@MountOlympus ~]$ lspci
00:00.0 Host bridge: ATI Technologies Inc RX780/RX790 Chipset Host Bridge
00:02.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (external gfx0 port A)
00:0a.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port F)
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4850]
01:00.1 Audio device: ATI Technologies Inc HD48x0 audio
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
03:07.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster
03:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)

the output of ifconfig -a:
Code:

[Hermes@MountOlympus ~]$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr This:is:My:Mac:Address:YAY! 
          inet addr:My.Network.IP.Address  Bcast:not.sure.What ths.is  Mask:not.Sure.Here.Either
          inet6 addr: Hex::hex:hex:hex:hex Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1492  Metric:1
          RX packets:7365 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7532 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5954051 (5.6 MiB)  TX bytes:1261215 (1.2 MiB)
          Interrupt:18

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:not.Sure.What.This is
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:800 (800.0 b)  TX bytes:800 (800.0 b)

pan0      Link encap:Ethernet  HWaddr This:One:Is:Different:Than:Eth0 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

virbr0    Link encap:Ethernet  HWaddr yet:Another:Mac:Address:here:YAY 
          inet addr:this.one.is.short  Bcast:slightly.Different.From.Eth0  Mask:255.255.255.0
          inet6 addr: Different::From:Eth0:by:a little Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:5397 (5.2 KiB)

Hope this helps. I wasn't sure if I took too much out
I would've posted the output of netstat, but it was too long. as for disabling "Useless Services" I neither know how, nor know which are useless

anomie 04-13-2009 03:58 PM

These symptoms can be caused by having your home router/NAT device specified as a nameserver. What's in /etc/resolv.conf? If it contains the IP of your NAT device's internal NIC, then change it to one of your ISP's nameservers instead to test.

It's hard to read your posts when you arbitrarily bold words.

Cassanova 04-13-2009 09:51 PM

Quote:

Originally Posted by anomie (Post 3507724)
These symptoms can be caused by having your home router/NAT device specified as a nameserver. What's in /etc/resolv.conf? If it contains the IP of your NAT device's internal NIC, then change it to one of your ISP's nameservers instead to test.

It's hard to read your posts when you arbitrarily bold words.

srry bout the random boldage... I just try to bold the main Ideas, because I often give too much detail so I bold the main points so that the less-patient can still help me.

Anyway, Unfortunately I'm not knowledgeable enough to know for sure what you mean by "NAT device's internal NIC" but I can tell you that the /etc/resolv.conf files on both my systems are very similar. They each have 3 numbers that I've seen before... in the connection settings windows... They are my primary DNS (which is my router), my secondary DNS and my Tertiary DNS (I think these are from my ISP but not sure... networking isn't my strong point). The only apparent difference between the two files, is that on my laptop there's an extra line on the top that says "search Rome"... Rome was part of my Laptop's old name... In the setup it wanted me to name the computer I called it "Colosseum.Rome" although w/o a ntwork, I'm not sure how necessary it was.

anomie 04-14-2009 12:15 PM

Quote:

Originally Posted by Cassanova
... I can tell you that the /etc/resolv.conf files on both my systems are very similar. They each have 3 numbers that I've seen before... in the connection settings windows... They are my primary DNS (which is my router), my secondary DNS and my Tertiary DNS (I think these are from my ISP but not sure...

For the sake of testing possible causes, back up your /etc/resolv.conf and then replace its contents with only this:
Code:

nameserver 208.67.222.222
nameserver 208.67.220.220

Do you see an improvement with your problem? (Those are OpenDNS's nameservers, BTW.)

repo 04-14-2009 12:41 PM

Also, try to disable ipv6
http://blog.taragana.com/index.php/a...ora-linux-why/

Cassanova 04-14-2009 06:52 PM

Thank you for your posts. I tried both suggestions. Changing the IPs in the resolv.conf file worked very well on both systems. However upon restart, the IPs were restored, and my internet was once again slow (but i know that the reset it supposed to happen). What does the alternate IPs speedimg me up indicate?

Unfortunately disabling IPv6 was impossible as I seem to lack the necessary file (/etc/modprobe.conf) in the proper location

repo 04-15-2009 12:54 AM

Take a look at post #13 from faislayer in this post
http://www.linuxquestions.org/questi...nstall-718869/

Cassanova 04-17-2009 12:21 PM

Updade:
Thanks to marko At FedoraForm, I've discovered that my IPv6 is already off. So now I get to figure out the next possible cause of my slow connection. The other lead that I've got, is that editing my /etc/resolv.conf file, and replacing the IPs in it (With IPs from OpenDNS) fixes it... but IDK why, and re-editing the file every time I boot, is annoying, and I'm not entirely comfortable with the whole idea of borrowing someone else's IPs anyway

anomie 04-17-2009 01:25 PM

Visit the OpenDNS URL I posted. They're providing a free beer community service.

If you don't want to change the /etc/resolv.conf every time, then make it system immutable.

# chattr +i /etc/resolv.conf

Or read the dhclient(8) manpages.

Cassanova 05-22-2009 08:21 PM

Quote:

Originally Posted by anomie (Post 3512496)
Visit the OpenDNS URL I posted. They're providing a free beer community service.

If you don't want to change the /etc/resolv.conf every time, then make it system immutable.

# chattr +i /etc/resolv.conf

Or read the dhclient(8) manpages.

AWESOME! this worked.... for a bit... and now both ethernet and Wireless are slow... any other suggestions? is there a way to undo that?

anomie 05-22-2009 08:29 PM

Undoing that attribute setting is as simple as:

# chattr -i /etc/resolv.conf

Keep in mind: if the OpenDNS nameservers are working slowly at the moment, it's probably very temporary. In 2+ years of using them, I have rarely seen noticeable issues.

Cassanova 05-22-2009 09:40 PM

Thank you. I thought that might do the trick but I wanted to be sure. upon studying my resolv.conf file, i found that it was indeed trying to use my router IP as a nameserver; as well as two other IPs (which logic suggests are my ISP's Nameservers). so I figured I'd just go ahead and use OpenDNS's service and change my router's setup to use those. Unfortunately the original IPs stay put, and OpenDNS's numbers just get added; So OpenDNS sees those, and can't figure out, that its numbers are there too. So I can't move on to step 2... So I've just created a symbolic link to my resolv.conf in my ~/ directory, and edit it manually every time I boot.

amani 05-23-2009 11:02 AM

Try changing mtu

#ifconfig eth0 mtu 1500


or 1412



#system-config-services
(for modifying services)


All times are GMT -5. The time now is 02:55 PM.