LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-15-2003, 10:41 AM   #1
NewbieUser
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware 8.1
Posts: 5

Rep: Reputation: 0
Slackware 2nd nic config problem


Hello,

Slackware 8.1
eth0 Linksys LNE100TX v4 IRQ10 0xe400-e4ff
eth1 DLink DFE-530TX+ IRQ11 0xe800-e8ff

Problem: second nic will not load for the life of me.

I've been counting the number of hairs that's been falling out.. lost count in the 80's. Been trying to install a second nic card for the past several days. I think I've pretty much read everything and tried everything that's been posted on the web, in the cd documents, in an old Linux book (redhat.. can't afford to buy another book right now), and have been on chat lines.

In the system information under PCI and I/O- ports both the nics show up. However under Network Interfaces only eth0 and lo shows up. Both ethercards works fine when only one of them are installed at a time. So I think it's a configuration problem.

I've tried everything from editing conf.modules to lilo.conf.
Things that I have tried:
conf.modules- alias eth1=tulip
alias eth1 driver
alias net -pf-4 off (i was getting desperate)
lilo.conf- append = eth0,0,eth1
append ether=10,0xe400,eth0 ether=11,0xe800,eth1

rc.inet1- tried adding "ifconfig eth1 <my ip> netmask <subnet mask> broadcast <broadcast> up"
tried to configure the ip addresses for eth1
tried disabling PNPOS setting in Bios (read that somewhere)

Now, of all the suggestions I found in rc.inet1 - "edit /etc/rc.d/rc.modules to load the support at boot time." How? I went to that file and it lead me to think that I needed to get the driver for the eth1 card. And things got more and more complicated.

Another suggestion I found was here on this board:

"ok, what your problem is is that redhat and most other linux distros treat network initilization differently than slackware. here's how you'll wanna add eth1 to your system:

in your network initilization script - which is /etc/rc.d/rc.inet1 - you'll want to duplicate the section in which it loads eth0 (which is pretty much everything after your loopback device).

i modified my rc.inet1 script a little in order to have it make more sense to me. i removed all of the eth0 init lines from that file and moved them to a separate file called "rc.eth0" (which i created). then i copied rc.eth0 to rc.eth1 and modified any mention of that file so that instead of "eth0" it read "eth1". then i changed my network settings according to what i wanted eth1 to be configured as. finally, you'll want to specify the device name, so add the line:

DEVICE="eth1"

to the top of your config variables (IPADDRESS, GATEWAY, etc).

then in rc.inet1 where the eth0 lines used to be, i simply add the following:

/etc/rc.d/rc.eth0
/etc/rc.d/rc.eth1

of course, you could always skip the new file process and simply duplicate the eth0 config section to reflect eth1, i just like the new files for the reason of clarity.

after you've done this, reinitilize your network by typing:

/etc/rc.d/rc.inet1

and you should see eth1 configured and ready to roll! hope this helps. :-)"
 
Old 02-16-2003, 11:49 AM   #2
tgb
LQ Newbie
 
Registered: Jun 2002
Location: Alabama, USA
Distribution: Slackware
Posts: 6

Rep: Reputation: 0
Have you checked out the ethernet howto?

http://www.ibiblio.org/pub/Linux/doc...WTO.html#ss2.3

There's a section on having multiple ethernet cards on one machine that talks about the way Linux autoprobes.
You don't say whether you've got the drivers as modules or compiled into the kernel, but that makes a difference.
Check out the howto and see if that helps.
 
Old 02-16-2003, 11:28 PM   #3
verigoth
Member
 
Registered: May 2002
Posts: 179

Rep: Reputation: Disabled
Dlink cards are based on RealTek chipsets: modprobe 8239too

verigoth
 
Old 02-17-2003, 06:03 AM   #4
NewbieUser
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware 8.1
Posts: 5

Original Poster
Rep: Reputation: 0
Thank you guys. I got some bogus info on the net saying it was tulip. After all that searching, it turns out to the driver... well I definitely got familiar with Linux from all that. As for the 2nd NIC you don't know how happy I was I got it to work.

There are some really cool ppl out there like "barcode" who logged in my machine and helped me setup my router and firewall.
You only think what a pain in the a** LInux is until you get it to work and see that there are ppl who're willing to help. Linux is getting to be pretty cool.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1st nic regular FTP, 2nd nic SSH Riselong Linux - Distributions 2 02-02-2004 06:13 PM
iptable problem upon nic config dillinja Linux - Hardware 3 08-06-2003 09:38 AM
dhcpd.conf and 2nd NIC problem KowCiller Linux - Networking 4 07-05-2003 09:01 PM
Slackware 2nd nic config problem NewbieUser Linux - Networking 1 02-15-2003 02:03 PM
Problem with adding a 2nd NIC to RH 7.0 IHawk Linux - Networking 0 02-18-2001 10:44 PM


All times are GMT -5. The time now is 08:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration