LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Slackware 10.1 + SSH Configuration (http://www.linuxquestions.org/questions/linux-networking-3/slackware-10-1-ssh-configuration-356907/)

Robert154 08-25-2005 12:16 PM

Slackware 10.1 + SSH Configuration
 
Hi all,

I am a newbie and I have 3 machines, all working on a network with the same DNS, and Gateway address. On one of the machine Slackware 10.1 is already installed. While I installed Slackware 10.1 on the remaining machines yesterday. I can connect remotely (from within network) through ssh with the first machine but cannot connect with the freshly installed machines through ssh. The configuration files (ssh_config and sshd_config) are same for all three machines i.e almost all of the entries are commented.
Can anybody help me how can I enable to connect with these machines remotely (from within the same network) through ssh?

Thanks,
Robert

xowl 08-25-2005 12:27 PM

D
 
Did U enabled it at boot?


something like

chmod 744 /etc/rc.d/rc.sshd
/etc/rc.d/rc.sshd start

flashingcurser 08-25-2005 11:16 PM

Slackware out of the box should be running sshd. Durring the install did you choose not to run the service? (see above)

If you did not install it-- check pkgtool-- from a root command line--

pkgtool

then choose view and look for "openssh", if it is not installed, download it from ftp://salckware.com

So if you know the individual IP's, then you should have no problem connecting to them from a machine within your local network.

Check to see if sshd is running on each machine. From a root command line:

ps aux | less

Look around for sshd.


If all that is ok, show us your config.


:)

Robert154 08-26-2005 08:51 PM

Hi all,

I have checked for sshd and it is running. The configuration file is default configuartion i.e all of the entries are commented. But it is the same case with the machine which is accessible through ssh and already have Slackware 10.1.

king111 08-26-2005 10:01 PM

Firewall, perhaps?


All times are GMT -5. The time now is 06:42 AM.