LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-26-2012, 06:39 PM   #1
DavidLee1A
Member
 
Registered: Dec 2012
Distribution: Debian Wheezy amd64
Posts: 123
Blog Entries: 12

Rep: Reputation: 5
setting up wireless trying to execute this .conf script to connect using WPA


I typed as per these directions in vi but I need to run the file now, cmod 0755 works for .sh files what do I use for .conf files?

"On a Linux client, install wpa_supplicant and create a configuration file, wpa_supplicant.conf (in Debian, installed in /etc/wpa_supplicant/) like the following:



update_config=1
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

network={
ssid="My_Secure_WLAN"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
group=CCMP
psk="PASSPHRASE"
priority=5
}
Again replace the parts in italics to match your setup and run wpa_supplicant -i eth1 -D wext -c /etc/wpa_supplicant/wpa_supplicant.conf (replacing eth1 with your wlan interface name and wext with the appropriate driver for your card; run wpa_supplicant without any options for more information). This command starts wpa_supplicant in the foreground and tries to connect to the WAP"
I need to (1) run this as a .conf file and (2) use the proper syntax to execute this script.
 
Old 12-26-2012, 10:01 PM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Hi DavidLee1A, Welcome to LQ. You don't run the conf file, you run wpa_supplicant with the options per the instructions and wpa_supplicant should read from the conf file. When you run the following you are telling wpa_supplicant where the conf file lives.

Code:
wpa_supplicant -i eth1 -D wext -c /etc/wpa_supplicant/wpa_supplicant.conf
The path to the conf file is in red. Hope that clears it up for you.

Good luck. ;-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Solved]Troubles setting up WPA wireless in 13.37 Snailatrice Slackware 4 05-21-2011 10:21 AM
[SOLVED] Connect to WPA wireless network dpp777 Linux - Wireless Networking 7 04-08-2011 07:44 PM
[SOLVED] Wireless WPA can't connect ripp3r Slackware 18 02-28-2010 01:24 PM
setting up wpa on wireless ?? stratotak Linux - Laptop and Netbook 3 12-29-2008 10:10 AM


All times are GMT -5. The time now is 07:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration