LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-28-2008, 04:03 AM   #1
Hughbert
LQ Newbie
 
Registered: Jun 2008
Location: Birmingham, UK
Distribution: Ubuntu Studio
Posts: 8

Rep: Reputation: 0
Setting up wired network on ubuntu not working


Hi all.

I know there have been a fair few threads on this one and I've looked at a lot of them but still can't seem to get anything working.

Anyway here's the situation. I've recently put Ubuntu 8.04 on my laptop (well, ubuntu studio but it's the same OS with extra programs) and it's my first time using linux. I don't have a wireless network setup at home so I've been trying to hook up my laptop to my 'SURFboard SB4100 Cable Modem' which is connected to my home PC.

In order to keep the PC running the net (and get help) while I do it I've left the ethernet cable in the back of the PC and I'm running a USB cable into my laptop which appears as eth2.

I've configured the network as dhcp, but I'm still a complete newbie at these things and I've not yet found a perfect guide on setting up so I've got a few questions. Here goes.

This is what my (windows) PC says about the network;
IP addr. 82.47.87.14
Subnet mask 255.255.254.10
Gateway 82.47.86.1
DHCP server 62.31.176.115
DNS servers 62.31.176.39
194.117.134.19
195.188.53.175

So I don't really know too much about this, but in the DNS tab on applications>network, should I be putting the DNS servers listed above or the IP address that appears in if config?

Here's what ifconfig says anyway
Code:
eth0      Link encap:Ethernet  HWaddr 00:0a:e4:eb:70:19  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:22 Base address:0x3000 

eth2      Link encap:Ethernet  HWaddr 00:04:bd:fc:45:69  
          inet6 addr: fe80::204:bdff:fefc:4569/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14130 errors:0 dropped:0 overruns:0 frame:0
          TX packets:193 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:688290 (672.1 KB)  TX bytes:14463 (14.1 KB)

eth2:avahi Link encap:Ethernet  HWaddr 00:04:bd:fc:45:69  
          inet addr:169.254.7.148  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1987 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1987 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:103482 (101.0 KB)  TX bytes:103482 (101.0 KB)
and route
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
link-local      *               255.255.0.0     U     0      0        0 eth2
default         *               0.0.0.0         U     1000   0        0 eth2
So sorry if this has been said before but I've been working on this problem for a few days now with no results so decided I should try and get some help. I've included as much info as I can, or at least the stuff that I've been looking at anyway.

Can anyone help?

Thanks
Hugh

Last edited by Hughbert; 06-29-2008 at 12:18 PM.
 
Old 06-28-2008, 04:25 AM   #2
Swagata Paul
Member
 
Registered: Jun 2008
Location: Kolkata, India
Posts: 57

Rep: Reputation: 15
Ok,

You have put a lots of info . don't do that.
Be specific.
I will solve ur problem.
Tell me 1st, What u want to do now? Want to connect to internet?
Or want to connect in a LAN?
 
Old 06-28-2008, 07:18 AM   #3
Hughbert
LQ Newbie
 
Registered: Jun 2008
Location: Birmingham, UK
Distribution: Ubuntu Studio
Posts: 8

Original Poster
Rep: Reputation: 0
Connect to the internet.

I thought putting lots of info was more helpful than saying 'waah my internet doesn't work', but to be fair I don't know what was important so I just put everything I could think of. Sorry about that.

Thanks
Hugh
 
Old 06-28-2008, 03:46 PM   #4
lwasserm
Member
 
Registered: Mar 2008
Location: Baltimore Md
Distribution: ubuntu
Posts: 184

Rep: Reputation: 41
On the laptop try

sudo dhclient eth2

What I am wondering is, does the cable modem even support using both its ethernet and usb ports at the same time? I'm not familiar with cable modems, but I know that on at least SOME DSL modems, you can't use both simultaneously. It is also possible that even if the modem hardware supports it, your ISP may not, or it may require configuring the modem differently. You can google for your modem and find a copy of the user manual to determine if this is possible.

What happens if you temporarily disconnect the desktop and plug the laptop into the modem via ethernet?

The 169.254.x.x addresses won't be used in your system, you can google "zeroconfig" or "avahi" for more information.

Your Windows desktop pc appears to be using DHCP to get an IP address. If your ubuntu laptop is using NetworkManager in it's default configuration, from what you have posted, everything should "just work" when you plug the laptop ethernet cable into the modem. If so, and assuming the ISP DHCP server will assign more than one IP address through the same modem, you could purchase a cheap ethernet switch to gain multiple etherent ports connecting to the modem.
 
Old 06-28-2008, 06:24 PM   #5
Hughbert
LQ Newbie
 
Registered: Jun 2008
Location: Birmingham, UK
Distribution: Ubuntu Studio
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks lwasserm I'll try that when I get the chance. Off to google my modem now...

Cheers
Hugh
 
Old 06-29-2008, 12:17 PM   #6
Hughbert
LQ Newbie
 
Registered: Jun 2008
Location: Birmingham, UK
Distribution: Ubuntu Studio
Posts: 8

Original Poster
Rep: Reputation: 0
So sudo dhclient eth2 has this to say;

Code:
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth2/00:04:bd:fc:45:69
Sending on   LPF/eth2/00:04:bd:fc:45:69
Sending on   Socket/fallback
DHCPDISCOVER on eth2 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on eth2 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth2 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth2 to 255.255.255.255 port 67 interval 16
DHCPDISCOVER on eth2 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth2 to 255.255.255.255 port 67 interval 7
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
Which I'm guessing means this didn't work, and the laptop couldn't find the network.

Moving the ethernet cable from the desktop to the laptop, or unplugging the ethernet cable while the USB is connected to the laptop didn't work either, ifconfig gives the same results (although the ip address might have been slightly different, it's still a 169.254.x.x).

So I'm guessing this means that my modem wont assign more than one ip address to different computers, or won't recognise my laptop maybe? If so, does that mean there's no way I'm going to connect to my home internet with my laptop?

Off to do a bit more research but any ideas are welcome
Hugh
 
Old 07-02-2008, 04:35 AM   #7
Tuxofunic
LQ Newbie
 
Registered: Mar 2008
Location: Ukraine
Distribution: Debian, ubuntu
Posts: 14

Rep: Reputation: 0
Oh yes - I have the same problem with my laptop network card. In windows all works pretty. My network provider uses DHCP server to give an IP. It gives IP via MAC address of my network card.
The same output as above of DHClient while probing in Debian, Ubuntu, Mandriva and FreeSpire. Cant`t assign IP via dhcp.
 
Old 07-02-2008, 09:01 AM   #8
Tuxofunic
LQ Newbie
 
Registered: Mar 2008
Location: Ukraine
Distribution: Debian, ubuntu
Posts: 14

Rep: Reputation: 0
Hi ppl ! I`ve resolved its problem.
Just removed avahi-daemon from startup runlevel, removed /etc/avahi folder.
In Gnome NetworkManager sat up dhcp usage to designate ip.
Now things`re good, i have only one ethernet card configured. Try this !
 
Old 07-02-2008, 12:31 PM   #9
Hughbert
LQ Newbie
 
Registered: Jun 2008
Location: Birmingham, UK
Distribution: Ubuntu Studio
Posts: 8

Original Poster
Rep: Reputation: 0
Hi tuxofonic

Just to clarify (I'm a noob, remember ) if I get rid of the /etc/avahi folder then it might work?

Also is startup runlevel a script/file in the linux filesystem? And avahi-daemon a part of that script? Or have I got that totally wrong?

Thanks for the help - sorry if my questions are pretty basic.
Hugh
 
Old 07-02-2008, 03:04 PM   #10
skuzye
Member
 
Registered: Jul 2008
Location: São Paulo - Brazil
Distribution: Fedora 17
Posts: 97

Rep: Reputation: 15
Unhappy This may helps... sorry if it doesn't

Quote:
Originally Posted by Tuxofunic View Post
Hi ppl ! I`ve resolved its problem.
Just removed avahi-daemon from startup runlevel, removed /etc/avahi folder.
In Gnome NetworkManager sat up dhcp usage to designate ip.
Now things`re good, i have only one ethernet card configured. Try this !
I don't see any need to remove /etc/avahi, if avahi-daemon is not running it shouldn't be able to use these config files anyways.

@Hughbert

avahi-daemmon is a program that runs as a service (daemon), you can prevent it of running simply by modifying it's permissions.
Use:

Code:
chmod -x file
Though, I'm also a beginner and I don't use Ubuntu (I don't know if this daemon exists in Slack) I cannot tell you exactly where it is located.

You can try doing:

Code:
locate avahi
I hope I could help something.
 
Old 07-02-2008, 09:28 PM   #11
lwasserm
Member
 
Registered: Mar 2008
Location: Baltimore Md
Distribution: ubuntu
Posts: 184

Rep: Reputation: 41
I agree with skuzye, don't remove any avahi folders. I would not chmod anything either. Google avahi or read the description in synaptic, it is a service you probably want to have available, especially on a laptop. Normally it does not interfere with other network functions. If you still want to remove it the better way is to uninstall it via synaptic or dpkg, or to just stop it from running for debugging purposes, you can type "sudo avahi-daemon --kill". man avahi-daemon for more info.

Did you have any luck finding an operation manual for your modem? It's possible that it doesn't use a plain ethernet protocol, perhaps it needs pppoe or something running on the computer. Perhaps you can check your windows system to see. Also, does the laptop connect to other ethernet networks without trouble? d
 
Old 07-03-2008, 12:41 AM   #12
Tuxofunic
LQ Newbie
 
Registered: Mar 2008
Location: Ukraine
Distribution: Debian, ubuntu
Posts: 14

Rep: Reputation: 0
Thumbs up yes sure

Quote:
Originally Posted by skuzye View Post
I don't see any need to remove /etc/avahi, if avahi-daemon is not running it shouldn't be able to use these config files anyways.

@Hughbert

avahi-daemmon is a program that runs as a service (daemon), you can prevent it of running simply by modifying it's permissions.
Use:

Code:
chmod -x file
Though, I'm also a beginner and I don't use Ubuntu (I don't know if this daemon exists in Slack) I cannot tell you exactly where it is located.

You can try doing:

Code:
locate avahi
I hope I could help something.
Thanks for your quote. I just saw the problem in avahi, its daemon always make one more eth0:avahi canfigured card with wrong IP addresses & netmask. I desided this is only reason my internet does not work. Of course, now, i gonna correct the way to make it solution. Try to remove avahi, chmoded it, etc. Just note that. I even not sure if avahi could ever be a reason. But.. fact is ...
Anyway I`ll follow your advice. Thanks
 
Old 07-03-2008, 09:12 PM   #13
skuzye
Member
 
Registered: Jul 2008
Location: São Paulo - Brazil
Distribution: Fedora 17
Posts: 97

Rep: Reputation: 15
@Tuxofunic


You know, the best thing to do is like @lwasserm said: reading man or google..Also, it would be wise to backup any change, just in case... hehe

Unfortunately I don't have any knowledge about this subject so I cannot help you further. I'm glad something that I posted could have been usefull to anyone.


Good luck solving your problem, and I'd apreciate if you report any progress, It's getting interesting

Skuzye

Last edited by skuzye; 07-03-2008 at 09:16 PM.
 
Old 07-04-2008, 04:33 AM   #14
Hughbert
LQ Newbie
 
Registered: Jun 2008
Location: Birmingham, UK
Distribution: Ubuntu Studio
Posts: 8

Original Poster
Rep: Reputation: 0
Hey guys

Thanks for all the posts. What I've done so far;

Tried moving the avahi folder out of /etc/ (effectively removing it) but putting it somewhere if I wanted to put it back. Didn't work unfortunately, still getting no connection so I moved it back.

Strangely after moving the avahi folder, although it stopped avahi running on whichever eth port was being used (i.e. eth0 or eth2) it still seemed to generate an avahi IP/mask/gateway for the unused port. Any ideas what that means?

I've found several rubbish 'user manuals' for my modem which didn't yield much info but eventually found one which did, and it confirmed that my cable modem will support multiple users, and is based on DHCP so should just 'plug and play'. However it said to contact my internet supplier for configuring for multiple users, so I'm going to try that; could be my internet was just configured wrong and I've bothered you all over nuffin'.

I guess we'll see.

Thanks
Hugh
 
Old 07-04-2008, 09:00 AM   #15
skuzye
Member
 
Registered: Jul 2008
Location: São Paulo - Brazil
Distribution: Fedora 17
Posts: 97

Rep: Reputation: 15
Quote:
Originally Posted by Hughbert View Post
Hey guys

Thanks for all the posts. What I've done so far;

Tried moving the avahi folder out of /etc/ (effectively removing it) but putting it somewhere if I wanted to put it back. Didn't work unfortunately, still getting no connection so I moved it back.

Strangely after moving the avahi folder, although it stopped avahi running on whichever eth port was being used (i.e. eth0 or eth2) it still seemed to generate an avahi IP/mask/gateway for the unused port. Any ideas what that means?

I've found several rubbish 'user manuals' for my modem which didn't yield much info but eventually found one which did, and it confirmed that my cable modem will support multiple users, and is based on DHCP so should just 'plug and play'. However it said to contact my internet supplier for configuring for multiple users, so I'm going to try that; could be my internet was just configured wrong and I've bothered you all over nuffin'.

I guess we'll see.

Thanks
Hugh
Ok, let's start again...

You can access internet through ethernet (windows), so your modem is working there, have you tried using dhcp on ethernet without connecting your windows machine to the usb port?

Quote:
eth2 Link encap:Ethernet HWaddr 00:04:bd:fc:45:69
inet6 addr: fe80::204:bdff:fefc:4569/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14130 errors:0 dropped:0 overruns:0 frame:0
TX packets:193 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:688290 (672.1 KB) TX bytes:14463 (14.1 KB)

eth2:avahi Link encap:Ethernet HWaddr 00:04:bd:fc:45:69
inet addr:169.254.7.148 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
As you can see eth2 doesnt have an ip address to itself but eth2:avahi has, so you could try to connect using eth2:avahi instead of eth2...

also, i'm not really sure if eth2:avahi has to have detected a gateway...

try this and see what happens:

Code:
sudo route add dev eth2:avahi

Skuzye
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wired network problem in Ubuntu (gusty) maverick_awp Linux - Networking 2 07-07-2008 08:47 AM
Setting up a Wi-Fi network between Ubuntu and Nokia E61i CrownAmbassador Linux - Hardware 0 05-09-2008 06:36 AM
xubuntu wired network laptop not seeing my ubuntu box larryfroot Linux - Networking 0 03-17-2008 04:20 PM
Can't get my WIRED PCMCIA network card working in Knoppix ploskinj Linux - Networking 1 04-01-2007 01:17 AM
Neither wireless or wired network is working hsimah Linux - Wireless Networking 9 04-12-2006 05:58 AM


All times are GMT -5. The time now is 11:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration