LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-10-2003, 09:49 AM   #1
MattLaw
Member
 
Registered: Sep 2003
Posts: 34

Rep: Reputation: 15
Question Setting up Samba


Hi, I setup Samba on my server and am using Mandrake 9.1 on the clients. The client recognises the Samba server but wont let me write to it. I am wondering do you have to edit the "smb.conf" or should it just pick up through wizards?

Here is my existing smb.conf file:



# Global parameters
[global]
workgroup = MDKGROUP
server string = Samba Server %v
encrypt passwords = Yes
map to guest = Bad User
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = cups
dns proxy = No
printer admin = @adm
printing = cups

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
guest ok = Yes
printable = Yes
print command = lpr-cups -P %p -o raw %s -r # using client side printer drivers.
browseable = No

[print$]
path = /var/lib/samba/printers
write list = @adm root
guest ok = Yes

[pdf-generator]
comment = PDF Generator (only valid users)
path = /var/tmp
printable = Yes
print command = /usr/share/samba/scripts/print-pdf %s ~%u //%L/%u %m %I "%J" &

[DOCUMENTS]
comment = /home/matthew/Documents
path = /home/matthew/Documents
guest ok = Yes
wide links = No
 
Old 09-10-2003, 09:57 AM   #2
angelrod
Member
 
Registered: Oct 2002
Location: Mexico
Distribution: RedHat 9.0 and SuSE 8.1
Posts: 229

Rep: Reputation: 30
You have to add a line to your share like:

writable = yes

And give access to some users:

valid users = user1 user2 user3
 
Old 09-11-2003, 02:52 AM   #3
collen
Member
 
Registered: Jun 2003
Location: /
Distribution: Fedora/Debian
Posts: 86

Rep: Reputation: 15
Or set a guest user, coz in your [DOCUMENTS] share you say
guest ok = yes, but in the [global] you say
map to guest = Bad User..

also make sure you added the right users with smbpasswd.

and ofcoz' you have to make sure the rwx rights are ok for
o/g/w ..


you should make a open share with all permisions wide open
and from there on do some tests with what is ok for you and not.

have fun

Collen
 
Old 09-11-2003, 03:29 AM   #4
MattLaw
Member
 
Registered: Sep 2003
Posts: 34

Original Poster
Rep: Reputation: 15
Thumbs up

Thanks a million, will try
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up Samba under 5.0.4 Linux31 Ubuntu 2 07-03-2005 11:37 PM
Help setting up Samba... CaptainRegular Linux - Networking 2 04-05-2005 07:03 AM
Setting up Samba kicken Linux - Newbie 3 06-07-2004 06:08 PM
setting up samba true_atlantis Linux - Newbie 1 05-28-2004 06:53 AM
Setting up Samba Spyder_Snyper Linux - Networking 2 01-24-2004 09:23 PM


All times are GMT -5. The time now is 04:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration