LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-29-2003, 07:13 PM   #1
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Rep: Reputation: 30
Setting up Samba


I'm trying to set up a samba server on my network. I do all of my configurations, but when I run smbclient to see if the server is working correctly, I get this is error:

NT_STATUS_LOGON_FAILURE

I have no idea what this means. I did some googling on it, but nothing really useful showed up. Any ideas what this is and what I can do to fix it?
 
Old 10-29-2003, 11:08 PM   #2
xexix
Member
 
Registered: Oct 2003
Location: Long Island, N.Y., U.S.A
Distribution: Gentoo, Slackware
Posts: 79

Rep: Reputation: 15
This means exactly what it says - you are not providing the proper password for the user (you knew that though). The problem is that by default the samba server uses 'nobody' as the default guest user. 'nobody' has a password field set to 'x' in /etc/password. nobody cannot be used as a login account.

Here is what i did to enable a guest(password less) login:

edit /etc/samba/smb.conf
remove leading ';' in front of the 'guest account' setting
and changed it to:
guest account = smbguest

create a guest account smbguest in /etc/passwd
useradd smbguest

edit /etc/passwd (as root)
remove second field 'x'. remove home directory. you should be left with something like:

smbguest::1001:100:::

My intend was to setup a shared folder using a guest account that i only i can write to but can be read by anyone in the office. here is some relevant stuff from my smb.conf:

workgroup = WORKGROUP
hosts allow = 192.168.1. 127.
guest account = smbguest

[shared]
comment = Shared
path = /usr/local/shared
browseable = yes
writable = yes
public = yes
guest ok = yes
write list = @wheel

Also, by default running smbclient resorts to using $USER environment variable as the user. If that user doesn't exist on the samba server, you won't be able to login. To change the user:
smbclient //server_name/share_folder -U bob%password

the %password is optional.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up Samba under 5.0.4 Linux31 Ubuntu 2 07-04-2005 12:37 AM
Help setting up Samba... CaptainRegular Linux - Networking 2 04-05-2005 08:03 AM
Setting up Samba kicken Linux - Newbie 3 06-07-2004 07:08 PM
setting up samba true_atlantis Linux - Newbie 1 05-28-2004 07:53 AM
Setting up Samba Spyder_Snyper Linux - Networking 2 01-24-2004 10:23 PM


All times are GMT -5. The time now is 08:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration