LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-14-2005, 06:01 PM   #1
shodekiagari
Member
 
Registered: Nov 2003
Posts: 47

Rep: Reputation: 15
Setting up a router under Linux


This is probably one of the simpler questions out there, but I'm stumped. I can't find any guides on how to set up a router under linux....

The way it's currently setup is wall jack --> modem --> router --> computer.

The instruction manual tells me to go to routerlogin.net for setup. However, when I do this my connection times out. I can see my dsl modem happily connected, and I'm pretty sure the router itself is receiving the signal, but somewhere between the router and my computer something is going wrong.

I'm currently running ubuntu (debian-based) linux with an MR814 Netgear router. The router says it's linux compatible and it should be as it's a web-based setup. I just need to get to that one website!

So, what should I do? Where do I start to get my computer to talk to the router? Any advice? I've tried google, but just about everything is on how to make your own linux router, not how to set up a linux router.

Thank you.
 
Old 01-14-2005, 06:28 PM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

Usually, you can just go to "http://<the IP address of the router>"

Dave
 
Old 01-14-2005, 07:23 PM   #3
ghazz
Member
 
Registered: Jan 2005
Location: Akron, OH
Distribution: Slackware 10
Posts: 32

Rep: Reputation: 15
Troubleshooting

Greetings.

Just to make sure you do not have a hardware problem, I'd check the lan connection or wifi lights on the back of your box(nic/wifi card), check connections to the router and modem(if applicable), if anything is loose, well, connect, heh.

Onward...if all checks out there, try some networking procedures: ping the computer, address 127.0.0.1 If it checks, find the IP for the router and ping that address. Usually a 192.168.x.x If you are able to ping the router you should be able to connect to the router via what "ilikejam" stated. If you cannot ping the router, try shutting down all the hardware and your computer system, and bring up the network first -- before bringing up your computer.

If nothing works, perhaps there is something unconfigured or incorrectly configured in your network settings... PPPoE settings perhaps?

I didn't check to see if your router is wireless and have not experienced a wireless network with Linux, so I am quite bias to wired network troubleshooting. My wireless exp extends into the Windows OS only. I will breach that barrier, hopefully very soon!

Best of Luck!

-ghazz
 
Old 01-15-2005, 01:20 AM   #4
shodekiagari
Member
 
Registered: Nov 2003
Posts: 47

Original Poster
Rep: Reputation: 15
Hello to both of you and thank you very much for helping me.

Alright, I've connected everything together. All the lights that should be on, are on. The ip of my router is printed on the back of my router so I tried pinging it or connecting to it via the web. No dice. I was able to ping 127.0.0.1 with the router plugged in but everything else gave me the error message "Destination Host Unreachable"

I think what's going wrong is that my computer is already configured for adsl. I don't run any startup scripts as far as I know... No roaring penguin or anything like that. I just have my etc/networks/interface filled out and my /etc/resolv.conf filled out. Could that be interfering with my router on startup? I duno if this information will help, but as soon as I unplug the router and replug the modem directly into my computer I have internet access

Am I missing something obvious? Am I doing something dumb? Both? Neither?

Thank you for helping me.
 
Old 01-15-2005, 02:26 AM   #5
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
What do you get when you run 'route' (as root)?

Dave
 
Old 01-15-2005, 02:39 AM   #6
shodekiagari
Member
 
Registered: Nov 2003
Posts: 47

Original Poster
Rep: Reputation: 15
When I run route as root I get the following (the first response is immediate, the second line comes after a delay).

shodekiagari@shodekiagari:~ $ sudo route
Password:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.0 U 0 0 0 eth0
default 64.136.xxx.1 0.0.0.0 UG 0 0 0 eth0


I tried pinging "64.136.xxx.1" just for fun and I got the unreachable message.
 
Old 01-15-2005, 07:14 AM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,890

Rep: Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743
If the internet connections works when you plug the PC into the modem then it must be configured for DSL.

Are there any GUI wizards for configuring networks? All you need is a LAN connection using DHCP and the use the router's IP address as the gateway. The router must be configured for the type of DSL on its WAN side.
 
Old 01-15-2005, 11:09 PM   #8
davichris23
LQ Newbie
 
Registered: Jul 2004
Location: BFE Idaho
Distribution: SuSE 9.0 Pro
Posts: 1

Rep: Reputation: 0
From the way it sounds is that your computer needs to be on the same subnet as your router to communicate with it, example dsl ip: 69.20.xxx.xxx, router ip is 192.168.1.1 so your computer ip needs to be something like 192.168.1.xxx to communicate with the netgear router. your router will have two ip's in it, one for the dsl/internet and one for the private lan
 
Old 01-16-2005, 02:45 AM   #9
shodekiagari
Member
 
Registered: Nov 2003
Posts: 47

Original Poster
Rep: Reputation: 15
Thank you everyone. I solved it! The clue you gave me was the fact that I needed to mess around with ip address.

Noting that my router's ip was 192.168.0.1 I issued the following command to change my computers ip address. "sudo ifconfig eth0 192.168.0.2"

I was then able to access the modem by going to http://192.168.0.1/welcome.htm It easily self-configured and it's now working a treat! I'm so happy! This is awesome. My router is working! Now all I've got to do is get it to talk to my windows 98 box and I'm set!

*dances*

Thanks everyone for helping out, your help means a whole lot to me!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting linux as Router puniti Linux - Networking 2 07-26-2003 09:01 AM
Setting linux to use router nigma Linux - Networking 6 05-04-2003 11:59 PM
Setting Up My Router In Linux! NeedsHelp Linux - Networking 2 08-28-2002 10:56 PM
Setting up Linux as a router planew Linux - Networking 1 02-07-2002 12:07 PM
Setting up a linux router? overide2k Linux - Networking 3 11-12-2001 09:46 PM


All times are GMT -5. The time now is 11:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration