LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Server responds to all configured ip addresses when the cable isn't plugged in. (http://www.linuxquestions.org/questions/linux-networking-3/server-responds-to-all-configured-ip-addresses-when-the-cable-isnt-plugged-in-489412/)

Mike_the_Man 10-04-2006 12:19 PM

Server responds to all configured ip addresses when the cable isn't plugged in.
 
I have two ips (192.168.1.10 and 192.168.100.10) on two different nics configured on a redhat ES 3 server. Only one of the network cables are plugged in on one of the nics. If I ping or arping that server from another machine on either of the ip's, the server responds. Is this supposed to happen by design? If it is, is there a way I can stop it? I only want the server to respond to traffic if it comes in on the appropriate network interface.

I tried setting "net.ipv4.conf.all.arp_filter = 1" in /etc/sysctl.conf and rebooted the servers, but that did not work.

Any help would be greatly appreciated.

marozsas 10-04-2006 02:28 PM

Try to disable the ip forward.

Code:

echo 0 > /proc/sys/net/ipv4/ip_forward
That way the linux router will not route packets from an interface to another one.

Mike_the_Man 10-04-2006 02:37 PM

Quote:

Originally Posted by marozsas
Try to disable the ip forward.

Code:

echo 0 > /proc/sys/net/ipv4/ip_forward
That way the linux router will not route packets from an interface to another one.

This is already disabled. After doing some research, there is a parameter called arp_ignore that may solve my problem, but it is not available in Redhat 3. Redhat support suggests using arp tables, but it seems to me that there should be a better resolution. Has anyone else seen this problem?


All times are GMT -5. The time now is 06:33 PM.