LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-04-2006, 12:19 PM   #1
Mike_the_Man
Member
 
Registered: Jan 2001
Location: work
Distribution: Redhat, Mandrake
Posts: 33

Rep: Reputation: 15
Server responds to all configured ip addresses when the cable isn't plugged in.


I have two ips (192.168.1.10 and 192.168.100.10) on two different nics configured on a redhat ES 3 server. Only one of the network cables are plugged in on one of the nics. If I ping or arping that server from another machine on either of the ip's, the server responds. Is this supposed to happen by design? If it is, is there a way I can stop it? I only want the server to respond to traffic if it comes in on the appropriate network interface.

I tried setting "net.ipv4.conf.all.arp_filter = 1" in /etc/sysctl.conf and rebooted the servers, but that did not work.

Any help would be greatly appreciated.
 
Old 10-04-2006, 02:28 PM   #2
marozsas
Senior Member
 
Registered: Dec 2005
Location: Campinas/SP - Brazil
Distribution: SuSE, RHEL, Fedora, Ubuntu
Posts: 1,393
Blog Entries: 1

Rep: Reputation: 63
Try to disable the ip forward.

Code:
echo 0 > /proc/sys/net/ipv4/ip_forward
That way the linux router will not route packets from an interface to another one.
 
Old 10-04-2006, 02:37 PM   #3
Mike_the_Man
Member
 
Registered: Jan 2001
Location: work
Distribution: Redhat, Mandrake
Posts: 33

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by marozsas
Try to disable the ip forward.

Code:
echo 0 > /proc/sys/net/ipv4/ip_forward
That way the linux router will not route packets from an interface to another one.
This is already disabled. After doing some research, there is a parameter called arp_ignore that may solve my problem, but it is not available in Redhat 3. Redhat support suggests using arp tables, but it seems to me that there should be a better resolution. Has anyone else seen this problem?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Detect network cable being plugged in Vgui Slackware 7 01-03-2009 06:22 AM
if( ethernet-cable-is-plugged-in ) { ... mrtwice Linux - Networking 13 10-08-2006 02:57 PM
Server responds to 2 IP addresses albracco Linux - Networking 3 03-17-2006 12:07 PM
What happens when a network cable is plugged in ? balajipriya Linux - Networking 1 08-12-2004 09:10 AM
dhcpcd, no network cable plugged in meyert Slackware 3 04-28-2004 08:34 PM


All times are GMT -5. The time now is 12:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration