Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 07-27-2006, 03:01 PM   #1
Registered: Apr 2004
Location: Costa Rica
Distribution: slack current with (still off the hook)
Posts: 284

Rep: Reputation: 33
SAMBA, WINBIND and KERBEROS against Windows 2000 Active Directory


I really hope you can help me with the solution or at least ideas because I ran out.

Here is the scenario:

4 Mandriva servers running samba +kerberos and windbind they all authenticate against a Windows 2000 Active Directory.

All works fine but just a few minutes ago one of them, yes just one, stopped authenticating one user.

I check the AD user settings and they were OK, in fact I tested that specific account on the other servers and they where fine.

Now I stopped the smb service and deleted all the .tdb files, restart smb, restart winbind and still nothing.

After struggling with it I decided to reboot it, and if got fixed but the whole point is that is an extremly odd behaviour and I really want to know what might cause it.
2 of the servers are on a hosting facility for backup and if one of those ever have the same problem will be a 2 hour drive to reboot the darn thing.

Thanks a lot.
Old 07-29-2006, 12:46 AM   #2
Senior Member
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46

If your asking why this 1 user was having issues, my guess would be that the user's kerberos ticket expired or was rejected for some reason. Rebooting the server probably didn't fix it, the client renewed the krb ticket on its own since the ticket was lost/expired/rejected. Without examining logs on both sides, the only thing I can do is speculate.
Old 07-29-2006, 12:52 AM   #3
Registered: Jul 2006
Location: Maryland, USA
Distribution: Fedora, PCLinuxOS
Posts: 582

Rep: Reputation: 65
You could set "syslog = 4" in your /etc/samba/smb.conf file and then restart samba.

Is there anything interesting in the most recent /var/log/samba/*.log files or /var/log/syslog?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Import users from windows 2000 active directory serabut Linux - Networking 0 05-26-2006 06:55 AM
How i connect REDHAT SERVER with active directory of windows 2000 sfahadtariq Linux - Networking 1 01-07-2006 06:05 AM
samba ldap winbindd kerberos with active directory errors xtrusion Linux - Software 0 03-21-2005 05:24 PM
Samba 3.0.4 with winbind and active directory upgrade problem jhibbets Red Hat 0 08-16-2004 12:24 PM
Opinion, does samba+winbind work well with windows 2000+active directory? tisource Linux - Networking 5 02-23-2003 02:34 AM

All times are GMT -5. The time now is 08:26 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration