LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-12-2003, 06:59 AM   #1
mooler
LQ Newbie
 
Registered: Oct 2003
Posts: 19

Rep: Reputation: 0
Samba + SWAT


Having problems getting swat running. SWAT is installed.

Samba is installed and running the same with xinetd but when typing http://192.169.0.2:901 in my browser swat donīt run.

Any ideas what this might about?

Got the advice to test xsmBROWSER and installed that but I donīt now how that works and there is no man to it?

Iīm pretty new to linux so thatīs probobly the answer but I need some guidance.
THX
 
Old 11-12-2003, 12:02 PM   #2
iainr
Member
 
Registered: Nov 2002
Location: England
Distribution: Ubuntu 9.04
Posts: 631

Rep: Reputation: 30
Try http://127.0.0.1:901

By default swat will only accept connections from localhost.
 
Old 11-12-2003, 12:23 PM   #3
mooler
LQ Newbie
 
Registered: Oct 2003
Posts: 19

Original Poster
Rep: Reputation: 0
Sorry to say that did'n work any other ideas?
 
Old 11-12-2003, 12:31 PM   #4
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Rep: Reputation: 30
Quote:
Originally posted by iainr
Try http://127.0.0.1:901

By default swat will only accept connections from localhost.
my default only accepts remote
 
Old 11-12-2003, 08:49 PM   #5
tornadoburn
LQ Newbie
 
Registered: Nov 2003
Location: Montreal, Canada
Distribution: RH 7.1
Posts: 23

Rep: Reputation: 15
In the SWAT file located in etc/xinetd.d/ make sure that un comment out the following line:
# disable =yes

second whether or you have a LAN make sure:
only_from = 192.168.1.0

Finally make sure that your host file is intact and it should look something like this:
127.0.0.1 MyLinuxBox localhost

From here you can just type into your prefered browser http://MyLinuxBox:901

But I suggest you install Webmin - much more efficent way of taking care of this stuff.
 
Old 11-13-2003, 09:46 AM   #6
mooler
LQ Newbie
 
Registered: Oct 2003
Posts: 19

Original Poster
Rep: Reputation: 0
Ok I 'll look in to the webadmin (don't really now what that is ) thing but just incase here's the swat file I have. If there's something obvious wrong with it please let me now. Have tried it with default uncommented with on and off but no luck so far.

THX

# default: off
# description: SWAT is the Samba Web Admin Tool. Use swat \
# to configure your Samba server. To use SWAT, \
# connect to port 901 with your favorite web browser.
service swat
{
port = 901
socket_type = stream
wait = no
only_from = 192.168.0.2
user = root
server = /usr/sbin/swat
log_on_failure += USERID
disable = no
}
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Samba/SWAT driesel Linux - Newbie 3 02-13-2005 09:33 AM
Samba and swat james.farrow Linux - Networking 7 04-04-2003 11:27 AM
Swat Samba whatever! theguy311 Linux - Software 8 01-25-2003 01:42 PM
SAMBa and SWAT Snake007uk Linux - General 8 05-16-2002 07:30 PM
samba swat has me chens_83 Linux - General 2 03-22-2002 06:31 PM


All times are GMT -5. The time now is 01:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration