LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 04-28-2006, 03:21 AM   #1
rubella
Member
 
Registered: Sep 2005
Location: Europe
Distribution: debian sarge
Posts: 65

Rep: Reputation: 15
Samba - slow as hell


hey

someone an idea what's going wrong in the following setup?
We are running a basic samba on ubuntu 5.10. when one person connects, it's going very very slow, maximum 300kBps. When a second user starts a filetransfer while user1 is busy with his filetransfer, he gets high speeds, and the first one, with his slow connection, has also a speedboost to full speed (8MBps). When one of the 2 users disconnect, the other one drops again to very low speeds... verrrry strange.

We do not use rocket-science configfiles, the default one, with following extension:

[fileserver]
comment = A office fileserver
guest ok = yes
guest only = yes
path = /fileserver
browseable = yes
writable = yes
create mask = 0700
directory mask = 0700
 
Old 04-28-2006, 07:26 AM   #2
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
you need to post the "global" section of your file.....
 
Old 05-03-2006, 05:17 AM   #3
rubella
Member
 
Registered: Sep 2005
Location: Europe
Distribution: debian sarge
Posts: 65

Original Poster
Rep: Reputation: 15
hey

hope this is helpfull. thx.


Quote:
#======================= Global Settings =======================

[global]
workgroup = TEST
server string = %h server (a Samba Fileserver)
dns proxy = no
log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
panic action = /usr/share/samba/panic-action %d
security = share
encrypt passwords = true
passdb backend = tdbsam guest

obey pam restrictions = yes

guest account = ftp
invalid users = root
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .

socket options = TCP_NODELAY


[fileserver]
comment = A Q-tastic office fileserver
guest ok = yes
guest only = yes
path = /fileserver
browseable = yes
writable = yes
create mask = 0700
directory mask = 0700

Last edited by rubella; 05-03-2006 at 08:18 AM.
 
Old 05-03-2006, 06:39 AM   #4
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
could you maybe do "grep -v "#" smb.conf on the file... so we can see without all the comment lines....
 
Old 05-03-2006, 08:19 AM   #5
rubella
Member
 
Registered: Sep 2005
Location: Europe
Distribution: debian sarge
Posts: 65

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by satinet
could you maybe do "grep -v "#" smb.conf on the file... so we can see without all the comment lines....
et voila
 
Old 05-03-2006, 08:34 AM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 11,812

Rep: Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923
Let's hope that was "^#" ...
(and yes, I have nothing constructive to contribute)
 
Old 05-03-2006, 08:43 AM   #7
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
just wondering why you're using "share level" security....

what version of samba is it?

i'm not sure about the "obey pam restrictions" and how that is relevant to share level security.
 
Old 05-03-2006, 10:31 AM   #8
rubella
Member
 
Registered: Sep 2005
Location: Europe
Distribution: debian sarge
Posts: 65

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by satinet
just wondering why you're using "share level" security....

what version of samba is it?

i'm not sure about the "obey pam restrictions" and how that is relevant to share level security.

i am working with version 3.0.14a, distributed with ubuntu 5.10.

we are using share level cause everyone in the office has full access on it.

i have commented out following params, without any success:

encrypt passwords = true
passdb backend = tdbsam guest
obey pam restrictions = yes
socket options = TCP_NODELAY
 
Old 05-03-2006, 10:37 AM   #9
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
it does seem very strange...... i really can't offer much insight. sorry....
 
Old 05-03-2006, 01:49 PM   #10
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Rep: Reputation: 30
I advice you to try this.

Put on [global] ok?

Code:
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
read raw = yes
write raw = yes
oplocks = yes
max xmit = 65535
dead time = 15
getwd cache = yes
 
Old 05-03-2006, 08:06 PM   #11
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 114Reputation: 114
Yes, I was going to focus on sockets and oplocks, but stormrider beat me to it.
 
Old 05-04-2006, 05:43 AM   #12
rubella
Member
 
Registered: Sep 2005
Location: Europe
Distribution: debian sarge
Posts: 65

Original Poster
Rep: Reputation: 15
hey guys, thx for the replies! unfortunatly, it did not fix the problem...
 
Old 05-04-2006, 10:06 AM   #13
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Rep: Reputation: 30
Did you restarted samba after making those changes?
 
Old 05-04-2006, 02:07 PM   #14
doublejoon
Member
 
Registered: Oct 2003
Location: King George, VA
Distribution: RHEL/CentOS/Scientific/Fedora, LinuxMint
Posts: 366

Rep: Reputation: 44
just a thought What duplex mode is your NIC? might be on half

do this just to see if its set on half duplex

Code:
ethtool eth0
if it is try this

Code:
ethtool -s eth0 speed 100 duplex full autoneg off
 
Old 05-05-2006, 02:06 AM   #15
rubella
Member
 
Registered: Sep 2005
Location: Europe
Distribution: debian sarge
Posts: 65

Original Poster
Rep: Reputation: 15
yes, i've restarted samba everytime i made some changes to the config.

output of ethtool:
Quote:
Settings for eth0:
Supported ports: [ MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Current message level: 0x000000ff (255)
Link detected: yes
so, it's on full duplex...

should it be a bug in samba, or something else? thx guys for all of your advices!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 10, XP, Samba and networking hell! jobiwan Linux - Networking 9 10-18-2004 02:26 PM
firefox running slow as hell ! (loading ppages slower than my 56k) qwijibow Linux - Software 6 08-24-2004 09:25 AM
Why the hell is linux running so slow! plz help sendas4 Linux - General 9 08-02-2004 08:00 PM
Samba Hell TrashCanMan Linux - Networking 3 07-14-2003 12:33 PM
Warning: elxlinux is slow as hell! jetblackz Linux - Software 1 03-24-2002 02:04 PM


All times are GMT -5. The time now is 09:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration