LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Samba - slow as hell (http://www.linuxquestions.org/questions/linux-networking-3/samba-slow-as-hell-439620/)

rubella 04-28-2006 03:21 AM

Samba - slow as hell
 
hey

someone an idea what's going wrong in the following setup?
We are running a basic samba on ubuntu 5.10. when one person connects, it's going very very slow, maximum 300kBps. When a second user starts a filetransfer while user1 is busy with his filetransfer, he gets high speeds, and the first one, with his slow connection, has also a speedboost to full speed (8MBps). When one of the 2 users disconnect, the other one drops again to very low speeds... verrrry strange.

We do not use rocket-science configfiles, the default one, with following extension:

[fileserver]
comment = A office fileserver
guest ok = yes
guest only = yes
path = /fileserver
browseable = yes
writable = yes
create mask = 0700
directory mask = 0700

satinet 04-28-2006 07:26 AM

you need to post the "global" section of your file.....

rubella 05-03-2006 05:17 AM

hey

hope this is helpfull. thx.


Quote:

#======================= Global Settings =======================

[global]
workgroup = TEST
server string = %h server (a Samba Fileserver)
dns proxy = no
log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
panic action = /usr/share/samba/panic-action %d
security = share
encrypt passwords = true
passdb backend = tdbsam guest

obey pam restrictions = yes

guest account = ftp
invalid users = root
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .

socket options = TCP_NODELAY


[fileserver]
comment = A Q-tastic office fileserver
guest ok = yes
guest only = yes
path = /fileserver
browseable = yes
writable = yes
create mask = 0700
directory mask = 0700

satinet 05-03-2006 06:39 AM

could you maybe do "grep -v "#" smb.conf on the file... so we can see without all the comment lines....

rubella 05-03-2006 08:19 AM

Quote:

Originally Posted by satinet
could you maybe do "grep -v "#" smb.conf on the file... so we can see without all the comment lines....

et voila ;)

syg00 05-03-2006 08:34 AM

Let's hope that was "^#" ... ;)
(and yes, I have nothing constructive to contribute)

satinet 05-03-2006 08:43 AM

just wondering why you're using "share level" security....

what version of samba is it?

i'm not sure about the "obey pam restrictions" and how that is relevant to share level security.

rubella 05-03-2006 10:31 AM

Quote:

Originally Posted by satinet
just wondering why you're using "share level" security....

what version of samba is it?

i'm not sure about the "obey pam restrictions" and how that is relevant to share level security.


i am working with version 3.0.14a, distributed with ubuntu 5.10.

we are using share level cause everyone in the office has full access on it.

i have commented out following params, without any success:

encrypt passwords = true
passdb backend = tdbsam guest
obey pam restrictions = yes
socket options = TCP_NODELAY

satinet 05-03-2006 10:37 AM

it does seem very strange...... i really can't offer much insight. sorry....

stormrider_may 05-03-2006 01:49 PM

I advice you to try this.

Put on [global] ok?

Code:

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
read raw = yes
write raw = yes
oplocks = yes
max xmit = 65535
dead time = 15
getwd cache = yes


jiml8 05-03-2006 08:06 PM

Yes, I was going to focus on sockets and oplocks, but stormrider beat me to it.

rubella 05-04-2006 05:43 AM

hey guys, thx for the replies! unfortunatly, it did not fix the problem...

stormrider_may 05-04-2006 10:06 AM

Did you restarted samba after making those changes?

doublejoon 05-04-2006 02:07 PM

just a thought What duplex mode is your NIC? might be on half

do this just to see if its set on half duplex

Code:

ethtool eth0
if it is try this

Code:

ethtool -s eth0 speed 100 duplex full autoneg off

rubella 05-05-2006 02:06 AM

yes, i've restarted samba everytime i made some changes to the config.

output of ethtool:
Quote:

Settings for eth0:
Supported ports: [ MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Current message level: 0x000000ff (255)
Link detected: yes
so, it's on full duplex...

should it be a bug in samba, or something else? thx guys for all of your advices!


All times are GMT -5. The time now is 04:33 PM.