LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-25-2008, 08:50 PM   #1
dbc001
Member
 
Registered: Jan 2004
Distribution: Slackware, Ubuntu
Posts: 97

Rep: Reputation: 15
Samba share name disappeared


My slackware server seems to have lost it's Netbios share name. I can still connect to it using it's IP address, but I can't get to \\server from windows or linux. Everything worked fine until a few days ago, and I dont remember making any changes lately!

from an Ubuntu command line on another machine, running
Code:
smbclient -L \\server
gives this error:
Code:
Connection to server failed (Error NT_STATUS_BAD_NETWORK_NAME)
running the same command with the IP address gives the full listing of shares though!

/etc/smb.conf seems to have the correct line:
Code:
netbios name = server
Can anyone help me troubleshoot this? I'm lost!

Thanks in advance,
dbc
 
Old 02-26-2008, 10:54 PM   #2
dbc001
Member
 
Registered: Jan 2004
Distribution: Slackware, Ubuntu
Posts: 97

Original Poster
Rep: Reputation: 15
found something in my logs...

found this in /var/log/samba/log.smbd :
Code:
[2008/02/26 23:01:21, 0] lib/util_sock.c:get_peer_addr(1222)
  getpeername failed. Error was Transport endpoint is not connected
[2008/02/26 23:01:21, 0] lib/util_sock.c:get_peer_addr(1222)
  getpeername failed. Error was Transport endpoint is not connected
Not sure if it's relevant though...
 
Old 02-26-2008, 11:26 PM   #3
livetoday
Member
 
Registered: Jun 2006
Location: India
Distribution: RHEL,Suse,Fedora
Posts: 106

Rep: Reputation: 15
It seems that nebios name service is not running..

check:

ps ax | grep nmbd

if does not show any running service...then you need to run manually nmbd -D or restart samba service......
 
Old 02-26-2008, 11:35 PM   #4
dbc001
Member
 
Registered: Jan 2004
Distribution: Slackware, Ubuntu
Posts: 97

Original Poster
Rep: Reputation: 15
yep - that was it

Thanks - 'ps ax | grep nmbd' gave this output:
Code:
 2915 pts/0    R+     0:00 grep nmbd
Then I ran 'nmbd start' to start it and everything is back up & running. thanks again!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't mount samba share and then write to the share calbazon Linux - Software 8 10-10-2010 02:35 AM
show the samba share but can't mount the share badall Linux - Server 3 05-30-2007 05:24 AM
searching samba share breaks connection to share Elomis Linux - Server 1 05-11-2007 01:28 AM
samba: linux mounted share = choppy playback, windows mounted share = smooth kleptophobiac Linux - Software 2 04-10-2005 09:23 AM
Simple Samba Setup, Share & Not Share timmywo Linux - Software 4 07-30-2004 08:27 AM


All times are GMT -5. The time now is 12:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration