LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-26-2004, 10:52 AM   #1
compassmanwi
LQ Newbie
 
Registered: Apr 2004
Posts: 13

Rep: Reputation: 0
Question SAMBA Server not accessible


Well, I tried piggy-backing on other threads, without success. So, I am starting my own thread. I have a RH9.0 server running SAMBA2.2.7a. I have a correct xinetd.conf. My smb.conf is correct as far as I can tell. I can see the server on XP and Win98 boxes, but I can't connect. I cannot connect through the XP Network Places wizard. (The server is found, but there are no shares.) The Win98 Network Neighborhood sees the server and knows it is a SAMBA server, but returns a 'Permissions' error. The user and password are correct for the SAMBA server.

There are also some odd behavior on the Linux side. I can connect with smbclient using the hostname of the server but not the netbios name of the SAMBA server. I can also connect to the XP and Win98 shares quite well. Also, when I run smbclient, the reports are different for the Linux and the Windows connections - in particular domain, workgroup and master browser.

I know that this SAMBA box was running at one time. I think some of the problems can be attributed to the 2.2.7a, which I believe was a security update some months ago. I have uninstalled/reinstalled without success. I have tried stripped down smb.conf with no results. I am to the point where I am thinking about moving to Fefora and hoping this will get sorted out. Can anyone give me some direction to go?

Thanks.
 
Old 08-26-2004, 12:34 PM   #2
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
Re: SAMBA Server not accessible

The permissions error could be either the settings in the smb.conf for the share are wrong, the samba username/password are wrong or the linux permissions on the directory you are trying to share with Samba are wrong. Have a look in the samba logs to see what's happening when you try to connect.

Here's an extract from my smb.conf - I've set up individual user directories on the linux box as /away/data/username. I have linux users for each Windows users - their linux passwords are different from the Samba passwords. I set the Samba passwords using 'smbpasswd -a username' using the Windows passwords for each user. Therefore when each user connects he sees a share called data that is their own personal data directory.

When setting up the linux directories it is essential that the GID is root (so that the Samba server can control the shares) - the UID is a normal user.

[data]
comment = Network data directories
path = /away/data/%u
create mask = 0640
directory mask = 0750
guest ok = no
printable = no
read only = no
browseable = yes

I found that the thing to do when setting up Samba is to take it a step at a time - start with a simple share that's browseable and writable by everyone and then change the settings one at a time until you get it doing what you want.
 
Old 08-26-2004, 02:15 PM   #3
tokehs
LQ Newbie
 
Registered: Aug 2004
Location: vienna
Distribution: Fedora Core 2
Posts: 18

Rep: Reputation: 0
sometimes it is the hardware

i had a similar problem and i tried really everthing i could until it almost drove me crazy... i will spare you the whole story and all the details but in the end i tried a different network interface card and and suddenly everthing worked even with XP... in the end i found out that the reason was an obviously not fully developed driver for the gigabit network card. so my tip for you is, especially when you are quite sure that your smb.conf is ok, not to waste a lot of time on the software side but to check the hardware first, try a different card or a different driver. i would even give it a try if the network adapter seems to behave normal with all other protocols and tasks, as it did in my case, just try!

i hope it will help!

regards tokehs
 
Old 08-26-2004, 07:50 PM   #4
UbErBeAsT
LQ Newbie
 
Registered: Jan 2004
Location: USA
Distribution: Slackware 9.1
Posts: 25

Rep: Reputation: 15
Did you remember to do a smbpasswd -a username as root?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba - Windows XP Problem (//Samba is not accessible) Covenent Linux - Networking 20 08-11-2011 04:07 PM
Samba not accessible tyrie Linux - Newbie 5 10-13-2005 08:28 AM
Samba mounts not accessible Milinu Linux - Newbie 2 09-06-2004 01:50 PM
Samba share not accessible Quercus Linux - Software 2 12-07-2003 08:43 AM
samba server is not accessible mla Linux - Software 5 09-30-2003 04:55 PM


All times are GMT -5. The time now is 09:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration