LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-18-2005, 09:06 AM   #1
aleida
LQ Newbie
 
Registered: Aug 2005
Location: cloud 9
Distribution: RHEL ES4, RHEL AS3, Xandros OCE
Posts: 2

Rep: Reputation: 0
Samba returns access denied error. wbinfo -t fails.


OS - RHEL AS 3.0
I built this machine to be a Squid server and have that functioning almost without an issue. Long story short = I need to use NTLM authentication.

Samba Version - 3.0.14

I have successfully added my machine to the domain using kinit. Whn I confirm kinit with klist -e, I am told that I have no tickets cached but do not receive an error message.

At this point in time, wbinfo -u and wbinfo -g work without an issue. Whenever I try wbinfo -t, I get an error "NT_STATUS_ACCESS_DENIED"

My smb.conf file reads:

#======================= Global Settings =====================================
[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = xxx.xxx
netbios name = blue-squid
hosts allow = 10.100.1.100
realm = xxx.xxx
server string = Linux Samba Server
security = ads
encrypt passwords = Yes
smb passwd file = /etc/passwd
password server = blue-w2k-ad
log file = /var/log/samba/%m.log
max log size = 0
#socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
preferred master = False
local master = No
domain master = False
dns proxy = No
wins server = 10.100.1.100
winbind separator = +
winbind enum users = yes
winbind enum groups = yes
winbind use default domain = yes
idmap uid = 10000-20000
idmap gid = 10000-20000

When I uncomment the 'socket options = ....' line I get the error NT_STATUS_UNSUCCESSFUL.

Here is where it gets weird: blue-w2k-ad, the password server lists three item in it's event logs pertaining to this wbinfo attempt....and they are all 'Success Audits.'


I have tried a slew of fixes that I have googled but none have remedied my situation. This seems to be a common error, any advice?

Thanks so much.
 
Old 08-18-2005, 09:19 AM   #2
XOR007
Member
 
Registered: May 2005
Location: Africa
Distribution: Ubuntu, Redhat 6.2 to 9, Centos 4, Suse 8 Ent.,Suse 9 Ent.
Posts: 51

Rep: Reputation: 15
I am not sure this is related, but why is your hosts allow set to only one ip? This might be an idiot reply but try to specifically allow both the w2k and Samba Server.
 
Old 08-18-2005, 09:49 AM   #3
aleida
LQ Newbie
 
Registered: Aug 2005
Location: cloud 9
Distribution: RHEL ES4, RHEL AS3, Xandros OCE
Posts: 2

Original Poster
Rep: Reputation: 0
The hosts allow line is, by default, commented out in the smb.conf file. I recently changed it to the one IP that you see. I changed it to the IPs of both machines. The results are the same with each of these three configurations.

Thanks though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba + CUPS "Access denied, unable to connect" error lirik Linux - Networking 10 10-13-2011 01:09 PM
XP Client Returns 'Access is Denied' Error When Trying to Connect to a Samba Server BuckRogers01 Linux - Networking 1 05-25-2005 11:55 AM
Samba server: access denied error vharishankar Linux - General 7 09-07-2004 12:17 AM
Samba - Access denied aikempshall Linux - Networking 22 08-24-2004 06:50 AM
Access denied XP samba shares djtsa Linux - Software 0 10-02-2003 06:26 AM


All times are GMT -5. The time now is 11:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration