LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 09-17-2008, 02:57 PM   #1
jhaxxar
LQ Newbie
 
Registered: Sep 2008
Posts: 11

Rep: Reputation: 0
SAMBA Problem


I am attempting to setup Samba on my RHEL4 system for access by my WinXP systems. I can see the shares on my WinXP system, but when I attempt to access a share, a username/password box pops up. The username is already filled in with Software\guest and requests a password. I have no idea what password it is requiring.

I am a novice to Linux, so any help would be Appreciated. I can supply screen shots from the WinXP side if it will help along with my smb.conf file.
 
Old 09-17-2008, 03:29 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,105

Rep: Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720
Quote:
Originally Posted by jhaxxar View Post
I am attempting to setup Samba on my RHEL4 system for access by my WinXP systems. I can see the shares on my WinXP system, but when I attempt to access a share, a username/password box pops up. The username is already filled in with Software\guest and requests a password. I have no idea what password it is requiring.

I am a novice to Linux, so any help would be Appreciated. I can supply screen shots from the WinXP side if it will help along with my smb.conf file.
It's asking for a user ID/password on your Linux system. Windows is populating it with whatever it thinks is right.
 
Old 09-17-2008, 03:35 PM   #3
Unknown_User
Member
 
Registered: Jan 2003
Location: EU (UK)
Distribution: Ubuntu 10.x, Fedora 9, OpenSuSE 11.3, Mythbuntu (Don't know it? Try - it rocks!)
Posts: 225

Rep: Reputation: 30
Have you added the names of the users that you want to access the share(s) to the smbusers file and set passwords using smbpasswd?
 
Old 09-17-2008, 03:59 PM   #4
jhaxxar
LQ Newbie
 
Registered: Sep 2008
Posts: 11

Original Poster
Rep: Reputation: 0
The username is already filled in and is greyed out. The username is software\guest.

Right now I only have me as a user.
 
Old 09-17-2008, 04:25 PM   #5
Unknown_User
Member
 
Registered: Jan 2003
Location: EU (UK)
Distribution: Ubuntu 10.x, Fedora 9, OpenSuSE 11.3, Mythbuntu (Don't know it? Try - it rocks!)
Posts: 225

Rep: Reputation: 30
My apologies if I'm misunderstanding you here but when you try to access your samba share from XP samba replies with "who are you and what's your password?" hence the dialogue box.

It then checks the provided information against it's list of users and passwords.

If you haven't supplied samba with any usernames and passwords then only 'guest' exists without sufficient permissions to see the contents of the shares.

You could set a password for 'guest' using smbpasswd but it's not wise to use that account as it is an obvious one to attack if you are in an environment where that could happen.

Try creating a user on the Linux machine by editing the smbusers file and then setting a password for that user (using smbpasswd). You should then be able to access the share from Windows by typing in the username and password in the dialogue box when it appears.
 
Old 09-18-2008, 09:49 AM   #6
jhaxxar
LQ Newbie
 
Registered: Sep 2008
Posts: 11

Original Poster
Rep: Reputation: 0
Still having problems

My smb.conf file is

[global]

workgroup = workgroup
server string = Samba Server
encrypt passwords = yes
username map = /etc/samba/smbusers

[homes]
comment = Home Directories
browseable = no
writeable = yes

[root]
path = /root
writeable = yes
guest ok = yes

[Software1]
comment = Software Dept Server
path = /software1
writeable = yes
guest ok = yes

My smbusers file

# Unix_name = SMB_name1 SMB_name2 ...
root = administrator admin
nobody = guest pcguest smbguest
adm = jdonaldson
jdonaldson = jdonaldson


My smbpasswd file

jdonaldson:500:73AB.......................


When I access the system from my WinXP system I see both the Home and Software1 shares. When I click on the Software1 share a username/password box pops up. The Username part is greyed out and says Software\guest. The password box is writeable.

It should have come up and allowed to put user "jdonaldson".

So what am I doing wrong?
 
Old 09-18-2008, 05:57 PM   #7
Unknown_User
Member
 
Registered: Jan 2003
Location: EU (UK)
Distribution: Ubuntu 10.x, Fedora 9, OpenSuSE 11.3, Mythbuntu (Don't know it? Try - it rocks!)
Posts: 225

Rep: Reputation: 30
When Windows talks to samba it uses the its username and password to try to log in to the share.

If the username and password don't match then, after three attempt (that you don't see) samba will default to the guest account and the dialogue box greys out.

You could ensure that your Windows username and password match the samba settings or change your smb.conf to add a share along the lines of;

[Jhaxxars share]
path = /media/Storage/Jhaxxars Share
browesable = yes
writable = yes
guest ok = no
username = yourusername
only user = yes

or if you want a public share that anyone can get into without a username and password then edit smb.conf to something like;

[global]
workgroup = workgroup
netbios name = whatever-server
server string = Samba Server
interfaces = eth0, lo
auth methods = guest
map to guest = Bad User
hosts allow = 192.168.1., 127.0.0.1

[shared]
comment = Shared
path = /pub
write list = nobody, guest
read only = No
guest ok = Yes
 
Old 09-18-2008, 07:26 PM   #8
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
How are you trying to connect to the share drive? If you are doing it from explorer (ie with "map network drive"), there should be a check box in the browse/enter share name screen to logon or connect as a different user. Click on that to allow modifying the username.
 
Old 09-19-2008, 10:31 AM   #9
jhaxxar
LQ Newbie
 
Registered: Sep 2008
Posts: 11

Original Poster
Rep: Reputation: 0
Unknown_User..... thank you for the tip. It allows me to logon now. Since I am not super adapt at Samba or Linux in general, I created a user called "software". Added it as a Samba user. This way each person in the lab can logon to it, access the folders, and etc. Crude...yes, but works.
 
  


Reply

Tags
permissions, samba, shares, smb, xp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba - Windows XP Problem (//Samba is not accessible) Covenent Linux - Networking 20 08-11-2011 05:07 PM
Samba sharing problem (user permission problem) beikokutn Linux - Software 4 03-11-2008 06:55 AM
samba 3 problem - samba PDC can not join to the domain ananthak Linux - Networking 1 05-21-2006 11:39 AM
Samba problem MichaelHall Slackware 0 03-03-2004 03:31 AM
when i restart SAMBA,it says:stop samba failed,start SAMBA OK! whepin Linux - Networking 3 12-26-2001 06:54 AM


All times are GMT -5. The time now is 11:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration