LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-19-2006, 08:47 AM   #1
metalsam
Member
 
Registered: Mar 2006
Location: london
Distribution: fedora core 4
Posts: 56

Rep: Reputation: 15
Samba problem


this is my smb.conf file:
[global]
workgroup = OFFICE1
netbios name = SAMLINUX
server string = Samba Server
interfaces = lo, eth0
bind interfaces only = Yes
hosts equiv = /etc/hosts
smb passwd file = /var/lib/samba/private/smbpasswd
username map = /etc/samba/sambausers
log file = /var/log/samba/%m.log
max log size = 50
smb ports = 139 445
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
hostname lookups = Yes
printcap name = cups
logon path = \\%L\profiles\.msprofile
logon drive = P:
logon home = \\%L\%U\\.9xprofile
dns proxy = No
wins support = Yes
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
guest ok = Yes
hosts allow = 192.168.0.0, 192.168.0.1, 192.168.0.2, 192.168.0.5, localhost
hosts deny = none
cups options = raw

[printers]
comment = All Printers
path = /var/spool/samba
hosts allow =
hosts deny =
printable = Yes
browseable = No

[homes]
comment = homes directories
valid users = %S
read only = No
inherit acls = Yes

[profiles]
comment = network profiles service
path = %H
read only = No
create mask = 0600
directory mask = 0700
store dos attributes = Yes

[users]
comment = all users
path = /home/
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares
browseable = No


I can see linux from XP, but when i try to get into it, i get network path not found error. I have static IPs for linux and XP from the router.
 
Old 05-19-2006, 12:50 PM   #2
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Rep: Reputation: 30
Which profile are you using to connect to?
 
Old 05-19-2006, 01:07 PM   #3
metalsam
Member
 
Registered: Mar 2006
Location: london
Distribution: fedora core 4
Posts: 56

Original Poster
Rep: Reputation: 15
trying to connect from the admin XP profile, metalsam

I tried adding it to the samba password thingy:

smbpasswd -a metalsam

but i told me that the samba password file didnt exist :s
 
Old 05-19-2006, 08:46 PM   #4
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: KirraMail Live Email Server
Posts: 1,279

Rep: Reputation: 61
Are you using this as a NT style domain controller or just a samba server?
 
Old 05-19-2006, 09:58 PM   #5
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 770
Blog Entries: 6

Rep: Reputation: 75
; smb passwd file = /var/lib/samba/private/smbpasswd

; username map = /etc/samba/sambausers

comment that line with ; above is sample and restart samba

let see

Last edited by routers; 05-19-2006 at 10:06 PM.
 
Old 05-20-2006, 02:44 AM   #6
metalsam
Member
 
Registered: Mar 2006
Location: london
Distribution: fedora core 4
Posts: 56

Original Poster
Rep: Reputation: 15
ok,

i deleted the IP of my windows computer (192.168.0.5) from the allowed IP adresses, and know windows can see linux.

I also commented those lines, but it still says,

does not have permission, network path not found

Thanks for the help so far !
 
Old 05-20-2006, 06:55 AM   #7
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 770
Blog Entries: 6

Rep: Reputation: 75
can i have ur below output

# testparm
 
Old 05-20-2006, 07:25 AM   #8
coolb
Member
 
Registered: Apr 2006
Location: Cape Town, South Africa
Distribution: Gentoo 2006.1(2.6.17-gentoo-r7)
Posts: 222

Rep: Reputation: 30
Quote:
Originally Posted by metalsam
ok,

i deleted the IP of my windows computer (192.168.0.5) from the allowed IP adresses, and know windows can see linux.

I also commented those lines, but it still says,

does not have permission, network path not found

Thanks for the help so far !
Try configuring your Samba server from Webmin. I configured mine from there and it works fine...

Just I thought, is your Samba server and Windows clients in the same workgroup/domain, maybe Samba has a problem if they are not in the same one.
 
Old 05-20-2006, 07:46 AM   #9
metalsam
Member
 
Registered: Mar 2006
Location: london
Distribution: fedora core 4
Posts: 56

Original Poster
Rep: Reputation: 15
yup, ive set teh workgroup.

what is webmin ?
 
Old 05-20-2006, 08:27 AM   #10
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 770
Blog Entries: 6

Rep: Reputation: 75
webmin is gui web system manager but let see # testparm
 
Old 05-20-2006, 08:52 AM   #11
metalsam
Member
 
Registered: Mar 2006
Location: london
Distribution: fedora core 4
Posts: 56

Original Poster
Rep: Reputation: 15
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[profiles]"
Processing section "[users]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

# Global parameters
[global]
workgroup = OFFICE1
netbios name = SAMLINUX
server string = Samba Server
interfaces = lo, eth0
bind interfaces only = Yes
hosts equiv = /etc/hosts
log file = /var/log/samba/%m.log
max log size = 50
smb ports = 139 445
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
hostname lookups = Yes
printcap name = cups
logon path = \\%L\profiles\.msprofile
logon drive = P:
logon home = \\%L\%U\\.9xprofile
dns proxy = No
wins support = Yes
default service = global
guest ok = Yes
hosts allow = 192.168.0.0, 192.168.0.1, 192.168.0.2, localhost
hosts deny = none

[homes]
comment = homes directories
valid users = %S
read only = No
inherit acls = Yes

[profiles]
comment = network profiles service
path = %H
read only = No
create mask = 0600
directory mask = 0700
store dos attributes = Yes

[users]
comment = all users
path = /home/
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares
browseable = No
 
Old 05-20-2006, 09:59 AM   #12
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 770
Blog Entries: 6

Rep: Reputation: 75
ok can u try this way , first backup smb.conf
Quote:
mv smb.conf smb.conf.BAK
take this file save as smb.conf and restart samba
Quote:
[global]
workgroup = OFFICE1
netbios name = SAMLINUX
encrypt passwords = yes
smb passwd file = smbpasswd %u
unix password sync = no
null passwords = no
server string = Samba Server

[test-user1]
comment = user1
path = /home/user1
valid users = user1
public = no
writable = yes
printable = no
create mask = 0765
--add user1 to linux system

# adduser user1
passwd user1

--adduser to smb
# smbpasswd -a user1
pass...

# /etc/init.d/smb restart

from xp search computer on network type SAMLINUX
i hope this way right for testing

Last edited by routers; 05-20-2006 at 10:00 AM.
 
Old 05-20-2006, 12:12 PM   #13
metalsam
Member
 
Registered: Mar 2006
Location: london
Distribution: fedora core 4
Posts: 56

Original Poster
Rep: Reputation: 15
I changed the file, but know when i look in my workgroup on XP, I cant see linux
 
Old 05-20-2006, 07:09 PM   #14
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: KirraMail Live Email Server
Posts: 1,279

Rep: Reputation: 61
Add to the global settings `security = share`

[global]
workgroup = OFFICE1
netbios name = SAMLINUX
encrypt passwords = yes
smb passwd file = smbpasswd %u
unix password sync = no
null passwords = no
server string = Samba Server
security = share

[test-user1]
comment = user1
path = /home/user1
valid users = user1
public = no
writable = yes
printable = no
create mask = 0765

This should allow XP machines to see the share first before asking for a password if the share requires it. And don't forget to restart samba:

Last edited by fotoguy; 05-20-2006 at 07:12 PM.
 
Old 05-21-2006, 03:31 AM   #15
metalsam
Member
 
Registered: Mar 2006
Location: london
Distribution: fedora core 4
Posts: 56

Original Poster
Rep: Reputation: 15
ok, now XP can see linux, but i get:

\\Samlinux is not accessible, you may not have permission to use this network resource.

network path was not found.
 
  


Reply

Tags
samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba - Windows XP Problem (//Samba is not accessible) Covenent Linux - Networking 20 08-11-2011 04:07 PM
samba 3 problem - samba PDC can not join to the domain ananthak Linux - Networking 1 05-21-2006 10:39 AM
Samba Problem Marine Eater Linux - Networking 2 12-17-2004 03:58 PM
samba problem haobaba1 Linux - Networking 5 08-17-2003 12:35 PM
when i restart SAMBA,it says:stop samba failed,start SAMBA OK! whepin Linux - Networking 3 12-26-2001 05:54 AM


All times are GMT -5. The time now is 03:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration