LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Samba problem (http://www.linuxquestions.org/questions/linux-networking-3/samba-problem-446406/)

metalsam 05-19-2006 08:47 AM

Samba problem
 
this is my smb.conf file:
[global]
workgroup = OFFICE1
netbios name = SAMLINUX
server string = Samba Server
interfaces = lo, eth0
bind interfaces only = Yes
hosts equiv = /etc/hosts
smb passwd file = /var/lib/samba/private/smbpasswd
username map = /etc/samba/sambausers
log file = /var/log/samba/%m.log
max log size = 50
smb ports = 139 445
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
hostname lookups = Yes
printcap name = cups
logon path = \\%L\profiles\.msprofile
logon drive = P:
logon home = \\%L\%U\\.9xprofile
dns proxy = No
wins support = Yes
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
guest ok = Yes
hosts allow = 192.168.0.0, 192.168.0.1, 192.168.0.2, 192.168.0.5, localhost
hosts deny = none
cups options = raw

[printers]
comment = All Printers
path = /var/spool/samba
hosts allow =
hosts deny =
printable = Yes
browseable = No

[homes]
comment = homes directories
valid users = %S
read only = No
inherit acls = Yes

[profiles]
comment = network profiles service
path = %H
read only = No
create mask = 0600
directory mask = 0700
store dos attributes = Yes

[users]
comment = all users
path = /home/
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares
browseable = No


I can see linux from XP, but when i try to get into it, i get network path not found error. I have static IPs for linux and XP from the router.

pdeman2 05-19-2006 12:50 PM

Which profile are you using to connect to?

metalsam 05-19-2006 01:07 PM

trying to connect from the admin XP profile, metalsam

I tried adding it to the samba password thingy:

smbpasswd -a metalsam

but i told me that the samba password file didnt exist :s

fotoguy 05-19-2006 08:46 PM

Are you using this as a NT style domain controller or just a samba server?

routers 05-19-2006 09:58 PM

; smb passwd file = /var/lib/samba/private/smbpasswd

; username map = /etc/samba/sambausers

comment that line with ; above is sample and restart samba

let see

metalsam 05-20-2006 02:44 AM

ok,

i deleted the IP of my windows computer (192.168.0.5) from the allowed IP adresses, and know windows can see linux.

I also commented those lines, but it still says,

does not have permission, network path not found

Thanks for the help so far !

routers 05-20-2006 06:55 AM

can i have ur below output

# testparm

coolb 05-20-2006 07:25 AM

Quote:

Originally Posted by metalsam
ok,

i deleted the IP of my windows computer (192.168.0.5) from the allowed IP adresses, and know windows can see linux.

I also commented those lines, but it still says,

does not have permission, network path not found

Thanks for the help so far !

Try configuring your Samba server from Webmin. I configured mine from there and it works fine...

Just I thought, is your Samba server and Windows clients in the same workgroup/domain, maybe Samba has a problem if they are not in the same one.

metalsam 05-20-2006 07:46 AM

yup, ive set teh workgroup.

what is webmin ?

routers 05-20-2006 08:27 AM

webmin is gui web system manager but let see # testparm

metalsam 05-20-2006 08:52 AM

Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[profiles]"
Processing section "[users]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

# Global parameters
[global]
workgroup = OFFICE1
netbios name = SAMLINUX
server string = Samba Server
interfaces = lo, eth0
bind interfaces only = Yes
hosts equiv = /etc/hosts
log file = /var/log/samba/%m.log
max log size = 50
smb ports = 139 445
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
hostname lookups = Yes
printcap name = cups
logon path = \\%L\profiles\.msprofile
logon drive = P:
logon home = \\%L\%U\\.9xprofile
dns proxy = No
wins support = Yes
default service = global
guest ok = Yes
hosts allow = 192.168.0.0, 192.168.0.1, 192.168.0.2, localhost
hosts deny = none

[homes]
comment = homes directories
valid users = %S
read only = No
inherit acls = Yes

[profiles]
comment = network profiles service
path = %H
read only = No
create mask = 0600
directory mask = 0700
store dos attributes = Yes

[users]
comment = all users
path = /home/
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares
browseable = No

routers 05-20-2006 09:59 AM

ok can u try this way , first backup smb.conf
Quote:

mv smb.conf smb.conf.BAK
take this file save as smb.conf and restart samba
Quote:

[global]
workgroup = OFFICE1
netbios name = SAMLINUX
encrypt passwords = yes
smb passwd file = smbpasswd %u
unix password sync = no
null passwords = no
server string = Samba Server

[test-user1]
comment = user1
path = /home/user1
valid users = user1
public = no
writable = yes
printable = no
create mask = 0765
--add user1 to linux system

# adduser user1
passwd user1

--adduser to smb
# smbpasswd -a user1
pass...

# /etc/init.d/smb restart

from xp search computer on network type SAMLINUX
i hope this way right for testing

metalsam 05-20-2006 12:12 PM

I changed the file, but know when i look in my workgroup on XP, I cant see linux :(

fotoguy 05-20-2006 07:09 PM

Add to the global settings `security = share`

[global]
workgroup = OFFICE1
netbios name = SAMLINUX
encrypt passwords = yes
smb passwd file = smbpasswd %u
unix password sync = no
null passwords = no
server string = Samba Server
security = share

[test-user1]
comment = user1
path = /home/user1
valid users = user1
public = no
writable = yes
printable = no
create mask = 0765

This should allow XP machines to see the share first before asking for a password if the share requires it. And don't forget to restart samba:

metalsam 05-21-2006 03:31 AM

ok, now XP can see linux, but i get:

\\Samlinux is not accessible, you may not have permission to use this network resource.

network path was not found.


All times are GMT -5. The time now is 10:29 PM.