LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Samba Prob: nmblookup failure (http://www.linuxquestions.org/questions/linux-networking-3/samba-prob-nmblookup-failure-64358/)

paulmann 06-08-2003 11:03 AM

Samba Prob: nmblookup failure
 
All,

I am a Linux newbie and I am troubleshooting my Samba set up. I have 2 Win2k machines and 1 Linux box all connected via 4 port router with DHCP. I am debugging my setup using a troubleshooting doc found at http://au1.samba.org/samba/ftp/docs/Samba24Hc13.pdf I have been going through this doc one step at a time and I am definately making progress. Samba is running. Users are added. Connectivity has been confirmed using "smbclient". However, Step 3 of this troubleshooting guide attacks Name Resolution. Thats where I hit a snag.

Using "nmblookup -B 192.168.0.255 manning2" gives me the following error:

querying manning2 on 192.168.0.255
name_query failed to find name manning2

manning2 is the Linux box in question running Samba
192.168.0.255 is the Broadcast address for this network interface (verified thru ifconfig).

Using "nslookup manning2" gives me the following error:

Server: 192.168.0.1
Address: 192.168.0.1#53

** server can't find manning2: NXDOMAIN

-The /etc/hosts file has a loopback entry with "manning2" listed.
-Running "hostname" returns "manning2".
-I can "ping manning2" and it returns 192.168.0.3, the ip assigned by my router.

I am not sure what I need to do from here. Anyhelp would be appreciated.

-Paul

Spotnik 06-09-2003 10:05 AM

Check your smb.conf file for the line:

netbios name = Manning2

which should be just under your Workgroup name.

I hit the same snag a few days ago. I had lots of other problems, but this entry was the last one I fixed that got it all running for me. I didn't have to have this entry in my RH 7.0 machine, so trying to recycle my smb.conf wasn't as smooth as I thought it would be.

Hope this eliminates at least one variable!

paulmann 06-09-2003 07:17 PM

Already had the smb.conf entry. Thx, Spotnik

Turns out, it was my firewall settings.

It fixed my nmblookup problem and my Samba problems.

This was a good one. It took me awhile to figure it out. Hope this post helps others.

-Paul


All times are GMT -5. The time now is 07:32 PM.