LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-03-2006, 02:02 PM   #1
jorbot
LQ Newbie
 
Registered: Oct 2006
Posts: 1

Rep: Reputation: 0
Samba Permissions Problem


I am having a very annoying problem that I am sure has a very simple solution, but I cannot seem to figure this out. I have spent about a week trying to figure this out, searching through endless forum and documentation sources. But I continue to have the same problem.

Here is what I am trying to do...

I have a network at our office of about 30 Windows workstations. They are all on a simple workgroup. I am not running any domains. We are a very small company and I am not a network administrator, so I want to try to keep this as simple as possible. We just bought a new server with no OS. The main use of the new server is to run a large file sharing repository for the company with local network and VPN access. The VPN is handled by our router/firewall. I want to have one directory on the server that has full access permissions to everybody in the company to read, write, and change files as needed.

In order to keep cost low, I decided to try out Linux to run the server. I could do it with Windows XP, but as far as I know, that would be incredibly inefficient because XP is not designed to be run as a server. However, the problem is that I am completely new to Linux so I am really struggling here.

I have figured out that I am supposed to use Samba for windows networking. I have played with the settings quite a bit to get Samba to work with our network and I am able to connect to the server and read files. However, I cannot write or change anything. It keeps telling me that I do not have the correct permissions. I have changed just about every setting I can think of in the smb.conf file to no avail. I set the permissions to 777 on the shared directory in Linux and it still does not work.

I have actually tried this on three different distributions (Fedora, SUSE, and Ubuntu) and two completely different sets of computers and networks (office and home) and I get the same result in every situation. So this tells me there is noting wrong with the OS or hardware but something that I am doing wrong in the configuration.

As part of my troubleshooting process, I completely turned off the firewalls on both ends and I still get the same problem. I changed my network settings from DHCP to manually setting my IP address and settings; no change. I tried creating specific users and groups just for file sharing and changing the ownership of the fileshare directory to that group; no change. I tried sharing a directory in the root level (/fileshare) and in the home directory (/home/samba/fileshare); no change. I just do not know what else to try.

Within the smb.conf file I have tried public = yes, writable = yes, browseable = yes, create mask, force user, force group and just about anything else you can think of. Still no change.

Can you think of any simple step I may be missing? Are Samba permissions only handled within the smb.conf file or is there somewhere else that I need to set up access permissions as well?

This is a critical feature of our new server and I am afraid I may have to give up on Linux altogether if I cannot make this work. I would hate to revert back to Windows.

Do you have any ideas how I may come to a solution to this problem?

Sorry for the long post but I wanted to be as detailed as possible. I am also sorry if this specific issue has already been dealt with in this forum. If so, a link to the previously posted solution would be an incredible help, considering I have already done extensive searching and could not find the solution.

Thank you so much for your help.

Last edited by jorbot; 10-03-2006 at 02:06 PM.
 
Old 10-03-2006, 02:38 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Your distros should also include a pdf or postscript version of the "Samba 3 by Example" book. Either as part of the regular package or from a samba-doc package.
Look in /usr/share/doc/packages/ for a samba or samba3 directory. It sounds like either you need to add the default user as a samba user or you need to change the permissions of the directory that you wish to share. There are two very similar examples in the book that you could use for a model.
 
Old 04-17-2008, 11:56 AM   #3
Dell_Linux_tech
LQ Newbie
 
Registered: Apr 2008
Posts: 1

Rep: Reputation: 0
Smile SE Linux may be preventing samba from working.

From the console type:
setenforce 0
 
Old 06-09-2008, 04:53 AM   #4
sins
LQ Newbie
 
Registered: Jun 2008
Posts: 4

Rep: Reputation: 0
Hi Jorbot just try it and post the output....
give chmod -R 777 to /fileshare and try to change the files from client side,also check the SE linux(no probs disable it)

Last edited by sins; 06-09-2008 at 04:54 AM.
 
  


Reply

Tags
networking, permissions, samba, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba permissions problem Hans Vanpee Linux - Networking 2 01-27-2006 09:43 AM
Samba permissions problem mago Slackware 7 12-24-2005 12:18 PM
Samba problem - no permissions Seventh Linux - Software 5 11-08-2005 05:05 AM
Samba Permissions Problem Stormblade Linux - Software 1 11-12-2004 07:09 AM
Samba Permissions Problem gigglesnorter Linux - Software 0 05-24-2004 04:37 AM


All times are GMT -5. The time now is 05:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration