LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-12-2002, 09:44 AM   #1
cic
Member
 
Registered: Jun 2001
Distribution: Red Hat
Posts: 33

Rep: Reputation: 15
Unhappy Samba passwords


Hi All,
Can anyone tell me how to use password authentication with Samba and Windows... without the Windows client logging into a domain??. Ive got it going and have 2 public folders and 1 "private" folder. The smb.conf reads as follows:

[Private]
comment = Admin
path = /vol/samba/private
valid users = john
browsable = Yes
public = No
writable = Yes
create mode = 0700

(Ive created the dir and used the command : chown smbuser:smb /vol/samba/private... as I did with the public folders)

Now I get a login and password pop-up menu when trying to access the folder from my XP machine, but the user is "guest" by default and unchangeble. Actually my problem is not understanding where the problem lies.... in networking (not logging on)?, the smb.conf?, or the password itself?..... Can someone please shine some light?
 
Old 08-12-2002, 09:59 AM   #2
GAVollink
Member
 
Registered: Apr 2002
Location: St. Paul, Minnesota
Distribution: UbuntuStudio, Ubuntu
Posts: 357

Rep: Reputation: 31
Samba runs as root, so changing the user is not necessary when the share is authenticated. Only 'guest' access is mapped to a special user (possibly 'samba' in your case).

[private]
path = /vol/samba/private
valid users = john

Private should be readable and writable by user 'john', and samba will create and manipulate files as if it were 'john'.

Do you authenticate though smbpassword? Is 'john' both a UNIX user and also a user in 'smbpasswd'?

Finally, make sure that if your client is expecting encrypted password access that samba has encryption enabled (see docs for the [global] section.

Thank you,
Gary Allen Vollink
 
Old 08-13-2002, 04:33 AM   #3
cic
Member
 
Registered: Jun 2001
Distribution: Red Hat
Posts: 33

Original Poster
Rep: Reputation: 15
Ok.. Ive chown"ed" my private dir to "john" and used "smbpasswd -a john" to create the password. Encryption is on... Actually heres a copy of my smb.conf:

-------------------------------------------------------------
[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = FIDO

# server string is the equivalent of the NT Description field
server string = FIDO Samba Server

hosts allow = 10.1.1.1 10.1.1.10 127.
interfaces = 10.1.1.1/24 127.0.0.1/24
bind interfaces only = Yes
security = SHARE
encrypt passwords = Yes
smb passwd file = /etc/samba/smbpasswd
log file = /var/log/samba/log.%m
max log size = 50
read bmpx = No
time server = Yes
os level = 65
preferred master = Yes
dns proxy = No
wins support = Yes
guest account = smbuser
hide dot files = No

printcap name = /etc/printcap
load printers = yes

printing = lprng

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

[printers]
comment = All Printers
path = /var/spool/samba
browseable = no

guest ok = no
printable = yes

[Public]
comment = Shared Directory
path = /home/public
read only = No
create mask = 0664
directory mask = 0775
guest ok = Yes

[Data]
comment = Software
path = /vol/samba/data
read only = No
create mask = 0660
directory mask = 0770
guest ok = Yes

[Private]
comment = Administrator
path = /vol/samba/private
valid users = john
browsable = Yes
public = No
writable = Yes
create mode = 0700

----------------------------------------------------------------
Can anybody see something missing or out of place?
After the changes - I still get a login box (on my XP machine) with no abitlity to change the username (ie: fido/guest) but I can type in a password (ie: [smbpaswd -a john] ....that obviosly doesnt work).....
 
Old 08-13-2002, 11:28 PM   #4
sudheermt
LQ Newbie
 
Registered: Jul 2002
Posts: 11

Rep: Reputation: 0
Just play around with

[global]
..
security = SHARE / user / server

make sure, the user logged in , is using same username passwd, which you added by smbpasswd.

sudheer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba passwords mheymann Linux - Networking 1 08-18-2005 05:36 AM
samba and passwords mega man Linux - Networking 2 06-14-2005 03:31 AM
Samba setup - no passwords vman33197 Linux - Newbie 1 05-05-2004 09:14 AM
Samba Passwords klatch Linux - Newbie 2 03-28-2004 05:18 AM
Is there a way to sync Samba passwords with linux user passwords MarleyGPN Linux - Networking 2 09-09-2003 10:59 AM


All times are GMT -5. The time now is 11:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration