LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 08-03-2013, 12:01 AM   #1
ZTagr
LQ Newbie
 
Registered: Aug 2013
Posts: 14

Rep: Reputation: Disabled
Samba on Fedora19, 64-bit "times out" quickly when attempting to connect to workgroup


Hi all!

I have only recently installed Fedora 19, 64-bit on my notebook pc, and need to communicate with it using Samba. I found out that Samba was not installed by default, so I installed in with the yum command:
"yum install samba"

I then made my normal modifications to the smb.conf file, and started and enabled both smbd and nmbd.

At first, I was not able to communicate in either direction (from my other networked pc's, or to them from Fedora), so I went online to see if I could find some answers.

I made a few adjustments:

A) I disabled SELinux (if only for a short time, just until I can establish a networked connection to my workgroup...)

B) I made the following iptables entries:
iptables -A INPUT -s 192.168.137.0/24 -p udp -m udp --dport 137 -j ACCEPT

iptables -A INPUT -s 192.168.137.0/24 -p udp -m udp --dport 138 -j ACCEPT

iptables -A INPUT -s 192.168.137.0/24 -p tcp -m tcp --dport 139 -j ACCEPT

iptables -A INPUT -s 192.168.137.0/24 -p tcp -m tcp --dport 445 -j ACCEPT

I also opened up ports 137-139 and 445 with the GUI interface to firewalld.

Now, I can connect to the Fedora 19 system from any pc within my workgroup, but can NOT connect to "workgroup" (the actual NAME of my workgroup) from Fedora 19! I keep getting "timeout connecting to workgoup" errors. These error notices appear almost immediately after I double-click on the "workgroup" icon; however, I have set my connect-to-server timeout to over one minute! (actually, it's set to a minute and a half...)

Does this issue sound familiar to anyone? This is the first time I have ever used Samba 4, and I understand it differs substantially from Samba 3; could this be an issue?

Or, is there an iptables / firewalld step I've missed?

Please help if you can!

Thanks in advance,
- ZTagr.
 
Old 08-03-2013, 07:40 AM   #2
ZTagr
LQ Newbie
 
Registered: Aug 2013
Posts: 14

Original Poster
Rep: Reputation: Disabled
Thumbs up Solved at last...

Thanks for all who took time to read my question!

As I stated in the original posting, I am new to Fedora 19, 64-bit (having just switched from Ubuntu 64-bit after some two years...). I had never needed to deal with SELinux to any large degree and had never encountered the likes of firewalld before! It turns out that THAT was where my problem ultimately lay!

I only "stumbled on" the firewalld GUI setup by accident while sifting through the Fedora KDE4 menu, looking for anything that I thought might be helpful in solving my problem. When I ran it (the GUI interface app) I found it quite intuitive, and really didn't need any help in doing what I believed needed to be done with it to allow Samba to communicate through it. I decided to make the default ZONE "Home" at that time, and configured the ports for Samba in THAT zone. Once I had done so, I was able to communicate from any of the pc's on my LAN to my Fedora machine, and so I was pretty sure I had been successful in setting it up correctly. I was of course unable to communicate OUT from Fedora to the rest of my workgroup (thus, my posted question).

Here was where I made a small error! The NetworkManager in Ubuntu looks very similiar to that in Fedora w/KDE4 DTE. There is ONE MAJOR DIFFERENCE in the two versions - the Fedora version has a setting for the wired network called "Firewall zone" which I had NOTICED, but didn't think much of at the time. Now, later on, once I had "stumbled" on to firewalld's GUI app, I did not recall having even SEEN that setting! I of course never realized that in NetworkManager, the firewall zone was set to "Trusted" zone! And I had NOT made any modifications to that zone! Thus my problem...

Needless to say, once I had realized my mistake, and set the current firewall zone to "Home" within NetworkManager, Samba performed flawlessly!

Guess I need to hit the manuals for Fedora, eh?

But, you would think that, because you can SET the default zone in the firewalld GUI, that any apps. working with the firewall (such as Samba) would simply USE the selected default zone! Instead I need to both SET the default zone, and then tell Samba what zone I want it to use...(not entirely logical, and one step too many!). If Samba had indeed used the DEFAULT ZONE, I would have had the problem solved a day earlier... - sigh...

Thanks again!
ZTagr.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SAMBA PDC > "Username could not be found" when attempting to add WinXP client to dom RossR Linux - Server 0 08-21-2009 03:56 PM
xp workgroup pc cannot change "<samba server>/Guest" in connection pop-up duderancher Linux - Server 4 09-17-2008 03:34 PM
Data transfer online is slow "at times" or "stops at times" Balarabay1 Suse/Novell 14 04-30-2006 11:00 AM
Samba srever "times out" ... or something soren625 Linux - Networking 4 05-19-2004 06:22 PM
need help, on how to access quickly to special characters like "" or ""? Motaro Linux - Newbie 1 12-31-2003 12:53 PM


All times are GMT -5. The time now is 03:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration