LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-23-2007, 06:40 PM   #1
Keithj
Member
 
Registered: May 2005
Location: Essex and Norfolk
Distribution: Debian, Fedora 8 and 9, Mandriva 2009, Mepis, Kubuntu, SuSe 10.1, Slackware 12.1 - and Knoppix.
Posts: 155

Rep: Reputation: 30
Samba no longer allowing access


Fedora runs my main fileserver. On Friday I upgraded to Core 7. There were some snags along the way, but eventually (with help from folks here) I got it running.

However, following the upgrade, the other machines on the network can't see this one (which they did fine before). It can see them, however.

The Fedora machine can't see itself in the Samba screen either - but displays perfectly happily the others on the network.

If I manually change the samba address in konqueror to smb://fedora-vin then it can see itself. It still doesn't appear in the network list under Keithj.

I'll post my smb.conf below this (I'm using the laptop while I poke at the server).

Can anyone suggest what's up?
 
Old 06-23-2007, 06:49 PM   #2
Keithj
Member
 
Registered: May 2005
Location: Essex and Norfolk
Distribution: Debian, Fedora 8 and 9, Mandriva 2009, Mepis, Kubuntu, SuSe 10.1, Slackware 12.1 - and Knoppix.
Posts: 155

Original Poster
Rep: Reputation: 30
This is the smb.conf file that goes with the above:
Quote:
# FEDORA SAMBA FILE AS AT 23 June 2007

[global]

workgroup = Keithj
server string = Fedora-Vin
hosts allow = 192.168.8. 192.168.1. 127.

printcap name = /etc/printcap
cups options = raw

log file = /var/log/samba/log.samba
max log size = 1000

socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192

dns proxy = no
security = share
restrict anonymous = no
domain master = no
preferred master = no
max protocol = NT
ldap ssl = No
server signing = Auto
paranoid server security = no
encrypt passwords = no
guest ok = yes
guest account = keithj
netbios name = FEDORA


[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
printable = yes


[server]
comment = Fedora
path = /servfiles
writeable = yes
guest ok = yes
browseable = yes
 
Old 06-23-2007, 07:06 PM   #3
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Try disabling SELinux temporarily with

setenforce 0

from the terminal and see if that fixes things. If it does, you can diable SELinux for smb from the security settings in gnome

Also, have you opened the firewall for ports 137-139?

Last edited by billymayday; 06-23-2007 at 07:07 PM.
 
Old 06-23-2007, 07:40 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
If the other hosts are XP computers, they may be using port 445 for browsing.
grep ' 445/' /etc/services
microsoft-ds 445/tcp # Microsoft-DS
microsoft-ds 445/udp # Microsoft-DS

Also, do the other hosts use "Keithj" as the workgroup name?

Last edited by jschiwal; 06-23-2007 at 07:42 PM.
 
Old 06-23-2007, 07:47 PM   #5
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You can get away without port 445 I believe (I keep mine closed) since you get quite a bit of notification traffic flying around
 
Old 06-23-2007, 07:48 PM   #6
Keithj
Member
 
Registered: May 2005
Location: Essex and Norfolk
Distribution: Debian, Fedora 8 and 9, Mandriva 2009, Mepis, Kubuntu, SuSe 10.1, Slackware 12.1 - and Knoppix.
Posts: 155

Original Poster
Rep: Reputation: 30
Thanks for those...

SELinux is supposed not to be running anyway - setenforce 0 brings the response bash: setenforce: command not found

There's no firewall on the machine - it's behind the server firewall, where the only machines that can access it are the ones that should (but can't, right now).

grep ' 445/' /etc/services
brings up an error message etc/services: No such file or directory.

microsoft-ds 445/tcp # Microsoft-DS gets "command not found".


I've just installed smb4k and will have a play with that tomorrow.
 
Old 06-23-2007, 07:57 PM   #7
Keithj
Member
 
Registered: May 2005
Location: Essex and Norfolk
Distribution: Debian, Fedora 8 and 9, Mandriva 2009, Mepis, Kubuntu, SuSe 10.1, Slackware 12.1 - and Knoppix.
Posts: 155

Original Poster
Rep: Reputation: 30
Yes, Keithj is the network name all the machines use. The Fedora one can see the others on there and access them with no problem. They can't see it.

If I reboot to Mepis or Debian, all works fine. The smb.conf files are virtually identical, which is what baffles me.
 
Old 06-23-2007, 09:15 PM   #8
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
The /etc/services file is a text config file that is a table of port number & internet service names. On FC6 at least it is provided by the "setup" rpm package. It is used by xinetd and maybe the libwrap library. You should try fixing that. I don't know if it is provided by a different package in FC7 however but it may be essential that you have this file. For example, you have to add an entry for swat in this file and edit /etc/xinetd.d/swat before using the web based swat interface.

If this server is on all the time you could enable wins in your samba config. Then use the server's IP address as the wins entry on the other hosts. This can prevent netbios udp floods.

This url explains the types of browsing used in windows.
http://www.petri.co.il/what's_port_445_in_w2k_xp_2003.htm

The samba 3 Howto and Reference also has a chapter on browsing. See the /usr/share/doc/samba-<version>/Samba3-HOWTO.pdf file. The pdf files here are the same books you can purchase at Barnes & Nobels.
 
Old 06-23-2007, 09:50 PM   #9
IdahoSilverSage
LQ Newbie
 
Registered: Apr 2007
Posts: 13

Rep: Reputation: 0
The other machines?

Quote:
Originally Posted by Keithj
Fedora runs my main fileserver. On Friday I upgraded to Core 7. There were some snags along the way, but eventually (with help from folks here) I got it running.

However, following the upgrade, the other machines on the network can't see this one (which they did fine before). It can see them, however.

The Fedora machine can't see itself in the Samba screen either - but displays perfectly happily the others on the network.

If I manually change the samba address in konqueror to smb://fedora-vin then it can see itself. It still doesn't appear in the network list under Keithj.

I'll post my smb.conf below this (I'm using the laptop while I poke at the server).

Can anyone suggest what's up?
Are the other computers Linux or Windows? I have found Windows XP SP1 machines have trouble seeing Linux computers and also Windows SP2 computers on a workgroup.
 
Old 06-24-2007, 07:44 AM   #10
Keithj
Member
 
Registered: May 2005
Location: Essex and Norfolk
Distribution: Debian, Fedora 8 and 9, Mandriva 2009, Mepis, Kubuntu, SuSe 10.1, Slackware 12.1 - and Knoppix.
Posts: 155

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by jschiwal
The /etc/services file is a text config file that is a table of port number & internet service names. On FC6 at least it is provided by the "setup" rpm package. It is used by xinetd and maybe the libwrap library. You should try fixing that. I don't know if it is provided by a different package in FC7 however but it may be essential that you have this file. For example, you have to add an entry for swat in this file and edit /etc/xinetd.d/swat before using the web based swat interface.
I have none of those files. KSysGuard tells me that selinux and xinetd aren't running. smbd is running, nmbd is not.

Quote:
If this server is on all the time you could enable wins in your samba config. Then use the server's IP address as the wins entry on the other hosts. This can prevent netbios udp floods.
Sounds like a workaround - really, I'd like to get Samba working correctly.

I don't think the problem is with the Windows machines, because they can see the Samba connection from the other distros on the server. The only problem is that the other distros can't access the SCSI drives successfully. Fedora was "perfect" till I upgraded; now I have several "stopper" bugs, of which this one is the killer.


Quote:
The samba 3 Howto and Reference also has a chapter on browsing. See the /usr/share/doc/samba-<version>/Samba3-HOWTO.pdf file. The pdf files here are the same books you can purchase at Barnes & Nobels.
Thanks - I'll have a read of that when I get back in later today,
 
Old 06-24-2007, 10:19 AM   #11
Keithj
Member
 
Registered: May 2005
Location: Essex and Norfolk
Distribution: Debian, Fedora 8 and 9, Mandriva 2009, Mepis, Kubuntu, SuSe 10.1, Slackware 12.1 - and Knoppix.
Posts: 155

Original Poster
Rep: Reputation: 30
Well, after a couple of hours reading the PDF, which was most interesting but mostly unhelpful, I found the solution. The two lines under [global] reading:

guest ok = yes
guest account = keithj

which were correct with the previous version and with Mepis, Debian and SuSe, should now read

guest ok = no

The line
guest ok = yes
under the individual folders remains.

So easy! Why it's changed, if it's really changed, I don't know.

I got some very interesting error messages along the way - for example, very few of the commands, such as 'smbd', will run in a root command window.
[root@Keithj]# smbd
returns the message
bash: smbd: command not found

However, /usr/sbin/smbd works fine. I suspect Fedora 7 has done away with the "PATH" variable. Or mine has.

My fileserver is back! Phew!

Now, when spare time appears again, I'll look into why icons for running software don't appear in the taskbar (Skype, and many more background tasks of that nature). A different thread, though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba NOT allowing access to folders cucolin@ Linux - Software 6 07-04-2007 01:25 AM
Samba not allowing one user to access one share SeanWcisel Linux - Software 2 04-04-2007 07:38 AM
only allowing lan ip address to access samba ginda Linux - Security 1 12-10-2006 09:57 AM
Samba NOT allowing access cucolin@ Linux - Software 4 11-09-2006 03:34 PM
Samba share - network name no longer available when browsing samba from win2k dorango Linux - Software 0 03-02-2004 01:02 PM


All times are GMT -5. The time now is 09:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration