LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-21-2003, 11:44 AM   #1
ndprichardson
LQ Newbie
 
Registered: Oct 2003
Posts: 7

Rep: Reputation: 0
Angry Samba Netlogon - Driving me mad!!!


Hi All

I wonder if anyone could help me with this.

I have successfully configured my samba server to allow Win XP Pro machines to log on, Hoorah!!

However for some reason they will not process any netlogon scripts.

The server is a RHL 8.0, running samba version 2.2.3.

The XP machines dont just fail when running the scripts, they dont even seem to look at the scripts. Win 98 clients using the same sign ons load each script every time.

Everything currently works fine with any win98 machines. I reallty thought id cracked it when my win XP box authenticated to it, but its just the logon scripts.

Could It be something on the XP machines??

Or is it a silly thing in Linux?

If anyone can help, I will probably faint.

Best Reagrds

Nate
 
Old 10-21-2003, 12:48 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Welcome to LQ.

Is it XP home or XP pro?

Have you added the XP machine to the domain?
 
Old 10-21-2003, 04:22 PM   #3
ndprichardson
LQ Newbie
 
Registered: Oct 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks

LinuxQuestions looks like it could save my butt!!

Im on a deadline!!!!

Anyways, Machine account is added to /etc/passwd and also smbpasswd.

Was a struggle to get to this point, where the winxp boxes would actually log onto the samba server.

Its just the logon scripts now.

I have tried chown ing the relevant users .bat file so it os owned by the actual user and not root.

I have tried various registry entries but none worked.

At logon, for some reason, the xp box just will not even look at the logon script.

when logging on as the same user on a 98 machine, logon script works fine.

im well and truly stuck.

any thoughts??

Thanks in advance

Nathan
 
Old 10-21-2003, 04:28 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Its good to see you added it to the password files - most people miss that.

Did you get any error messages when you added the P machine to the domain?

Like I asked before -
Is it XP home or XP pro?
 
Old 10-21-2003, 05:55 PM   #5
ndprichardson
LQ Newbie
 
Registered: Oct 2003
Posts: 7

Original Poster
Rep: Reputation: 0
I am using only xp pro

When adding the machine accounts to the domain, I recieved no error messages.

I did initially, but after overcoming alll the various problems (passwd, smbpasswd, smbusers, reg entries client side etc etc) I can freely join machines to the domain with no errors.

They all logon and authenticate to the domain perfectly, and once in, if I copy the batch file for the logon script to the xp box locally and run it from , say , the desktop, it will map al my drives ok, so I dont think it is a prob with the batch files themselves.

I have checked and checked again the smb.conf file, and all seems to be ok (works for 98 boxes)



Nathan
 
Old 10-23-2003, 01:22 PM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
When you login to XP are you selecting the domain from the drop down list and not the local computer?
 
Old 10-23-2003, 03:46 PM   #7
ndprichardson
LQ Newbie
 
Registered: Oct 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Yup

And in the Samba log, it shows as the PC successfully loging in.

One thing I have noticed today is that when I manually run the batch file to connect the drives, any folders in them appear as read only??

I tried changing permissions in XP but it would not let me.

I also tried chmod and chown for me the user, as root and as nobody for my directory on the linux box, but no good.


Makes me think it could be something to do with permissions...................................................

Nathan
 
Old 10-23-2003, 04:02 PM   #8
ashinara
LQ Newbie
 
Registered: Oct 2003
Location: Sweden
Distribution: Debian
Posts: 6

Rep: Reputation: 0
Hi!

Below Share Defentions i found this string:
"# By default, the home directories are exported read-only. Change next
# parameter to 'yes' if you want to be able to write to them.
writable = yes"


Have you enable it?
 
Old 10-23-2003, 04:27 PM   #9
ndprichardson
LQ Newbie
 
Registered: Oct 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for your post

Unfortunatly, this is set as yes.

Using the same account on a windows 98 machine, you can write to the home directorys no problem!!



Nathan
 
Old 10-24-2003, 12:27 PM   #10
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
When you created the batch file - did you do it in windows then copy it over via samba? Sometiem the different EOLs cause problems.
 
Old 10-24-2003, 05:54 PM   #11
ndprichardson
LQ Newbie
 
Registered: Oct 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Yeah

All of the Batch files (150 in total) were created in windoze

I foundout that windoze only likes to lee windows format batch files!!

They all work no probs in 98!

After a long day at work looking into it (and now a long night of beer) I have a feeling its windoze side that is causing the prob!!

what am I to do?

It is an acive server, we now have 10 users on XP, 10 more on monday that cant map drives Nooooooooooooooooo!

Regards

Nathan
 
Old 10-24-2003, 06:32 PM   #12
dlucas10
LQ Newbie
 
Registered: Aug 2001
Posts: 18

Rep: Reputation: 0
Stupid question but I'm going to ask it anyways....

do you have this line in you smb.conf file

logon script = %U.bat <--- that would execute dlucas10.bat script
 
Old 10-25-2003, 02:38 AM   #13
ndprichardson
LQ Newbie
 
Registered: Oct 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Cheers for that

But yes, it is already in there!!!

I even tried changing it to /home/netlogon/%u.bat but no dice.

Cheers

Nathan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
battstat driving me mad oookiezooo Linux - Newbie 1 04-15-2005 06:22 AM
apt-get, driving me mad? luqman Red Hat 1 03-03-2005 12:03 AM
kernel is driving me mad luqman Linux - Newbie 6 02-18-2005 05:05 AM
kernel is driving me mad luqman Red Hat 2 02-17-2005 07:00 AM
Samba driving me mad powadha Linux - Networking 4 06-10-2004 01:46 PM


All times are GMT -5. The time now is 01:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration