LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Samba frustration (http://www.linuxquestions.org/questions/linux-networking-3/samba-frustration-79971/)

debest 08-07-2003 06:45 PM

Samba frustration
 
Okay, first post to this forum, be gentle!

I'm mildly experienced with Linux standalone, but I want to get my machine communicating with my wife's ThinkPad.

They are connected via WiFi/switch/router (Linksys BEFW11S4), both machines are able to PING each other just fine.

The desktop (RedHat 9) is able to mount shares from the ThinkPad (Windows 98SE) just fine with the "smbmount" command. I was able to see the shared directories from her laptop just fine. Cool!

The other direction, however, is another story. I cannot get "Network Neighbourhood" on the ThinkPad to see any computer other than itself.

My smb.conf file:
---
[global]
netbios name = Bunny
workgroup = MYGROUP
security = user
encrypt passwords = yes

[public]
path = /tmp
read only = no
---

My Windows settings
---
Computer Name: ThinkPad
Workgroup: MYGROUP
---

I went to samba.org, and looked through all the linked documents. One that seemed to fit what I was doing was a PDF document from SAM's "Teach yourself SAMBA in 24 hours" (wanted to put a URL here, forum wouldn't let me. See documenation at samba dot org) I went through this Troubleshooting guide. Everything went fine through "Level one" (TCP/IP connectivity, matching network masks and broadcast addresses, testparm on smb.conf) and "Level two" (local server and client software), with one exception: it asked (on page 222) to verify the "broadcast address" of the Win98 machine using winipcfg. I did not see anything on the winipcfg utility that specified this. The document claimed it should be 192.168.1.255 (as it was on my Linux box).

My experience falls down on "Level three" (Remote access to shares). It says (on page 228) to run:

$ nmblookup -B 192.168.1.255 [hostname]

and the result should be:

querying [hostname] on 192.168.1.255
192.168.1.[add] [hostname]<00>

Instead, I get:

querying [hostname] on 192.168.1.255
name_query failed to find name [hostname]

for both the desktop ('Bunny") and the laptop ('ThinkPad")

The document had this to say:
"If all has gone well to this point, this test should seldom fail. However, if either step does result in an error, verify that the broadcast address on each client is set to the same value. You should also check for any *interfaces* or *bind interface only* settings that would prevent the Samba host from responding to queries arriving from this particular subnet."

As I stated before, I don't know how to verify the broadcast address on the Windows box. And the second suggestion is Greek, what are they talking about?

Anyone want to point to salvation, here?

DocKarl 08-07-2003 07:50 PM

OK...

Try (in this order)..

iptables -F
service network restart
service samba restart

let me know if that works.

Doc

debest 08-07-2003 10:03 PM

Thanks, Doc!

I had stopped and restarted Samba a number of times (a correction for you (on RedHat, anyways): the third command should have been:

"service smb restart"

I think it was the networt restart that fixed things.

By the way, the command "iptables -F" does a "flush" of all the chains of the firewall (according to the man page). What is the implication of this? Is my firewall down now? Will rebooting be necessary?

Thanks, again.

DocKarl 08-07-2003 10:16 PM

Of course you are right - service smb restart !!

OK, with regards to iptables -F, the default firewall value for RH9 when you initially install is "MEDIUM", I believe.

Now I am no expert on firewalls or iptables, but I know that on my installation of RH9, I could not get Samba to work (problem was exactly as you described) because my firewall rules were not allowing my windows machine to access the linux machine.

Previously with RH8, I could not even get samba to work in my LAN if I set the firewall to off during installation (had to use iptables -F at each boot). This does not seem to be the case with RH9 - if on initial installation you set firewall to 'none' Samba will work ok.

Since I have a wireless router, that acts as a strong firewall for my system, I have no real worries with turning the firewall off (as achieved by iptables -F). This will remain the case until you next restart linux, after which the normal rules will apply.

There is a fairly in depth discussion of iptables at the following URL.

http://www.linuxguruz.org/iptables/h...les-HOWTO.html

All the best, let me know how you go,

Doc.

debest 08-09-2003 12:26 AM

Doc, since you gave me the hint that iptables was the problem, check out this earlier discussion on LQ.org..

http://www.linuxquestions.org/questions/history/68699

Post #7 (born4linux) nailed the way to keep iptables up with RH's odd /etc/sysconfig/iptables file, but open up the hole required for Samba.

Oh, I suppose I could go your way and just rely on the Linksys, but I just can't help thinking that iptables does a better job (no proof, just common sense since tons of experts have examined iptables' code, and noone outside of Linksys has seen theirs). I suppose that two firewalls can't be worse than one.

Thanks, again, for your hint. I hope I'll be a contributor soon.

DocKarl 08-09-2003 12:29 AM

Thanks Debest - great to be of mutual help! I had pretty much given up on using IPTABLES!

All the best,

Matt


All times are GMT -5. The time now is 08:54 AM.