LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Samba doesn't work with users (http://www.linuxquestions.org/questions/linux-networking-3/samba-doesnt-work-with-users-594478/)

vega2k 10-25-2007 08:10 AM

Samba doesn't work with users
 
Hello, I have tried to configure samba but I get this error "session setup failed: NT_STATUS_LOGON_FAILURE" when I try to connect to the server then I have "security=user" option on but then I set "security=share" I can connect to the server but only public folders.
I have added the user I try to logon to in the smb user/password file and added the user to the main Unix system.
I hope someone can help me with this because it's the first time I'm setting up Linux almost myself. ^.~
My system is running, Ubuntu 7.10.

smb.conf
Code:

[global]
    # General server settings
    netbios name = server
    server string =
    workgroup = homenetwork.com
;    wins support = yes
    dns proxy = no

    panic action = /usr/share/samba/panic-action %d
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 1

;    security = share
    security = user
    username map = /etc/samba/smbusers
    encrypt passwords = true
    passdb backend = tdbsam
    obey pam restrictions = yes
    invalid users = root

;  unix password sync = no
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *passwd:*password\supdated\ssuccessfully$

    announce version = 5.0
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192

[shared]
    comment = winshare
    path = /samba/
    public = yes
    writable = yes
    public = yes
    writable = yes
    public = yes
    writable = yes
    valid users = vega2k
    create mask = 0744
    directory mask = 0755
    admin users = admin
    force user = nobody
    force group = nogroup


DiBosco 10-26-2007 05:10 AM

When you say you've added the user, have you added both the Linux account user on the server and the smbuser too? You have to do something like:

smbpasswd -a username

Where username is the name of the person for whom you have set-up a Linux account for on the server.

Please double check that syntax if it's not working!


All times are GMT -5. The time now is 07:31 PM.