LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 04-27-2011, 12:00 PM   #1
stefane321
Member
 
Registered: May 2004
Location: Canada
Distribution: SUSE 9.3
Posts: 132

Rep: Reputation: 15
Samba configuration problem


Hello,

i need your help to make work my samba server

my server is a opensuse 11.4

my work station is a windows 7

i want to acces my linux srv/www/htdocs/ directory from my windows 7

so i join you print screen of my samba panel

it appear to be not working if i try toi connect from windows

http://www.bizhosting411.biz/snapshot1.png


http://www.bizhosting411.biz/snapshot2.png

thanks
 
Old 04-27-2011, 12:04 PM   #2
HasC
Member
 
Registered: Oct 2009
Location: South America - Paraguay
Distribution: Debian 5 - Slackware 13.1 - Arch - Some others linuxes/*BSDs through KVM and Xen
Posts: 329

Rep: Reputation: 55
can you post your smb.conf file? the errors you got on win 7? some samba logs?
 
Old 04-27-2011, 01:38 PM   #3
stefane321
Member
 
Registered: May 2004
Location: Canada
Distribution: SUSE 9.3
Posts: 132

Original Poster
Rep: Reputation: 15
The problem in windows is when i try to add the network connection.

Look this print screnn (sorry, its in french)

http://www.bizhosting411.biz/smb.jpg


Here is my smb.conf file:

Code:
# Samba config file created using SWAT
# from UNKNOWN (127.0.0.1)
# Date: 2011/04/27 11:41:14

[global]
	netbios name = WORKGROUP
	map to guest = Bad User
	printcap name = cups
	add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
	logon path = \\%L\profiles\.msprofile
	logon drive = P:
	logon home = \\%L\%U\.9xprofile
	domain logons = Yes
	os level = 65
	preferred master = Yes
	domain master = Yes
	usershare allow guests = Yes
	hosts allow = 192.168.1.0
	cups options = raw

[homes]
	comment = Home Directories
	valid users = %S, %D%w%S
	read only = No
	inherit acls = Yes
	browseable = No

[profiles]
	comment = Network Profiles Service
	path = %H
	read only = No
	create mask = 0600
	directory mask = 0700
	store dos attributes = Yes

[users]
	comment = All users
	path = /home
	read only = No
	inherit acls = Yes
	veto files = /aquota.user/groups/shares/

[groups]
	comment = All groups
	path = /home/groups
	read only = No
	inherit acls = Yes

[printers]
	comment = All Printers
	path = /var/tmp
	create mask = 0600
	printable = Yes
	browseable = No

[print$]
	comment = Printer Drivers
	path = /var/lib/samba/drivers
	write list = @ntadmin, root
	force group = ntadmin
	create mask = 0664
	directory mask = 0775

[netlogon]
	comment = Network Logon Service
	path = /var/lib/samba/netlogon
	write list = root

[srv/www/htdocs/]
	available = No
 
Old 04-28-2011, 04:46 PM   #4
stefane321
Member
 
Registered: May 2004
Location: Canada
Distribution: SUSE 9.3
Posts: 132

Original Poster
Rep: Reputation: 15
I need help please!!

smbclient -L localhost
Code:
Enter root's password: 
Connection to localhost failed (Error NT_STATUS_CONNECTION_REFUSED)
testparm /etc/samba/smb.conf
Code:
Load smb config files from /etc/samba/smb.conf
rlimit_max: rlimit_max (1024) below minimum Windows limit (16384)
Processing section "[homes]"
Processing section "[profiles]"
Processing section "[users]"
Processing section "[groups]"
Processing section "[printers]"
Processing section "[print$]"
Processing section "[MonServeurWeb]"
Loaded services file OK.
WARNING: You have some share names that are longer than 12 characters.
These may not be accessible to some older clients.
(Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
        workgroup = MSHOME
        netbios name = OPENSUSE
        map to guest = Bad User
        passdb backend = smbpasswd
        printcap name = cups
        add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
        logon path = \\%L\profiles\.msprofile
        logon drive = P:
        logon home = \\%L\%U\.9xprofile
        domain master = No
        usershare allow guests = Yes
        hosts allow = 192.168.1.0
        cups options = raw

[homes]
        comment = Home Directories
        valid users = %S, %D%w%S
        read only = No
        inherit acls = Yes
        browseable = No

[profiles]
        comment = Network Profiles Service
        path = %H
        read only = No
        create mask = 0600
        directory mask = 0700
        store dos attributes = Yes

[users]
        comment = All users
        path = /home
        read only = No
        inherit acls = Yes
        veto files = /aquota.user/groups/shares/

[groups]
        comment = All groups
        path = /home/groups
        read only = No
        inherit acls = Yes

[printers]
        comment = All Printers
        path = /var/tmp
        create mask = 0600
        printable = Yes
        browseable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin, root
        force group = ntadmin
        create mask = 0664
        directory mask = 0775

[MonServeurWeb]
        comment = "Commentaire"
        path = /srv/www/htdocs"
        read only = No
        create mask = 0775
        guest ok = Yes
 
  


Reply

Tags
samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem in samba configuration mehnaz Linux - Newbie 19 07-28-2009 11:39 PM
Problem in Samba Configuration Ahmad Gurchani Linux - Networking 2 01-01-2005 08:48 AM
Samba Configuration problem montylee Linux - Networking 12 11-24-2004 05:57 AM
samba configuration problem (?) schbond Linux - Networking 3 06-13-2003 08:38 PM
samba configuration problem keirobyn Linux - Networking 3 03-19-2002 12:40 AM


All times are GMT -5. The time now is 12:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration