LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-02-2007, 01:27 PM   #1
gerhardbartsch
LQ Newbie
 
Registered: Aug 2003
Location: New Jersey
Posts: 19

Rep: Reputation: 0
SAMBA Configuration Issue: "Network path was not found" on client


Client

Ok,

I've configured Samba on my Fedora Core 6 system to share a few group folders under /home/groups/.

This /home partition is a separate mount that located on a SAN.

Using the system-config-samba GUI I've created two samba shares that reflect the two folders under /home/groups that I want to share. They are /home/groups/group312 and /home/group/group320.

I then told samba that the workgroup should be lfs1 (they are not the same on the client and the samba server) and that the security settings should be:
Authentication Mode = User
Encrypt Passwords = Yes
Guest Account = eeguser

I then created a WIndows User that maps to eeguser as well.

On the Linux system, the group folders are owned by 'eeguser' and the group ownership is also 'eeguser'

Oddly, when I browse the lfs1 linux box from the network, I see the two group folders, and then I also see eeguser's /home directory (/home/eeguser).

I can not access the contents of the two group folders, but I can access the contents of eeguser's home directory.

When I attempt to browse into either group312 or group320 (the samba shares) I get an error on the Windows XP client:

"Network path was not found."

When I check the samba log for that machine, I get multiple instances of:

[2007/04/02 13:36:40, 0] smbd/service.c:make_connection_snum(920)
'/home/groups/group320' does not exist or permission denied when connecting to [group320] Error was Permission denied

Oh, and I'm running the 3.0.24-3.fc6 version of samba.

What in the world is the issue?

Gerhard

PS:

[root@lfs1 samba]# testparm /etc/samba/smb.conf
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[group312]"
Processing section "[group320]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
workgroup = LFS1
server string = Lab File Server 1
guest account = eeguser
username map = /etc/samba/smbusers
log file = /var/log/samba/%m.log
max log size = 50
dns proxy = No
guest ok = Yes
hosts allow = 192.168.14., 127.0.0.1
cups options = raw

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /usr/spool/samba
printable = Yes
browseable = No

[group312]
comment = Group 312 Share
path = /home/groups/group312
read only = No

group320]
comment = Group 320 Share
path = /home/groups/group320
read only = No
[root@lfs1 samba]#

Last edited by gerhardbartsch; 04-02-2007 at 07:00 PM.
 
Old 04-02-2007, 08:00 PM   #2
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Some things I can think of:

Check that your Samba user account is part of the eeguser group. This is one reason why permission is denied - group312 and group320 are owned by user eeguser and group eeguser.

In Windows, map to them with ip addresses instead of their NETBIOS name.

Code:
net use z: \\192.168.1.2\group312 /user eeguser
add the guest ok for group312 and group320
Code:
[group312]
comment = Group 312 Share
path = /home/groups/group312
read only = No
guest ok = yes

[group320]
comment = Group 320 Share
path = /home/groups/group320
read only = No
guest ok = yes
Maybe change the security = share ???

Try those and report back. Remember to restart the samba service
Code:
service samba restart

Last edited by Micro420; 04-02-2007 at 08:06 PM.
 
Old 04-02-2007, 08:51 PM   #3
gerhardbartsch
LQ Newbie
 
Registered: Aug 2003
Location: New Jersey
Posts: 19

Original Poster
Rep: Reputation: 0
wilco

Ok, I'll try that in the morning and give you a response...

Curiously, with the 'eeguser' account I created both a user and a group. During testing I changed the owner to eeguser and the group ownership to the eeguser group. I've also got the guest user set up as eeguser... would any of this be part of my problem?

I guess where I'm getting a little confused is with the user accounts.

eeguser belongs to the group312 and group320 groups.

Those linux groups have the premissions to access the two group folders, since those two group own the group premissions of each share (as read/write under Linux)...

I've created a user map for eeguser under samba, and it reflects one of the windows accounts on one of the stand alone windows client machines.

If samba creates a map where windows account X maps to eeguser, why wouldn't I be able to browse the samba shares and then access them for R/W?

Also, does the account used for guests (the guest account) have to be different than the eeguser account(i.e. be unique)?

Thanks for the help in general!

Sincerely,

Gerhard
 
Old 04-03-2007, 01:07 AM   #4
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
I think one thing you are not realizing is that you also need a samba user account. Since your global setting is SECURITY = USER, that means that you need a Linux account on your system which you already have. Then on top of that, you need to create a samba account and this is what you need when Windows asks you for a username/password.

To create a samba user account eeguser, type as root
Code:
 smbpasswd -a eeguser
If you don't have a samba user account, Windows will not recognize your eeguser Linux account. It wants the samba user account so it can map it. In fact, after you created this samba user account and put a password on it, it is advisable to LOCK the eeguser Linux user account. Samba will still work and Windows will be able to map the samba drive, however, this eeguser cannot log into the LInux box.

Last edited by Micro420; 04-03-2007 at 01:11 AM.
 
Old 04-03-2007, 02:40 PM   #5
gerhardbartsch
LQ Newbie
 
Registered: Aug 2003
Location: New Jersey
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Micro420
I think one thing you are not realizing is that you also need a samba user account. Since your global setting is SECURITY = USER, that means that you need a Linux account on your system which you already have. Then on top of that, you need to create a samba account and this is what you need when Windows asks you for a username/password.

To create a samba user account eeguser, type as root
Code:
 smbpasswd -a eeguser
If you don't have a samba user account, Windows will not recognize your eeguser Linux account. It wants the samba user account so it can map it. In fact, after you created this samba user account and put a password on it, it is advisable to LOCK the eeguser Linux user account. Samba will still work and Windows will be able to map the samba drive, however, this eeguser cannot log into the LInux box.
Ok, so here is what happened:

I tried using the 'eeguser' rather then the windows account that is supposed to map to the Linux account (eeguser)... and suddenly everything works.

Odd...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba configuration error when accessing NTFS files " Network path not found" leo_ieo Linux - General 2 10-09-2006 08:55 PM
"Network path not found " zameer_india Linux - Networking 5 10-01-2004 04:47 AM
Firestarter "No DHCP client configuration found" Locura Linux - General 1 12-10-2003 10:05 AM
"Mars DOMAIN" - Network Path not found. ikw38 Linux - Networking 0 07-09-2003 06:20 PM
Samba & Win2K pro, "network path not found" RedHat123 Linux - Networking 8 02-05-2002 09:57 PM


All times are GMT -5. The time now is 03:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration