LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-11-2009, 10:21 AM   #1
tulsi
Member
 
Registered: Aug 2009
Location: Chennai
Posts: 47

Rep: Reputation: 15
Question Samba config


Hi


my system host windows xp and also installed linux through VMware. how to
sharing files windows and linux .
In windows I tried run command in my IP address and display the network path was not found.
in my centos has no /etc/ini.d/smb file. but only file has /etc/samba/smb.conf . please help me.
also in /var/log/samba has no files.

Last edited by tulsi; 09-12-2009 at 01:04 PM.
 
Old 09-11-2009, 06:54 PM   #2
adamben
Member
 
Registered: Feb 2007
Distribution: slackware,gentoo,ubuntu
Posts: 50

Rep: Reputation: 17
Check to make sure smbd is listening:
sudo lsof -Pi:139

Yes?

Check the logs under /var/log/samba :
You should see something like log.<hostname or ip of your windows xp box>

You'll probably need to be root to view them - so "sudo less <log>" or "sudo tail -40 <log>" should do

If you don't see any logs indicating that there was a connection - make sure your Windows box has the firewall open.

Still issues? Check linux firewall - probably iptables -L will do it for you... if nothing, Post your smb.conf file(ditching the comments would be helpful).

PS:
you can try a telnet test as well - see if you can reach the service from windows - <window key>+R -> cmd.

If you get something like this:
telnet <yourlinuxbox> 139

Connected to yourlinuxbox.
Escape character is '^]'.
^]

its likely not a firewall issue.
(you can close the window)
 
Old 09-11-2009, 07:07 PM   #3
adamben
Member
 
Registered: Feb 2007
Distribution: slackware,gentoo,ubuntu
Posts: 50

Rep: Reputation: 17
btw - if the problem is the windows firewall - from the land of oz...

http://www.microsoft.com/windowsxp/u...nfirewall.mspx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie: Samba under Ubuntu - default config locations don't match samba.org mdutch Ubuntu 0 08-28-2009 02:38 PM
Samba config won't do what I want havoc3d Linux - Server 3 04-06-2009 10:34 PM
Samba "system-config-samba" not displaying users in Gnome GUI - CentOS 5.0 bskrakes Linux - Server 6 03-01-2009 11:59 AM
Webmin cannot handle Samba config files that use the config or include directives allelopath Linux - Networking 3 01-18-2005 09:36 AM
possible samba config problem or network config issue? rruffin Linux - Networking 3 06-03-2003 04:04 PM


All times are GMT -5. The time now is 01:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration